From 4392aa7a89f6a9d458e7e148d0b69674984d5280 Mon Sep 17 00:00:00 2001
From: Mike Frysinger <vapier@gentoo.org>
Date: Sat, 16 Oct 2004 20:17:18 +0000
Subject: Fix stupid dependency on sys-libs/libtermcap-compat (i.e. remove it)
 #64212.

---
 app-editors/teco/ChangeLog           |  5 ++++-
 app-editors/teco/Manifest            | 12 ++++++------
 app-editors/teco/teco-1.00-r2.ebuild | 25 +++++++++++++------------
 3 files changed, 23 insertions(+), 19 deletions(-)

(limited to 'app-editors/teco')

diff --git a/app-editors/teco/ChangeLog b/app-editors/teco/ChangeLog
index 9fae95892b61..f70f2ba0d33a 100644
--- a/app-editors/teco/ChangeLog
+++ b/app-editors/teco/ChangeLog
@@ -1,6 +1,9 @@
 # ChangeLog for app-editors/teco
 # Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/teco/ChangeLog,v 1.8 2004/06/24 22:02:00 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/teco/ChangeLog,v 1.9 2004/10/16 20:17:18 vapier Exp $
+
+  16 Oct 2004; Mike Frysinger <vapier@gentoo.org> teco-1.00-r2.ebuild:
+  Fix stupid dependency on sys-libs/libtermcap-compat (i.e. remove it) #64212.
 
 *teco-1.00-r2 (08 Sep 2003)
 
diff --git a/app-editors/teco/Manifest b/app-editors/teco/Manifest
index 8bcab3718efc..363e3853decb 100644
--- a/app-editors/teco/Manifest
+++ b/app-editors/teco/Manifest
@@ -1,14 +1,14 @@
 -----BEGIN PGP SIGNED MESSAGE-----
 Hash: SHA1
 
-MD5 3e0d8463bf44efdb555a275b280cb7de ChangeLog 1093
+MD5 dd4231cbadf17a5c6572a4f2f0820068 ChangeLog 1242
 MD5 7510851e62ed9c830d82a0e6d068052a metadata.xml 1324
-MD5 469f90bb947ba0e475f3262999734cc2 teco-1.00-r2.ebuild 1330
+MD5 f4c299dc3bb579e1188afcc7cc4a4950 teco-1.00-r2.ebuild 1328
 MD5 cbaebc6d51eb71e4aaaea9737b9d88f6 files/digest-teco-1.00-r2 282
 -----BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.8 (GNU/Linux)
+Version: GnuPG v1.9.10 (GNU/Linux)
 
-iD8DBQFA30gDHTu7gpaalycRAhPWAKCD8Dip3oLFnx6CI6HLsaUfzSJQ4gCg1OKw
-L+FE8/mHPWllvIb5dM2cIG4=
-=p8ET
+iD8DBQFBcYHaHTu7gpaalycRAj99AJ43Ze7wAuw9fOLHpSS5tJDrxUy4jwCcCPJT
+sJJk/keCwVn5H8IorLAbb48=
+=J5oY
 -----END PGP SIGNATURE-----
diff --git a/app-editors/teco/teco-1.00-r2.ebuild b/app-editors/teco/teco-1.00-r2.ebuild
index ff29ed19eec4..a6ff9ecf91f3 100644
--- a/app-editors/teco/teco-1.00-r2.ebuild
+++ b/app-editors/teco/teco-1.00-r2.ebuild
@@ -1,6 +1,6 @@
 # Copyright 1999-2004 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/teco/teco-1.00-r2.ebuild,v 1.4 2004/06/27 22:19:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/teco/teco-1.00-r2.ebuild,v 1.5 2004/10/16 20:17:18 vapier Exp $
 
 inherit ccc
 
@@ -17,29 +17,30 @@ SLOT="0"
 KEYWORDS="alpha x86"
 IUSE="doc"
 
-DEPEND="virtual/libc
-	sys-libs/libtermcap-compat
+RDEPEND="virtual/libc"
+DEPEND="${DEPEND}
 	>=sys-apps/sed-4"
-RDEPEND="virtual/libc
-	sys-libs/libtermcap-compat"
 PROVIDE="virtual/editor"
 
 S=${WORKDIR}
 
-src_compile() {
+src_unpack() {
+	unpack ${A}
+	cd ${S}
 	# Remove hardcoded compiler and CFLAGS
-	sed -i 's/CFLAGS = -O//' Makefile
+	sed -i \
+		-e 's/CFLAGS = -O//' \
+		-e 's:-ltermcap:-lncurses:' \
+		Makefile
 	replace-cc-hardcode
+}
 
+src_compile() {
 	emake || die "compilation failed"
-
-	echo
-	size te; ls -l te
-	echo
 }
 
 src_install() {
-	dobin te
+	dobin te || die
 	dodoc sample.tecorc sample.tecorc2 READ.ME MANIFEST
 	use doc && dodoc tecolore.txt tech.txt teco.doc tecoprog.doc
 	doman te.1
-- 
cgit v1.2.3-65-gdbad