summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/colo/ChangeLog8
-rw-r--r--sys-boot/colo/Manifest4
-rw-r--r--sys-boot/colo/colo-1.22.ebuild44
3 files changed, 41 insertions, 15 deletions
diff --git a/sys-boot/colo/ChangeLog b/sys-boot/colo/ChangeLog
index 4f52ed41a4bb..4cd6a5e57d00 100644
--- a/sys-boot/colo/ChangeLog
+++ b/sys-boot/colo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/colo
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/colo/ChangeLog,v 1.20 2007/09/19 04:14:12 redhatter Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/colo/ChangeLog,v 1.21 2009/02/25 00:32:25 kumba Exp $
+
+ 25 Feb 2009; Joshua Kinard <kumba@gentoo.org> colo-1.22.ebuild:
+ Make sys-boot/colo cross-compiler safe, dodge gcc-4.3.x stricter checks,
+ and fixup the ebuild a little.
19 Sep 2007; Stuart Longland <redhatter@gentoo.org> -colo-1.19.ebuild,
-colo-1.21.ebuild:
diff --git a/sys-boot/colo/Manifest b/sys-boot/colo/Manifest
index 7f30215776f4..5fde9d73da89 100644
--- a/sys-boot/colo/Manifest
+++ b/sys-boot/colo/Manifest
@@ -2,6 +2,6 @@ AUX default.colo 840 RMD160 4045d90f4aba0e1ed7c3fde4187893ec97b52657 SHA1 5aafba
AUX menu.colo 1624 RMD160 0d5e70134e70ce483f9c8ddfdabef9e7a93af62b SHA1 4bcd7f7e50f16cb739a778ed8890cd6ef263e1b2 SHA256 f74c91aff1c1d598dfc69db26556dce774affecc0ea1d8c821320a172c8ead1e
AUX simple.colo 648 RMD160 164e3ff5b9640936f5335be2fc0ba7bb53330c1a SHA1 0113e526d07e63096d0d1cffecd92776e5568574 SHA256 5f3c4bd46bb7633cf0f4012fd4cfb72af575ed00ac1000d0c8bd2026748abaa5
DIST colo-1.22.tar.gz 257968 RMD160 4a07cfe5050f395a8eb7c7d5fe71748877377084 SHA1 079e0409f662be9cac8b645c972f013f3f17af92 SHA256 ec51237286be9581d6be1ff3e43c9a654aaf4e1414d1bb194f02032e57119163
-EBUILD colo-1.22.ebuild 3477 RMD160 7fdbfd29514fc96f22d1baba18ffb763b4fc6b22 SHA1 9aac4de02a56fb85af81ac26c7799450c1680fba SHA256 c697e1210d9682902f51fbe44e6a3b0bb08ec662c0659e67b1277810e80fe005
-MISC ChangeLog 3546 RMD160 d78ea3e3ad2acc1b1445df4bb0ed038e3cd3b198 SHA1 63c0987db488514c0c560f02e849e85c125888ed SHA256 bb09fafb5b54af2fbd21fde450e6778890f7fe551f8e07ee34786e1a99baba12
+EBUILD colo-1.22.ebuild 4138 RMD160 a76a4222e11a037849356d5d5cc516906d237e3e SHA1 e031b57743e3b3363907e37aa8df02a5e59782aa SHA256 c342e4412da3171c2dab9c2bf65bacde13f97f23813b56b47bebf3c3c4bce686
+MISC ChangeLog 3717 RMD160 e0969bc5886890f4ab2feccdf59fb640052216d8 SHA1 69b7219493fa24522bbe27daa38c600028e56bc0 SHA256 864638ed5b96d8389a5ccd6a252c134df8a46efd7de2ee83a4ae8f6496a1af45
MISC metadata.xml 364 RMD160 b01d8ab7f62c5578f13393d993608f226e1161fc SHA1 8492db2ed14bcbb4fc6966c15b6dcfb00d9eeb3a SHA256 0c3846d04ec7c0175ee19756c4e1bff0f13a323f6f19a8b034b0dd51baacb437
diff --git a/sys-boot/colo/colo-1.22.ebuild b/sys-boot/colo/colo-1.22.ebuild
index cf657e4eccb4..d16d036f5b12 100644
--- a/sys-boot/colo/colo-1.22.ebuild
+++ b/sys-boot/colo/colo-1.22.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/colo/colo-1.22.ebuild,v 1.3 2007/07/15 02:25:03 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/colo/colo-1.22.ebuild,v 1.4 2009/02/25 00:32:25 kumba Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="CObalt LOader - Modern bootloader for Cobalt MIPS machines"
HOMEPAGE="http://www.colonel-panic.org/cobalt-mips/"
SRC_URI="http://www.colonel-panic.org/cobalt-mips/colo/colo-${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="-* mips"
+KEYWORDS="-* ~mips"
IUSE=""
DEPEND=""
RESTRICT="strip"
@@ -33,20 +33,42 @@ src_unpack() {
src_compile() {
echo -e ""
einfo ">>> Building the CoLo Bootloader ..."
- cd ${S}
+
+ # Remove -Werror from CFLAGS
+ # gcc-4.3.x is more strict; We'll go back and fix later
+ cd "${S}"
+ for x in $(grep -rl "Werror" "${S}"/*); do
+ sed -i -e 's/\-Werror//g' "${x}"
+ done
+
+ # Keep elf2rfx from automatically building via the Makefile
+ sed -i -e 's/tools\/elf2rfx //' "${S}"/Makefile
+
+ # Build it first with BUILD_CC in case of cross-compiles
+ cd "${S}"/tools/elf2rfx
+ make CC="$(tc-getBUILD_CC)" || die
+
+ # Build the rest
+ cd "${S}"
make clean || die # emake breaks the build
- make || die
+ make CC="$(tc-getCC)" OBJCOPY="$(tc-getOBJCOPY)" \
+ STRIP="$(tc-getSTRIP)" || die
+
+ # Now rebuild elf2rfx again with CC so it can be installed
+ cd "${S}"/tools/elf2rfx
+ make clean || die
+ make CC="$(tc-getCC)" || die
}
src_install() {
# bins
- cd ${S}
+ cd "${S}"
dodir /usr/lib/colo
- cp binaries/colo-chain.elf ${D}/usr/lib/colo
- cp binaries/colo-rom-image.bin ${D}/usr/lib/colo
+ cp binaries/colo-chain.elf "${D}"/usr/lib/colo
+ cp binaries/colo-rom-image.bin "${D}"/usr/lib/colo
# docs
- dodoc CHANGES COPYING INSTALL README README.{restore,shell,netcon} tools/README.tools TODO
+ dodoc CHANGES INSTALL README README.{restore,shell,netcon} tools/README.tools TODO
# all tools except lcdtools (see below)
local tool
@@ -71,7 +93,7 @@ src_install() {
# bootscripts
dodir /usr/lib/colo/scripts
- cp ${FILESDIR}/*.colo ${D}/usr/lib/colo/scripts
+ cp "${FILESDIR}"/*.colo "${D}"/usr/lib/colo/scripts
}
pkg_postinst() {