summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/gst-python/gst-python-0.10.17.ebuild')
-rw-r--r--dev-python/gst-python/gst-python-0.10.17.ebuild17
1 files changed, 13 insertions, 4 deletions
diff --git a/dev-python/gst-python/gst-python-0.10.17.ebuild b/dev-python/gst-python/gst-python-0.10.17.ebuild
index 1ca843f1579b..21beffb925b9 100644
--- a/dev-python/gst-python/gst-python-0.10.17.ebuild
+++ b/dev-python/gst-python/gst-python-0.10.17.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/gst-python-0.10.17.ebuild,v 1.1 2009/11/16 02:11:21 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/gst-python-0.10.17.ebuild,v 1.2 2010/03/10 05:31:02 leio Exp $
EAPI=2
NEED_PYTHON=2.4
@@ -13,14 +13,18 @@ SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
LICENSE="LGPL-2"
SLOT="0.10"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="examples"
+IUSE="examples test"
RDEPEND="|| ( >=dev-python/pygobject-2.11.2 >=dev-python/pygtk-2.6.3 )
>=media-libs/gstreamer-0.10.25
>=media-libs/gst-plugins-base-0.10.25
dev-libs/libxml2"
DEPEND="${RDEPEND}
- dev-util/pkgconfig"
+ dev-util/pkgconfig
+ test? (
+ media-plugins/gst-plugins-ogg
+ media-plugins/gst-plugins-vorbis
+ )" # tests a "audiotestsrc ! vorbisenc ! oggmux ! fakesink" pipeline
src_prepare() {
epatch "${FILESDIR}"/${PN}-0.10.9-lazy.patch
@@ -39,6 +43,11 @@ src_install() {
fi
}
+src_test() {
+ export LC_ALL="C"
+ emake check || die "make check failed"
+}
+
pkg_postinst() {
python_version
python_need_rebuild