summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/eaccelerator/ChangeLog6
-rw-r--r--dev-php/eaccelerator/Manifest16
-rw-r--r--dev-php/eaccelerator/eaccelerator-0.9.2a.ebuild90
-rw-r--r--dev-php/eaccelerator/files/digest-eaccelerator-0.9.2a1
4 files changed, 17 insertions, 96 deletions
diff --git a/dev-php/eaccelerator/ChangeLog b/dev-php/eaccelerator/ChangeLog
index 2bbdf7fab86a..e8af9dc873a5 100644
--- a/dev-php/eaccelerator/ChangeLog
+++ b/dev-php/eaccelerator/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-php/eaccelerator
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/eaccelerator/ChangeLog,v 1.11 2005/06/12 17:24:29 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/eaccelerator/ChangeLog,v 1.12 2005/06/17 08:10:03 sebastian Exp $
+
+ 17 Jun 2005; Sebastian Bergmann <sebastian@gentoo.org>
+ -eaccelerator-0.9.2a.ebuild:
+ Remove old version.
12 Jun 2005; Jason Wever <weeve@gentoo.org> eaccelerator-0.9.3.ebuild:
Stable on SPARC.
diff --git a/dev-php/eaccelerator/Manifest b/dev-php/eaccelerator/Manifest
index a9f61db9c3f0..c26f5b7a5e22 100644
--- a/dev-php/eaccelerator/Manifest
+++ b/dev-php/eaccelerator/Manifest
@@ -1,6 +1,14 @@
-MD5 628c82d3bfd23ed464700f1200890161 ChangeLog 1725
-MD5 bdcd6b09a03802d15b80766ec6a52fd3 eaccelerator-0.9.2a.ebuild 3167
-MD5 34b376f52ca199fffb4e52b83169574a metadata.xml 156
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 46c0372dd67839bef90c4c4604e629a3 eaccelerator-0.9.3.ebuild 3556
-MD5 3d30ceed6d4367d313daa9c6ec007e8f files/digest-eaccelerator-0.9.2a 71
+MD5 0bba1671c3a976648498685b08e23631 ChangeLog 1840
+MD5 34b376f52ca199fffb4e52b83169574a metadata.xml 156
MD5 543f0982cc0ffa866a7b03985dc77edb files/digest-eaccelerator-0.9.3 70
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFCsoVvaGfFFLhbXWkRArSAAJ4oS4dQdoNyxm5cLb6LJcgXoe8kCQCeK5EQ
+ZSTUkFcK6RpDfxfyXxtjf1w=
+=TTX1
+-----END PGP SIGNATURE-----
diff --git a/dev-php/eaccelerator/eaccelerator-0.9.2a.ebuild b/dev-php/eaccelerator/eaccelerator-0.9.2a.ebuild
deleted file mode 100644
index 52ca7c4df325..000000000000
--- a/dev-php/eaccelerator/eaccelerator-0.9.2a.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/eaccelerator/eaccelerator-0.9.2a.ebuild,v 1.7 2005/05/19 09:10:56 sebastian Exp $
-
-PHP_EXT_NAME="eaccelerator"
-PHP_EXT_ZENDEXT="yes"
-[ -z "${EACCELERATOR_CACHEDIR}" ] && EACCELERATOR_CACHEDIR=/var/cache/eaccelerator
-inherit php-ext-source
-
-DESCRIPTION="A PHP Accelerator & Encoder."
-HOMEPAGE="http://www.eaccelerator.net/"
-SRC_URI="mirror://sourceforge/eaccelerator/${P}.tar.gz"
-S=${WORKDIR}/eaccelerator
-IUSE="session"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 amd64 sparc"
-
-DEPEND="$DEPEND
- !dev-php/ioncube_loaders
- !dev-php/php-accelerator
- !dev-php/PECL-apc
- !dev-php/turck-mmcache"
-
-src_compile() {
- # eAccelerator does not work with Zend Thread Safety (ZTS)
- # so about if we are using Apache 2 with an MPM that would
- # require ZTS.
- if has_version '>=net-www/apache-2*'; then
- APACHE2_MPM="`/usr/sbin/apache2 -l | egrep 'worker|perchild|leader|threadpool|prefork'|cut -d. -f1|sed -e 's/^[[:space:]]*//g;s/[[:space:]]+/ /g;'`"
- case "${APACHE2_MPM}" in
- *prefork*) ;;
- *) eerror "eAccelerator does not yet work with the Apache 2 MPM in use." ; die ;;
- esac;
- fi
-
- myconf="--enable-eaccelerator=shared"
-
- if use !session; then
- myconf="${myconf} --without-eaccelerator-sessions"
- fi
-
- php-ext-source_src_compile
-}
-
-src_install() {
- php-ext-source_src_install
-
- # create cache dir if it does not exist
- #
- # settings should ensure that cached files are secure,
- # *but* this may break php-cli
- #
- # please file a bug in http://bugs.gentoo.org if this happens
- # for you
-
- keepdir ${EACCELERATOR_CACHEDIR}
- fowners root:root ${EACCELERATOR_CACHEDIR}
- fperms 1777 ${EACCELERATOR_CACHEDIR}
-
- insinto /usr/share/${PN}
- doins encoder.php eaccelerator.php eaccelerator_password.php
- dodoc AUTHORS ChangeLog COPYING NEWS README README.eLoader
-
- php-ext-base_addtoinifiles "eaccelerator.shm_size" '"16"'
- php-ext-base_addtoinifiles "eaccelerator.cache_dir" "\"${EACCELERATOR_CACHEDIR}\""
- php-ext-base_addtoinifiles "eaccelerator.enable" '"1"'
- php-ext-base_addtoinifiles "eaccelerator.optimizer" '"1"'
- php-ext-base_addtoinifiles "eaccelerator.check_mtime" '"1"'
- php-ext-base_addtoinifiles "eaccelerator.debug" '"0"'
- php-ext-base_addtoinifiles "eaccelerator.filter" '""'
- php-ext-base_addtoinifiles "eaccelerator.shm_max" '"0"'
- php-ext-base_addtoinifiles "eaccelerator.shm_ttl" '"0"'
- php-ext-base_addtoinifiles "eaccelerator.shm_prune_period" '"0"'
- php-ext-base_addtoinifiles "eaccelerator.shm_only" '"0"'
- php-ext-base_addtoinifiles "eaccelerator.compress" '"1"'
- php-ext-base_addtoinifiles "eaccelerator.compress_level" '"9"'
-}
-
-pkg_postinst () {
- einfo "You need to restart Apache to activate eAccelerator"
- einfo
- einfo 'A web interface is available to manage the eAccelerator cache.'
- einfo 'Copy /usr/share/eaccelerator/*.php to somewhere'
- einfo 'where your web server can see it.'
- einfo
- einfo 'A PHP script encoder is available to encode your PHP scripts.'
- einfo 'The encoder is available as /usr/share/eaccelerator/encoder.php'
- einfo 'The encoded file format is not yet considered stable'
-}
diff --git a/dev-php/eaccelerator/files/digest-eaccelerator-0.9.2a b/dev-php/eaccelerator/files/digest-eaccelerator-0.9.2a
deleted file mode 100644
index 6eec3000f758..000000000000
--- a/dev-php/eaccelerator/files/digest-eaccelerator-0.9.2a
+++ /dev/null
@@ -1 +0,0 @@
-MD5 e9059ebd49f14835534a1d96a97ababd eaccelerator-0.9.2a.tar.gz 115791