summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Test-Class/Test-Class-0.31.ebuild')
-rw-r--r--dev-perl/Test-Class/Test-Class-0.31.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-perl/Test-Class/Test-Class-0.31.ebuild b/dev-perl/Test-Class/Test-Class-0.31.ebuild
new file mode 100644
index 000000000000..e3ae6365e36e
--- /dev/null
+++ b/dev-perl/Test-Class/Test-Class-0.31.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Test-Class/Test-Class-0.31.ebuild,v 1.1 2008/09/15 08:32:59 tove Exp $
+
+MODULE_AUTHOR=ADIE
+inherit perl-module
+
+DESCRIPTION="Easily create test classes in an xUnit style."
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~sparc ~x86"
+IUSE="test"
+SRC_TEST="do"
+
+RDEPEND=">=virtual/perl-Storable-2
+ >=virtual/perl-Test-Simple-0.62
+ >=dev-perl/Test-Exception-0.25
+ >=dev-perl/Devel-Symdump-2.03
+ dev-lang/perl"
+DEPEND="${RDEPEND}
+ dev-perl/module-build
+ test? ( dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage )"