summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-10-06 11:43:52 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-10-06 11:43:52 +0000
commitca659fa035d99a0978ffd7af8c80a9b7f503aa36 (patch)
treef3c07590f19baaaa207e4689b4207f9566c76dd5 /xfce-extra
parentStable on amd64 wrt bug #339532 (diff)
downloadhistorical-ca659fa035d99a0978ffd7af8c80a9b7f503aa36.tar.gz
historical-ca659fa035d99a0978ffd7af8c80a9b7f503aa36.tar.bz2
historical-ca659fa035d99a0978ffd7af8c80a9b7f503aa36.zip
Initial commit.
Package-Manager: portage-2.2_rc88/cvs/Linux x86_64
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/transd/ChangeLog10
-rw-r--r--xfce-extra/transd/Manifest4
-rw-r--r--xfce-extra/transd/metadata.xml5
-rw-r--r--xfce-extra/transd/transd-0_p20101006.ebuild34
4 files changed, 53 insertions, 0 deletions
diff --git a/xfce-extra/transd/ChangeLog b/xfce-extra/transd/ChangeLog
new file mode 100644
index 000000000000..a6aa09358600
--- /dev/null
+++ b/xfce-extra/transd/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for xfce-extra/transd
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/transd/ChangeLog,v 1.1 2010/10/06 11:43:52 ssuominen Exp $
+
+*transd-0_p20101006 (06 Oct 2010)
+
+ 06 Oct 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +transd-0_p20101006.ebuild:
+ Initial commit.
+
diff --git a/xfce-extra/transd/Manifest b/xfce-extra/transd/Manifest
new file mode 100644
index 000000000000..0d5cf499a920
--- /dev/null
+++ b/xfce-extra/transd/Manifest
@@ -0,0 +1,4 @@
+DIST transd-0_p20101006.tar.bz2 87764 RMD160 2c2b85df3e66a70ed3002511b1bd50021b2ffac0 SHA1 4696dc128d816ef203317ac1b322e6a7816851a5 SHA256 53cefbeeaede5d68d2ef8a8e498f74f019ba4ba053bd2337efb34966d5c2b1d0
+EBUILD transd-0_p20101006.ebuild 863 RMD160 0336f0e8755be4492ad9aff9de3004f8af23e6b8 SHA1 c674baa8a22de9fe71f73aec724a6f8a8f17c80c SHA256 c8c322e6e54c65def903a0fd0f7839728010f72e7e22bf4c00b26d09a4d8b9da
+MISC ChangeLog 348 RMD160 96cf88fd06f4d2e21d77f2235e2f5b0d8b44d57d SHA1 13030033a5dfff50929635b1a017e28660e44b88 SHA256 3d7defe85cb33e95627ab943c3febebb63b476d2183633a78c51cdcf7260c0a4
+MISC metadata.xml 159 RMD160 43722935bd7b4db7fe8db681054f2e53c4a5f7ce SHA1 15958ad72e234ba572c9534533c21532eb6bc0fd SHA256 900ea49b6703fce452e205b85226bf1f994725963e5840da501182e7487d0e63
diff --git a/xfce-extra/transd/metadata.xml b/xfce-extra/transd/metadata.xml
new file mode 100644
index 000000000000..d56729e92f8e
--- /dev/null
+++ b/xfce-extra/transd/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>xfce</herd>
+</pkgmetadata>
diff --git a/xfce-extra/transd/transd-0_p20101006.ebuild b/xfce-extra/transd/transd-0_p20101006.ebuild
new file mode 100644
index 000000000000..a6602e31524d
--- /dev/null
+++ b/xfce-extra/transd/transd-0_p20101006.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/transd/transd-0_p20101006.ebuild,v 1.1 2010/10/06 11:43:52 ssuominen Exp $
+
+EAPI=2
+EAUTORECONF=yes
+EINTLTOOLIZE=yes
+inherit xfconf
+
+DESCRIPTION="A small daemon to watch for window creation and set window transparency values"
+HOMEPAGE="http://spuriousinterrupt.org/projects/transd"
+SRC_URI="http://dev.gentoo.org/~ssuominen/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="x11-libs/libX11
+ >=xfce-base/libxfcegui4-4.2"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ XFCONF="--disable-dependency-tracking
+ $(xfconf_use_debug)"
+ DOCS="AUTHORS README TODO"
+}
+
+src_prepare() {
+ sed -i -e '/Encoding/d' transd.desktop.in || die
+ xfconf_src_prepare
+}