summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-01-29 20:26:27 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-01-29 20:26:27 +0000
commit543df982d087515e20e0d00f87dedea7d908d63c (patch)
tree4a8d66df8622556400e514f2444c5cf08f36fc85 /xfce-extra
parentforce old libnotify in old xfce4-settings (diff)
downloadhistorical-543df982d087515e20e0d00f87dedea7d908d63c.tar.gz
historical-543df982d087515e20e0d00f87dedea7d908d63c.tar.bz2
historical-543df982d087515e20e0d00f87dedea7d908d63c.zip
force old libnotify in old sensors plug-in, correct some syntax
Package-Manager: portage-2.2.0_alpha19/cvs/Linux x86_64
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.0.0.ebuild25
1 files changed, 16 insertions, 9 deletions
diff --git a/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.0.0.ebuild b/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.0.0.ebuild
index 6e7216ac6153..d0101f721604 100644
--- a/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.0.0.ebuild
+++ b/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.0.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.0.0.ebuild,v 1.10 2010/08/11 20:50:52 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.0.0.ebuild,v 1.11 2011/01/29 20:26:27 ssuominen Exp $
+EAPI=3
EAUTORECONF=yes
-EAPI=2
inherit xfconf
DESCRIPTION="acpi, lm_sensors and hddtemp panel plugin"
@@ -19,7 +19,7 @@ RDEPEND=">=x11-libs/gtk+-2.10:2
>=xfce-base/libxfce4util-4.4
>=xfce-base/libxfcegui4-4.4
>=xfce-base/xfce4-panel-4.4
- libnotify? ( >=x11-libs/libnotify-0.4 )
+ libnotify? ( <x11-libs/libnotify-0.7 )
lm_sensors? ( >=sys-apps/lm_sensors-3.1.0 )
hddtemp? ( app-admin/hddtemp net-analyzer/gnu-netcat )"
DEPEND="${RDEPEND}
@@ -27,7 +27,8 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig"
pkg_setup() {
- XFCONF="--disable-dependency-tracking
+ XFCONF=(
+ --disable-dependency-tracking
--disable-static
$(use_enable hddtemp)
$(use_enable hddtemp netcat)
@@ -35,16 +36,22 @@ pkg_setup() {
$(use_enable acpi procacpi)
$(use_enable acpi sysfsacpi)
$(use_enable libnotify notification)
- $(xfconf_use_debug)"
+ $(xfconf_use_debug)
+ )
if ! use hddtemp && ! use lm_sensors && ! use acpi; then
- XFCONF="${XFCONF} --enable-procacpi --enable-sysfsacpi"
+ XFCONF+=(
+ --enable-procacpi
+ --enable-sysfsacpi
+ )
fi
DOCS="AUTHORS ChangeLog NEWS NOTES README TODO"
- PATCHES=( "${FILESDIR}/${P}-missing_includedir.patch"
- "${FILESDIR}/${P}-without_libnotify.patch" )
+ PATCHES=(
+ "${FILESDIR}"/${P}-missing_includedir.patch
+ "${FILESDIR}"/${P}-without_libnotify.patch
+ )
}
src_prepare() {