summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-01-29 21:01:57 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-01-29 21:01:57 +0000
commit209c5e3edbdbdf0bef4c0ca9054d6e77cee7479c (patch)
tree02cb305593e90204bdb07791e0e425c65b2b01dd /xfce-extra
parentbump to eapi3, use arrays etc (diff)
downloadhistorical-209c5e3edbdbdf0bef4c0ca9054d6e77cee7479c.tar.gz
historical-209c5e3edbdbdf0bef4c0ca9054d6e77cee7479c.tar.bz2
historical-209c5e3edbdbdf0bef4c0ca9054d6e77cee7479c.zip
bump to eapi3, use arrays
Package-Manager: portage-2.2.0_alpha19/cvs/Linux x86_64
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/eatmonkey/eatmonkey-0.1.4.ebuild13
-rw-r--r--xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.6-r1.ebuild12
-rw-r--r--xfce-extra/xfce4-modemlights-plugin/xfce4-modemlights-plugin-0.1.3.99.ebuild12
-rw-r--r--xfce-extra/xfce4-mpc-plugin/xfce4-mpc-plugin-0.3.5.ebuild11
-rw-r--r--xfce-extra/xfce4-wavelan-plugin/xfce4-wavelan-plugin-0.5.5.ebuild12
5 files changed, 37 insertions, 23 deletions
diff --git a/xfce-extra/eatmonkey/eatmonkey-0.1.4.ebuild b/xfce-extra/eatmonkey/eatmonkey-0.1.4.ebuild
index 0c701e2fbe50..8eded304d451 100644
--- a/xfce-extra/eatmonkey/eatmonkey-0.1.4.ebuild
+++ b/xfce-extra/eatmonkey/eatmonkey-0.1.4.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/eatmonkey/eatmonkey-0.1.4.ebuild,v 1.3 2010/03/27 09:52:31 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/eatmonkey/eatmonkey-0.1.4.ebuild,v 1.4 2011/01/29 20:55:47 ssuominen Exp $
-EAPI=2
+EAPI=3
inherit xfconf
DESCRIPTION="A download manager that works exclusively with aria2"
@@ -29,9 +29,12 @@ DEPEND="${COMMON_DEPEND}
sys-devel/gettext"
pkg_setup() {
+ PATCHES=( "${FILESDIR}"/${P}-syntax.patch )
+ XFCONF=(
+ --disable-dependency-tracking
+ )
+
DOCS="AUTHORS ChangeLog NEWS README"
- XFCONF="--disable-dependency-tracking"
- PATCHES=( "${FILESDIR}/${P}-syntax.patch" )
}
src_prepare() {
diff --git a/xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.6-r1.ebuild b/xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.6-r1.ebuild
index 401877b0327e..6968d90a3428 100644
--- a/xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.6-r1.ebuild
+++ b/xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.6-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.6-r1.ebuild,v 1.3 2010/11/05 13:56:24 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.6-r1.ebuild,v 1.4 2011/01/29 20:58:14 ssuominen Exp $
-EAPI=2
+EAPI=3
EAUTORECONF=yes
inherit xfconf
@@ -28,6 +28,10 @@ pkg_setup() {
"${FILESDIR}"/${P}-libxfce4panel_h.patch
"${FILESDIR}"/${P}-port-to-gio.patch
)
- XFCONF="--disable-dependency-tracking"
+
+ XFCONF=(
+ --disable-dependency-tracking
+ )
+
DOCS="AUTHORS ChangeLog NEWS"
}
diff --git a/xfce-extra/xfce4-modemlights-plugin/xfce4-modemlights-plugin-0.1.3.99.ebuild b/xfce-extra/xfce4-modemlights-plugin/xfce4-modemlights-plugin-0.1.3.99.ebuild
index 265ea907895f..4e1003ce1e11 100644
--- a/xfce-extra/xfce4-modemlights-plugin/xfce4-modemlights-plugin-0.1.3.99.ebuild
+++ b/xfce-extra/xfce4-modemlights-plugin/xfce4-modemlights-plugin-0.1.3.99.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-modemlights-plugin/xfce4-modemlights-plugin-0.1.3.99.ebuild,v 1.3 2009/10/06 11:11:34 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-modemlights-plugin/xfce4-modemlights-plugin-0.1.3.99.ebuild,v 1.4 2011/01/29 21:01:57 ssuominen Exp $
-EAPI=2
+EAPI=3
inherit xfconf
DESCRIPTION="a panel plugin to turn dialup (ppp) connections on/off"
@@ -25,6 +25,8 @@ DEPEND="${RDEPEND}
pkg_setup() {
DOCS="AUTHORS ChangeLog NEWS README"
- XFCONF="--disable-dependency-tracking
- $(use_enable debug)"
+ XFCONF=(
+ --disable-dependency-tracking
+ $(use_enable debug)
+ )
}
diff --git a/xfce-extra/xfce4-mpc-plugin/xfce4-mpc-plugin-0.3.5.ebuild b/xfce-extra/xfce4-mpc-plugin/xfce4-mpc-plugin-0.3.5.ebuild
index cbc5d20c1887..b4eac20890be 100644
--- a/xfce-extra/xfce4-mpc-plugin/xfce4-mpc-plugin-0.3.5.ebuild
+++ b/xfce-extra/xfce4-mpc-plugin/xfce4-mpc-plugin-0.3.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-mpc-plugin/xfce4-mpc-plugin-0.3.5.ebuild,v 1.5 2010/08/11 20:55:38 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-mpc-plugin/xfce4-mpc-plugin-0.3.5.ebuild,v 1.6 2011/01/29 20:56:50 ssuominen Exp $
-EAPI=2
+EAPI=3
EAUTORECONF=yes
inherit xfconf
@@ -25,8 +25,11 @@ DEPEND="${RDEPEND}
pkg_setup() {
PATCHES=( "${FILESDIR}"/${P}-exo_and_libxfcegui4.patch )
- XFCONF="--disable-dependency-tracking
+ XFCONF=(
+ --disable-dependency-tracking
$(use_enable libmpd)
- $(xfconf_use_debug)"
+ $(xfconf_use_debug)
+ )
+
DOCS="AUTHORS ChangeLog README TODO"
}
diff --git a/xfce-extra/xfce4-wavelan-plugin/xfce4-wavelan-plugin-0.5.5.ebuild b/xfce-extra/xfce4-wavelan-plugin/xfce4-wavelan-plugin-0.5.5.ebuild
index 7a1e00f841da..8eb915812af5 100644
--- a/xfce-extra/xfce4-wavelan-plugin/xfce4-wavelan-plugin-0.5.5.ebuild
+++ b/xfce-extra/xfce4-wavelan-plugin/xfce4-wavelan-plugin-0.5.5.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-wavelan-plugin/xfce4-wavelan-plugin-0.5.5.ebuild,v 1.7 2010/08/05 22:47:21 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-wavelan-plugin/xfce4-wavelan-plugin-0.5.5.ebuild,v 1.8 2011/01/29 20:59:04 ssuominen Exp $
-EAPI=2
+EAPI=3
EAUTORECONF=yes
inherit xfconf
@@ -25,7 +25,9 @@ DEPEND="${RDEPEND}
pkg_setup() {
DOCS="AUTHORS ChangeLog NEWS README THANKS"
- XFCONF="--disable-dependency-tracking
- $(xfconf_use_debug)"
+ XFCONF=(
+ --disable-dependency-tracking
+ $(xfconf_use_debug)
+ )
PATCHES=( "${FILESDIR}"/${P}-libs_for_xfce_create_header.patch )
}