summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2005-05-19 13:28:35 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2005-05-19 13:28:35 +0000
commitd788fb3dcab06c0e5236bd64cc794b1be0a5124d (patch)
tree25fce7159c75367a2e6e9891eed1e0b9f9341f1f /www-servers
parentStable on ppc64 (diff)
downloadhistorical-d788fb3dcab06c0e5236bd64cc794b1be0a5124d.tar.gz
historical-d788fb3dcab06c0e5236bd64cc794b1be0a5124d.tar.bz2
historical-d788fb3dcab06c0e5236bd64cc794b1be0a5124d.zip
bump
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx/ChangeLog7
-rw-r--r--www-servers/nginx/Manifest4
-rw-r--r--www-servers/nginx/files/digest-nginx-0.1.321
-rw-r--r--www-servers/nginx/nginx-0.1.32.ebuild81
4 files changed, 91 insertions, 2 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index d046a1ea4de7..42123be84c17 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.22 2005/05/16 14:11:16 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.23 2005/05/19 13:28:34 voxus Exp $
+
+*nginx-0.1.32 (19 May 2005)
+
+ 19 May 2005; Konstantin Arkhipov <voxus@gentoo.org> +nginx-0.1.32.ebuild:
+ Version bump.
*nginx-0.1.31 (16 May 2005)
diff --git a/www-servers/nginx/Manifest b/www-servers/nginx/Manifest
index f4812f8e7a02..c0935c3d28b1 100644
--- a/www-servers/nginx/Manifest
+++ b/www-servers/nginx/Manifest
@@ -2,10 +2,12 @@ MD5 f990623c1b2c1e33a1d3f060b521e233 nginx-0.1.31.ebuild 2075
MD5 e020548a3311a533a4160c66e39061ff nginx-0.1.30-r1.ebuild 2080
MD5 65987f13c01c296f08dd2b66d91f7d1f nginx-0.1.29-r2.ebuild 2061
MD5 0b612ee125685634d4e80df6e302d442 nginx-0.1.28-r2.ebuild 2082
-MD5 f6473e6c6348f73a46f25eedcfd63fa2 ChangeLog 3971
+MD5 01c0f62033e9d8161aa1b2994fcee8da nginx-0.1.32.ebuild 2075
+MD5 0016470ed090b70df8efec12e57cf180 ChangeLog 4093
MD5 822f3c821527e6a34f23a6a92a884766 metadata.xml 220
MD5 1128351ac7fd6ef7b14f169b1e327518 files/nginx-0.1.30-slashless_path.patch 412
MD5 dc573994590305f8244f0908b4067b56 files/digest-nginx-0.1.31 64
+MD5 18ea848c7776e53d7e9f8445ead94e5d files/digest-nginx-0.1.32 64
MD5 8c7b8c93f0c4048d83df9cdc31d86e1b files/nginx 922
MD5 964b96268e483e663e4ea13d03320185 files/digest-nginx-0.1.28-r2 64
MD5 4e72c813c956580f61dea414fe1af8b3 files/digest-nginx-0.1.29-r2 64
diff --git a/www-servers/nginx/files/digest-nginx-0.1.32 b/www-servers/nginx/files/digest-nginx-0.1.32
new file mode 100644
index 000000000000..c0760f21e736
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.1.32
@@ -0,0 +1 @@
+MD5 39e42a0c1240bb281be9fbb8273a0b13 nginx-0.1.32.tar.gz 293988
diff --git a/www-servers/nginx/nginx-0.1.32.ebuild b/www-servers/nginx/nginx-0.1.32.ebuild
new file mode 100644
index 000000000000..e45cf052733d
--- /dev/null
+++ b/www-servers/nginx/nginx-0.1.32.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.1.32.ebuild,v 1.1 2005/05/19 13:28:34 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug fastcgi pcre threads ssl zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )"
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || myconf="${myconf} --without-pcre"
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+
+ cd ${S} && ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm \
+ ${myconf} || die "configure failed"
+
+ emake || "failed to compile"
+}
+
+src_install() {
+ cd ${S} || die
+
+ dodir /var/log/${PN}
+ keepdir /var/log/${PN}
+
+ dodir /var/tmp/${PN}
+
+ dodir /var/tmp/${PN}/client
+ keepdir /var/tmp/${PN}/client
+
+ dodir /var/tmp/${PN}/proxy
+ keepdir /var/tmp/${PN}/proxy
+
+ dodir /var/tmp/${PN}/fastcgi
+ keepdir /var/tmp/${PN}/fastcgi
+
+ dodir /etc/${PN}
+
+ dosbin objs/nginx
+ doinitd ${FILESDIR}/nginx
+
+ insinto /etc/${PN}
+ rm conf/nginx.conf
+ doins -r conf/*
+ doins ${FILESDIR}/nginx.conf
+
+ dodoc CHANGES{,.ru} LICENSE README
+}