summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-10-03 23:38:00 +0000
committerMike Frysinger <vapier@gentoo.org>2009-10-03 23:38:00 +0000
commitbf98ec8361c560f1385370cbd38f74fb76e78b71 (patch)
tree5e0a5a765da7ad5bdc73426fbf4b7067ba4e2834 /sys-libs
parentstable x86, bug 287409 (diff)
downloadhistorical-bf98ec8361c560f1385370cbd38f74fb76e78b71.tar.gz
historical-bf98ec8361c560f1385370cbd38f74fb76e78b71.tar.bz2
historical-bf98ec8361c560f1385370cbd38f74fb76e78b71.zip
old
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/readline/readline-5.0-r2.ebuild82
-rw-r--r--sys-libs/readline/readline-5.1_p4.ebuild100
-rw-r--r--sys-libs/readline/readline-6.0.ebuild98
3 files changed, 0 insertions, 280 deletions
diff --git a/sys-libs/readline/readline-5.0-r2.ebuild b/sys-libs/readline/readline-5.0-r2.ebuild
deleted file mode 100644
index b4a323c15c68..000000000000
--- a/sys-libs/readline/readline-5.0-r2.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-5.0-r2.ebuild,v 1.13 2008/11/23 18:27:39 vapier Exp $
-
-inherit eutils multilib toolchain-funcs
-
-# Official patches
-PLEVEL="x001 x002 x003 x004 x005"
-
-DESCRIPTION="Another cute console display library"
-HOMEPAGE="http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html"
-SRC_URI="mirror://gnu/readline/${P}.tar.gz
- ${PLEVEL//x/mirror://gnu/${PN}/${PN}-${PV}-patches/${PN}${PV/\.}-}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
-IUSE=""
-
-# We must be certain that we have a bash that is linked
-# to its internal readline, else we may get problems.
-RDEPEND=">=sys-libs/ncurses-5.2-r2"
-DEPEND="${RDEPEND}
- >=app-shells/bash-2.05b-r2"
-
-src_unpack() {
- unpack ${P}.tar.gz
-
- cd "${S}"
- for x in ${PLEVEL//x} ; do
- epatch "${DISTDIR}"/${PN}${PV/\.}-${x}
- done
- epatch "${FILESDIR}"/bash-3.0-etc-inputrc.patch
- epatch "${FILESDIR}"/${P}-solaris.patch
- epatch "${FILESDIR}"/${P}-no_rpath.patch
- epatch "${FILESDIR}"/${P}-self-insert.patch
- epatch "${FILESDIR}"/${P}-del-backspace-policy.patch
- epatch "${FILESDIR}"/${P}-darwin.patch
-
- # force ncurses linking #71420
- sed -i -e 's:^SHLIB_LIBS=:SHLIB_LIBS=-lncurses:' support/shobj-conf || die "sed"
-
- # fix building in parallel
- epatch "${FILESDIR}"/readline-5.0-parallel.patch
-}
-
-src_compile() {
- # the --libdir= is needed because if lib64 is a directory, it will default
- # to using that... even if CONF_LIBDIR isnt set or we're using a version
- # of portage without CONF_LIBDIR support.
- econf --with-curses --libdir=/usr/$(get_libdir) || die
- emake || die
-}
-
-src_install() {
- # portage 2.0.50's einstall causes sandbox violations if lib64 is a
- # directory, since readline's configure automatically sets libdir for you.
- make DESTDIR="${D}" install || die
- dodir /$(get_libdir)
-
- if ! use userland_Darwin ; then
- mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)
- chmod a+rx "${D}"/$(get_libdir)/*.so*
-
- # Bug #4411
- gen_usr_ldscript libreadline.so
- gen_usr_ldscript libhistory.so
- fi
-
- dodoc CHANGELOG CHANGES README USAGE NEWS
- docinto ps
- dodoc doc/*.ps
- dohtml -r doc
-}
-
-pkg_preinst() {
- preserve_old_lib /$(get_libdir)/lib{history,readline}.so.4 #29865
-}
-
-pkg_postinst() {
- preserve_old_lib_notify /$(get_libdir)/lib{history,readline}.so.4
-}
diff --git a/sys-libs/readline/readline-5.1_p4.ebuild b/sys-libs/readline/readline-5.1_p4.ebuild
deleted file mode 100644
index 4677db17a41c..000000000000
--- a/sys-libs/readline/readline-5.1_p4.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-5.1_p4.ebuild,v 1.17 2008/11/23 18:27:39 vapier Exp $
-
-inherit eutils multilib toolchain-funcs
-
-# Official patches
-# See ftp://ftp.cwru.edu/pub/bash/readline-5.1-patches/
-PLEVEL=${PV##*_p}
-MY_PV=${PV/_p*}
-MY_P=${PN}-${MY_PV}
-
-DESCRIPTION="Another cute console display library"
-HOMEPAGE="http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html"
-SRC_URI="mirror://gnu/readline/${MY_P}.tar.gz
- $(for ((i=1; i<=PLEVEL; i++)); do
- printf 'ftp://ftp.cwru.edu/pub/bash/readline-%s-patches/readline%s-%03d\n' \
- ${MY_PV} ${MY_PV/\.} ${i}
- printf 'mirror://gnu/bash/readline-%s-patches/readline%s-%03d\n' \
- ${MY_PV} ${MY_PV/\.} ${i}
- done)"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE=""
-
-# We must be certain that we have a bash that is linked
-# to its internal readline, else we may get problems.
-RDEPEND=">=sys-libs/ncurses-5.2-r2"
-DEPEND="${RDEPEND}
- >=app-shells/bash-2.05b-r2"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${MY_P}.tar.gz
-
- cd "${S}"
- # Official patches
- local i
- for ((i=1; i<=PLEVEL; i++)); do
- epatch "${DISTDIR}"/${PN}${MY_PV/\.}-$(printf '%03d' ${i})
- done
- epatch "${FILESDIR}"/bash-3.0-etc-inputrc.patch
- epatch "${FILESDIR}"/${PN}-5.0-no_rpath.patch
- epatch "${FILESDIR}"/${MY_P}-cleanups.patch
- epatch "${FILESDIR}"/${MY_P}-rlfe-build.patch #116483
- epatch "${FILESDIR}"/${MY_P}-rlfe-uclibc.patch
- epatch "${FILESDIR}"/${MY_P}-rlfe-libutil.patch
- epatch "${FILESDIR}"/${MY_P}-fbsd-pic.patch
-
- ln -s ../.. examples/rlfe/readline
-
- # force ncurses linking #71420
- sed -i -e 's:^SHLIB_LIBS=:SHLIB_LIBS=-lncurses:' support/shobj-conf || die "sed"
-}
-
-src_compile() {
- # the --libdir= is needed because if lib64 is a directory, it will default
- # to using that... even if CONF_LIBDIR isnt set or we're using a version
- # of portage without CONF_LIBDIR support.
- econf --with-curses --libdir=/usr/$(get_libdir) || die
- emake || die
-
- if ! tc-is-cross-compiler; then
- cd examples/rlfe
- econf || die
- emake || die "make rlfe failed"
- fi
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
- dodir /$(get_libdir)
-
- mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)
- chmod a+rx "${D}"/$(get_libdir)/*.so*
-
- # Bug #4411
- gen_usr_ldscript libreadline.so
- gen_usr_ldscript libhistory.so
-
- if ! tc-is-cross-compiler; then
- dobin examples/rlfe/rlfe || die
- fi
-
- dodoc CHANGELOG CHANGES README USAGE NEWS
- docinto ps
- dodoc doc/*.ps
- dohtml -r doc
-}
-
-pkg_preinst() {
- preserve_old_lib /$(get_libdir)/lib{history,readline}.so.4 #29865
-}
-
-pkg_postinst() {
- preserve_old_lib_notify /$(get_libdir)/lib{history,readline}.so.4
-}
diff --git a/sys-libs/readline/readline-6.0.ebuild b/sys-libs/readline/readline-6.0.ebuild
deleted file mode 100644
index deab655be2ac..000000000000
--- a/sys-libs/readline/readline-6.0.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-6.0.ebuild,v 1.4 2009/02/24 08:57:47 kumba Exp $
-
-inherit autotools eutils multilib toolchain-funcs flag-o-matic
-
-# Official patches
-# See ftp://ftp.cwru.edu/pub/bash/readline-6.0-patches/
-PLEVEL=${PV##*_p}
-MY_PV=${PV/_p*}
-MY_P=${PN}-${MY_PV}
-[[ ${PV} != *_p* ]] && PLEVEL=0
-patches() {
- [[ ${PLEVEL} -eq 0 ]] && return 1
- local opt=$1
- eval set -- {1..${PLEVEL}}
- set -- $(printf "${PN}${MY_PV/\.}-%03d " "$@")
- if [[ ${opt} == -s ]] ; then
- echo "${@/#/${DISTDIR}\/}"
- else
- local u
- for u in ftp://ftp.cwru.edu/pub/bash mirror://gnu/${PN} ; do
- printf "${u}/${PN}-${MY_PV}-patches/%s " "$@"
- done
- fi
-}
-
-DESCRIPTION="Another cute console display library"
-HOMEPAGE="http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html"
-SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz $(patches)"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE=""
-
-# We must be certain that we have a bash that is linked
-# to its internal readline, else we may get problems.
-RDEPEND=">=sys-libs/ncurses-5.2-r2"
-DEPEND="${RDEPEND}
- >=app-shells/bash-2.05b-r2"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${MY_P}.tar.gz
-
- cd "${S}"
- [[ ${PLEVEL} -gt 0 ]] && epatch $(patches -s)
- epatch "${FILESDIR}"/${PN}-5.0-no_rpath.patch
- epatch "${FILESDIR}"/${PN}-6.0-rlfe-build.patch #151174
- epatch "${FILESDIR}"/${PN}-5.2-no-ignore-shlib-errors.patch #216952
-
- # force ncurses linking #71420
- sed -i -e 's:^SHLIB_LIBS=:SHLIB_LIBS=-lncurses:' support/shobj-conf || die "sed"
-
- # the bundled rlfe had its configure.in updated, but no one actually
- # ran autoconf to have the configure file updated
- ln -s ../.. examples/rlfe/readline
- cd examples/rlfe
- eautoconf
-}
-
-src_compile() {
- append-cppflags -D_GNU_SOURCE
-
- econf --with-curses || die
- emake || die
-
- if ! tc-is-cross-compiler ; then
- cd examples/rlfe
- append-ldflags -Lreadline
- econf || die
- emake || die "make rlfe failed"
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- gen_usr_ldscript -a readline history #4411
-
- if ! tc-is-cross-compiler; then
- dobin examples/rlfe/rlfe || die
- fi
-
- dodoc CHANGELOG CHANGES README USAGE NEWS
- docinto ps
- dodoc doc/*.ps
- dohtml -r doc
-}
-
-pkg_preinst() {
- preserve_old_lib /$(get_libdir)/lib{history,readline}.so.{4,5} #29865
-}
-
-pkg_postinst() {
- preserve_old_lib_notify /$(get_libdir)/lib{history,readline}.so.{4,5}
-}