summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-09-25 22:22:42 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-09-25 22:22:42 +0000
commitcd55fdd8bd14e8332efdf68fc69c128435ce40e0 (patch)
tree835359b0c84786a63eb8911e71ec7880a8966937 /sys-apps/debianutils
parentUpdated version; fixes a number of crash bugs. (diff)
downloadhistorical-cd55fdd8bd14e8332efdf68fc69c128435ce40e0.tar.gz
historical-cd55fdd8bd14e8332efdf68fc69c128435ce40e0.tar.bz2
historical-cd55fdd8bd14e8332efdf68fc69c128435ce40e0.zip
small fix
Diffstat (limited to 'sys-apps/debianutils')
-rw-r--r--sys-apps/debianutils/ChangeLog5
-rw-r--r--sys-apps/debianutils/debianutils-1.16.3.ebuild8
-rw-r--r--sys-apps/debianutils/files/debianutils-1.16.3-gentoo.patch73
3 files changed, 82 insertions, 4 deletions
diff --git a/sys-apps/debianutils/ChangeLog b/sys-apps/debianutils/ChangeLog
index b20fa557a7de..0318f01b9f87 100644
--- a/sys-apps/debianutils/ChangeLog
+++ b/sys-apps/debianutils/ChangeLog
@@ -1,11 +1,12 @@
# ChangeLog for sys-apps/debianutils
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/debianutils/ChangeLog,v 1.4 2002/09/25 12:16:21 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/debianutils/ChangeLog,v 1.5 2002/09/25 22:22:42 azarah Exp $
*debianutils-1.16.3 (25 Sep 2002)
25 Sep 2002; Martin Schlemmer <azarah@gentoo.org> :
- Version update. Add some of missing util.
+ Version update. Add some of missing util. Add patch to make
+ installkernel and mkboot more Gentoo friendly.
*debianutils-1.13.3-r3 (14 July 2002)
diff --git a/sys-apps/debianutils/debianutils-1.16.3.ebuild b/sys-apps/debianutils/debianutils-1.16.3.ebuild
index befcb6d99534..a7db27c10e39 100644
--- a/sys-apps/debianutils/debianutils-1.16.3.ebuild
+++ b/sys-apps/debianutils/debianutils-1.16.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/debianutils/debianutils-1.16.3.ebuild,v 1.1 2002/09/25 12:16:21 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/debianutils/debianutils-1.16.3.ebuild,v 1.2 2002/09/25 22:22:42 azarah Exp $
S=${WORKDIR}/${P}
DESCRIPTION="A selection of tools from Debian"
@@ -17,7 +17,11 @@ src_unpack() {
unpack ${A}
cd ${S}
- patch -p0 < ${FILESDIR}/${P}-Makefile-gentoo.diff
+ patch -p0 < ${FILESDIR}/${P}-Makefile-gentoo.diff || die
+
+ # Make installkernel and mkboot more Gentoo friendly
+ # <azarah@gentoo.org> (25 Sep 2002)
+ patch -p1 < ${FILESDIR}/${P}-gentoo.patch || die
}
src_compile() {
diff --git a/sys-apps/debianutils/files/debianutils-1.16.3-gentoo.patch b/sys-apps/debianutils/files/debianutils-1.16.3-gentoo.patch
new file mode 100644
index 000000000000..221286455ddb
--- /dev/null
+++ b/sys-apps/debianutils/files/debianutils-1.16.3-gentoo.patch
@@ -0,0 +1,73 @@
+diff -urN debianutils-1.16.3/installkernel debianutils-1.16.3.azarah/installkernel
+--- debianutils-1.16.3/installkernel 2002-06-13 14:22:33.000000000 +0200
++++ debianutils-1.16.3.azarah/installkernel 2002-09-26 23:07:52.000000000 +0200
+@@ -33,7 +33,7 @@
+ cat "$2" > "$dir/$1-$ver"
+
+ if [ -f "$dir/$1" ] ; then
+- if [ -L "$dir/$1" -a $(ls -l "$dir/$1" | awk '{print $11}') \
++ if [ -L "$dir/$1" -a "$(ls -l "$dir/$1" | awk '{print $11}')" \
+ = "$1-$ver" ] ; then
+ ln -sf "$1-$ver.old" "$dir/$1.old"
+ else
+diff -urN debianutils-1.16.3/mkboot debianutils-1.16.3.azarah/mkboot
+--- debianutils-1.16.3/mkboot 2002-02-19 02:03:17.000000000 +0200
++++ debianutils-1.16.3.azarah/mkboot 2002-09-26 23:10:00.000000000 +0200
+@@ -14,7 +14,13 @@
+
+ # check whether GRUB is installed
+ grubcheck () {
+- [ $(dpkg -s grub | grep -i ^status: | cut -d ' ' -f 4) = "installed" ]
++ # Right way in Gentoo to check, but grub is in system profile,
++ # so rather check for lilo first....
++ if [ -x /usr/bin/qpkg ] ; then
++ [ "$(qpkg -nc sys-apps/grub)" = "sys-apps/grub *" ]
++ else
++ return 1
++ fi
+ }
+
+ # check whether LILO is installed
+@@ -94,7 +100,7 @@
+ fi
+
+ boottype="lilo"
+- if [ $(whoami) != root ] ; then
++ if [ "$(whoami)" != root ] ; then
+ echo "Since you don't have root permissions, I can't put LILO on the diskette."
+ echo "I will make a non-LILO diskette instead, but it won't be as useful. You"
+ echo "can hit <Ctrl-C> to cancel."
+@@ -144,6 +150,16 @@
+ echo "either make a bootable floppy diskette, re-run LILO, or have GRUB"
+ echo "installed."
+
++ lilocheck
++ if [ $? -eq 0 ] ; then
++ echo -en "\nShould I run /sbin/lilo? (y/n) "
++ read input
++ if [ "$input" = "y" ] ; then
++ /sbin/lilo && exit 0
++ echo "There was a problem running /sbin/lilo."
++ fi
++ fi
++
+ grubcheck
+ if [ $? -eq 0 ] ; then
+ echo -e "\nGRUB is installed. To automatically switch to new kernels, point your"
+@@ -151,16 +167,6 @@
+ exit 0
+ fi
+
+- lilocheck
+- if [ $? -eq 0 ] ; then
+- echo -en "\nShould I run /sbin/lilo? (y/n) "
+- read input
+- if [ "$input" = "y" ] ; then
+- /sbin/lilo && exit 0
+- echo "There was a problem running /sbin/lilo."
+- fi
+- fi
+-
+ echo -en "\nShould I make a bootdisk? (y/n) "
+ read input
+ if [ "$input" = "y" ] ; then