summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2003-07-19 19:30:00 +0000
committerAron Griffis <agriffis@gentoo.org>2003-07-19 19:30:00 +0000
commit598af044b6301eac3e89c093e4ee124464ba4eae (patch)
tree9547070ccaf784c02e4ad3e74fa6daf028a4d741 /net-fs
parentchange exportfs timeout to 30 seconds (diff)
downloadhistorical-598af044b6301eac3e89c093e4ee124464ba4eae.tar.gz
historical-598af044b6301eac3e89c093e4ee124464ba4eae.tar.bz2
historical-598af044b6301eac3e89c093e4ee124464ba4eae.zip
change exportfs timeout to 30 seconds
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/nfs-utils/Manifest6
-rw-r--r--net-fs/nfs-utils/files/digest-nfs-utils-1.0.5-r11
-rw-r--r--net-fs/nfs-utils/files/nfs-2154
-rw-r--r--net-fs/nfs-utils/nfs-utils-1.0.5-r1.ebuild66
4 files changed, 224 insertions, 3 deletions
diff --git a/net-fs/nfs-utils/Manifest b/net-fs/nfs-utils/Manifest
index b8b8c55e1d60..ad7f5be00a9f 100644
--- a/net-fs/nfs-utils/Manifest
+++ b/net-fs/nfs-utils/Manifest
@@ -1,12 +1,12 @@
MD5 f7782767ba2c749c4015b109a218f369 nfs-utils-1.0.5.ebuild 1911
-MD5 b7b88eccb3851f3395a88402fd051e55 nfs-utils-1.0.5-r1.ebuild 1911
+MD5 46df3de30a3194ba950d5f66e1b408dd nfs-utils-1.0.5-r1.ebuild 1918
MD5 b46af45b8acea0fc23c697913ea229cd nfs-utils-1.0.1-r1.ebuild 1911
MD5 459bf83dd49739fb9c7191e012f74ddf nfs-utils-0.3.3-r1.ebuild 1504
-MD5 e32311f4b04a03bcec8942f5777d1a57 ChangeLog 3328
+MD5 34ea55470f76a0be121ba16a86dc906d ChangeLog 3558
MD5 d36e5306c46430c4a62657e9ea514ddd files/nfs 4443
MD5 cc56dba449d210ecbbe1beeb3114a6f4 files/nfs.confd 348
MD5 3b44b94c2a6c8335c53302efdf4907f8 files/nfs-1 4705
-MD5 5e15bf972ca4a9b78f766c7958f6add7 files/nfs-2 4708
+MD5 3e9f55a9f32346d63aeec1d0589b4df1 files/nfs-2 4708
MD5 da4b8b95f4c8a015c4a69257ea6582e1 files/digest-nfs-utils-1.0.1-r1 66
MD5 3219e53cb07ef64536526153158b7ab2 files/digest-nfs-utils-1.0.5-r1 67
MD5 3219e53cb07ef64536526153158b7ab2 files/digest-nfs-utils-1.0.5 67
diff --git a/net-fs/nfs-utils/files/digest-nfs-utils-1.0.5-r1 b/net-fs/nfs-utils/files/digest-nfs-utils-1.0.5-r1
new file mode 100644
index 000000000000..4f630b2a2adb
--- /dev/null
+++ b/net-fs/nfs-utils/files/digest-nfs-utils-1.0.5-r1
@@ -0,0 +1 @@
+MD5 ce48f1e17f1c49ca14dbd2b0e033d1b9 nfs-utils-1.0.5.tar.gz 265760
diff --git a/net-fs/nfs-utils/files/nfs-2 b/net-fs/nfs-utils/files/nfs-2
new file mode 100644
index 000000000000..42c29e9d5a24
--- /dev/null
+++ b/net-fs/nfs-utils/files/nfs-2
@@ -0,0 +1,154 @@
+#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/files/nfs-2,v 1.1 2003/07/19 19:29:52 agriffis Exp $
+
+#---------------------------------------------------------------------------
+# This script starts/stops the following
+# rpc.statd if necessary (also checked by init.d/nfsmount)
+# rpc.rquotad if exists (from quota package)
+# rpc.nfsd
+# rpc.mountd
+#---------------------------------------------------------------------------
+
+# NB: Config is in /etc/conf.d/nfs
+
+
+opts="start stop restart reload"
+
+# This variable is used for controlling whether or not to run exportfs -ua;
+# see stop() for more information
+restarting=no
+
+# The binary locations
+exportfs=/usr/sbin/exportfs
+statd=/sbin/rpc.statd
+rquotad=/usr/sbin/rpc.rquotad
+nfsd=/usr/sbin/rpc.nfsd
+mountd=/usr/sbin/rpc.mountd
+
+depend() {
+ need net portmap
+ after quota
+}
+
+start_statd() {
+ # Don't start rpc.statd if already started by init.d/nfsmount
+ killall -0 rpc.statd &>/dev/null && return 0
+ ebegin "Starting NFS statd"
+ start-stop-daemon --start --quiet --exec \
+ $statd -- $RPCSTATDOPTS 1>&2
+ eend $? "Error starting NFS statd"
+}
+
+stop_statd() {
+ # Don't stop rpc.statd if it's in use by init.d/nfsmount.
+ mount -t nfs | grep -q . && return 0
+ # Make sure it's actually running
+ killall -0 rpc.statd &>/dev/null || return 0
+ # Okay, all tests passed, stop rpc.statd
+ ebegin "Stopping NFS statd"
+ start-stop-daemon --stop --quiet --exec $statd 1>&2
+ eend $? "Error stopping NFS statd"
+}
+
+start() {
+ start_statd
+
+ # Exportfs likes to hang if networking isn't working.
+ # If that's the case, then try to kill it so the
+ # bootup process can continue.
+ if grep -q '^/' /etc/exports &>/dev/null; then
+ ebegin "Exporting NFS directories"
+ $exportfs -r 1>&2 &
+ ( sleep 30; kill -9 $! &>/dev/null & )
+ wait
+ eend $? "Error exporting NFS directories"
+ fi
+
+ if [ -x $rquotad ]; then
+ ebegin "Starting NFS rquotad"
+ start-stop-daemon --start --quiet --exec \
+ $rquotad -- $RPCRQUOTADOPTS 1>&2
+ eend $? "Error starting NFS rquotad"
+ fi
+
+ ebegin "Starting NFS daemon"
+ start-stop-daemon --start --quiet --exec \
+ $nfsd -- $RPCNFSDCOUNT 1>&2
+ eend $? "Error starting NFS daemon"
+
+ # Check if we support NFSv3
+ ebegin "Starting NFS mountd"
+ rpcinfo -u localhost nfs 3 &>/dev/null || \
+ RPCMOUNTDOPTS="$RPCMOUNTDOPTS --no-nfs-version 3"
+ start-stop-daemon --start --quiet --exec \
+ $mountd -- $RPCMOUNTDOPTS 1>&2
+ eend $? "Error starting NFS mountd"
+}
+
+stop() {
+ # Don't check NFSSERVER variable since it might have changed,
+ # instead use --oknodo to smooth things over
+ ebegin "Stopping NFS mountd"
+ start-stop-daemon --stop --quiet --oknodo \
+ --exec $mountd 1>&2
+ eend $? "Error stopping NFS mountd"
+
+ # nfsd sets its process name to [nfsd] so don't look for $nfsd
+ ebegin "Stopping NFS daemon"
+ start-stop-daemon --stop --quiet --oknodo \
+ --name nfsd --user root --signal 2 1>&2
+ eend $? "Error stopping NFS daemon"
+
+ if [ -x $rquotad ]; then
+ ebegin "Stopping NFS rquotad"
+ start-stop-daemon --stop --quiet --oknodo \
+ --exec $rquotad 1>&2
+ eend $? "Error stopping NFS rquotad"
+ fi
+
+ # When restarting the NFS server, running "exportfs -ua" probably
+ # isn't what the user wants. Running it causes all entries listed
+ # in xtab to be removed from the kernel export tables, and the
+ # xtab file is cleared. This effectively shuts down all NFS
+ # activity, leaving all clients holding stale NFS filehandles,
+ # *even* when the NFS server has restarted.
+ #
+ # That's what you would want if you were shutting down the NFS
+ # server for good, or for a long period of time, but not when the
+ # NFS server will be running again in short order. In this case,
+ # then "exportfs -r" will reread the xtab, and all the current
+ # clients will be able to resume NFS activity, *without* needing
+ # to umount/(re)mount the filesystem.
+ if [ "$restarting" = no ]; then
+ ebegin "Unexporting NFS directories"
+ # Exportfs likes to hang if networking isn't working.
+ # If that's the case, then try to kill it so the
+ # shutdown process can continue.
+ $exportfs -ua 1>&2 &
+ ( sleep 30; kill -9 $! &>/dev/null & )
+ wait
+ eend $? "Error unexporting NFS directories"
+ fi
+
+ stop_statd
+}
+
+reload() {
+ # Exportfs likes to hang if networking isn't working.
+ # If that's the case, then try to kill it so the
+ # bootup process can continue.
+ ebegin "Reloading /etc/exports"
+ $exportfs -r 1>&2 &
+ ( sleep 30; kill -9 $! &>/dev/null & )
+ wait
+ eend $? "Error exporting NFS directories"
+}
+
+restart() {
+ # See long comment in stop() regarding "restarting" and exportfs -ua
+ restarting=yes
+ svc_stop
+ svc_start
+}
diff --git a/net-fs/nfs-utils/nfs-utils-1.0.5-r1.ebuild b/net-fs/nfs-utils/nfs-utils-1.0.5-r1.ebuild
new file mode 100644
index 000000000000..0723602813c9
--- /dev/null
+++ b/net-fs/nfs-utils/nfs-utils-1.0.5-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-1.0.5-r1.ebuild,v 1.1 2003/07/19 19:29:52 agriffis Exp $
+
+IUSE="tcpd"
+
+DESCRIPTION="NFS client and server daemons"
+SRC_URI="mirror://sourceforge/nfs/${P}.tar.gz"
+HOMEPAGE="http://nfs.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc alpha sparc arm hppa"
+
+DEPEND="tcpd? ( sys-apps/tcp-wrappers )"
+RDEPEND="${DEPEND} >=net-nds/portmap-5b-r6"
+
+src_compile() {
+ ./configure \
+ --mandir=/usr/share/man \
+ --with-statedir=/var/lib/nfs \
+ --disable-rquotad --enable-nfsv3 || die "Configure failed"
+
+ if ! use tcpd; then
+ sed -e "s:\(-lwrap\|-DHAVE_TCP_WRAPPER\)::" < config.mk > config.mk.new
+ mv --force config.mk.new config.mk
+ fi
+
+ # parallel make still fails
+ make || die "Failed to compile"
+}
+
+src_install() {
+ make install install_prefix=${D} MANDIR=${D}/usr/share/man \
+ || die "Failed to install"
+
+ # Install some client-side binaries in /sbin
+ mkdir ${D}/sbin
+ mv ${D}/usr/sbin/rpc.{lockd,statd} ${D}/sbin
+
+ dodoc ChangeLog COPYING README
+ docinto linux-nfs ; dodoc linux-nfs/*
+
+ insinto /etc ; doins ${FILESDIR}/exports
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/nfs-2 nfs
+ newexe ${FILESDIR}/nfsmount nfsmount
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/nfs.confd nfs
+}
+
+pkg_postinst() {
+ einfo "NFS V2 and V3 servers now default to \"sync\" IO if ${P}"
+ einfo "(or later) is installed."
+ einfo "More info at ${HOMEPAGE} (see questions 5, 12, 13, and 14)."
+ echo
+ ewarn "PLEASE note: Since the latest NFS utils has changed the server"
+ ewarn "default to \"sync\" IO, then if no behavior is specified in the"
+ ewarn "export list, thus assuming the default behavior, a warning will"
+ ewarn "be generated at export time."
+ echo
+ # Running depscan since we introduced /etc/init.d/{portmap,nfs}
+ /etc/init.d/depscan.sh
+}