summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-10-04 05:47:28 +0000
committerHans de Graaff <graaff@gentoo.org>2013-10-04 05:47:28 +0000
commitc42f8af7219f5890157e3b7f713d6a0a9f650319 (patch)
treeb283d9d22fbd09b0888ea691c3a4b55be5e3c063 /dev-ruby/curb/curb-0.8.5.ebuild
parentUse updated security patch verify-ssl-certs-510417.diff from Debian patchset ... (diff)
downloadhistorical-c42f8af7219f5890157e3b7f713d6a0a9f650319.tar.gz
historical-c42f8af7219f5890157e3b7f713d6a0a9f650319.tar.bz2
historical-c42f8af7219f5890157e3b7f713d6a0a9f650319.zip
Version bump.
Package-Manager: portage-2.2.1/cvs/Linux x86_64 Manifest-Sign-Key: 0x8883FA56A308A8D7!
Diffstat (limited to 'dev-ruby/curb/curb-0.8.5.ebuild')
-rw-r--r--dev-ruby/curb/curb-0.8.5.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/curb/curb-0.8.5.ebuild b/dev-ruby/curb/curb-0.8.5.ebuild
new file mode 100644
index 000000000000..7396954dd988
--- /dev/null
+++ b/dev-ruby/curb/curb-0.8.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/curb/curb-0.8.5.ebuild,v 1.1 2013/10/04 05:47:21 graaff Exp $
+
+EAPI=5
+# No longer compatible with ruby 1.8
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_TEST="rake"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby-language bindings for libcurl"
+HOMEPAGE="http://curb.rubyforge.org/"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND+=" net-misc/curl[ssl]"
+RDEPEND+=" net-misc/curl[ssl]"
+
+all_ruby_prepare() {
+ # fix tests when localhost is also ::1
+ sed -i -e 's|localhost:|127.0.0.1:|g' tests/*.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake -Cext CFLAGS="${CFLAGS} -fPIC" archflags="${LDFLAGS}" V=1
+ cp -l ext/curb_core$(get_modname) lib || die
+}