summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTroy Dack <tad@gentoo.org>2003-03-02 05:17:12 +0000
committerTroy Dack <tad@gentoo.org>2003-03-02 05:17:12 +0000
commite0fd632de413a1fa335de242bb10f2a1ccfd9a78 (patch)
tree6ebf5e8c30150b9a97a8d49c7f8f608469cc519b /dev-python
parentInitial import of sulu, a program to upload mp3's to Samsung Uproar celphones. (diff)
downloadhistorical-e0fd632de413a1fa335de242bb10f2a1ccfd9a78.tar.gz
historical-e0fd632de413a1fa335de242bb10f2a1ccfd9a78.tar.bz2
historical-e0fd632de413a1fa335de242bb10f2a1ccfd9a78.zip
Version Bump, see Bug #6291
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ReportLab/ReportLab-1.17.ebuild30
-rw-r--r--dev-python/ReportLab/files/1.17/setup.py55
-rw-r--r--dev-python/ReportLab/files/digest-ReportLab-1.171
3 files changed, 86 insertions, 0 deletions
diff --git a/dev-python/ReportLab/ReportLab-1.17.ebuild b/dev-python/ReportLab/ReportLab-1.17.ebuild
new file mode 100644
index 000000000000..4526245f1178
--- /dev/null
+++ b/dev-python/ReportLab/ReportLab-1.17.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ReportLab/ReportLab-1.17.ebuild,v 1.1 2003/03/02 05:17:12 tad Exp $
+
+#goofy tarball versioning
+vmaj=${PV%%.*}
+vmin=${PV##*.}
+
+S=${WORKDIR}/reportlab
+DESCRIPTION="Tools for generating printable PDF documents from any data source."
+SRC_URI="http://www.reportlab.com/ftp/${PN}_${vmaj}_${vmin}.tgz"
+HOMEPAGE="http://www.reportlab.com/"
+
+DEPEND=">=dev-lang/python-1.5"
+RDEPEND="${DEPEND}
+ >=sys-libs/zlib-0.95
+ dev-python/Imaging"
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~sparc ~alpha"
+
+src_compile() {
+ cp ${FILESDIR}/${PV}/setup.py .
+ python setup.py build
+}
+
+src_install() {
+ python setup.py install --root=${D}
+ dodoc README license.txt docs/*
+}
diff --git a/dev-python/ReportLab/files/1.17/setup.py b/dev-python/ReportLab/files/1.17/setup.py
new file mode 100644
index 000000000000..2ca3d033e8d3
--- /dev/null
+++ b/dev-python/ReportLab/files/1.17/setup.py
@@ -0,0 +1,55 @@
+#! /usr/bin/env python
+
+from os import chdir, stat
+from distutils.core import setup, Extension
+
+setup (# Distribution meta-data
+ name = "ReportLab",
+ version = "1.17",
+ description = "Tools for generating printable PDF documents from any data source.",
+ author = "ReportLab Inc.",
+# author_email = "",
+ license = """
+#####################################################################################
+#
+# Copyright (c) 2000-2001, ReportLab Inc.
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without modification,
+# are permitted provided that the following conditions are met:
+#
+# * Redistributions of source code must retain the above copyright notice,
+# this list of conditions and the following disclaimer.
+# * Redistributions in binary form must reproduce the above copyright notice,
+# this list of conditions and the following disclaimer in the documentation
+# and/or other materials provided with the distribution.
+# * Neither the name of the company nor the names of its contributors may be
+# used to endorse or promote products derived from this software without
+# specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
+# ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
+# IN NO EVENT SHALL THE OFFICERS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
+# INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
+# TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER
+# IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
+# IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+# SUCH DAMAGE.
+#
+#####################################################################################""",
+ long_description = "Tools for generating printable PDF documents from any data source.",
+ url = "http://www.reportlab.com/",
+ extra_path = "reportlab",
+ package_dir = { '':'.' },
+ packages = [ 'extensions',
+ 'graphics', 'graphics/charts', 'graphics/widgets',
+ 'lib', 'pdfbase', 'pdfgen', 'platypus',
+ 'test', 'tools', 'tools/docco', 'tools/py2pdf',
+ 'tools/pythonpoint', 'tools/pythonpoint/styles',
+ '.',
+ ],
+#./fonts
+ )
+
diff --git a/dev-python/ReportLab/files/digest-ReportLab-1.17 b/dev-python/ReportLab/files/digest-ReportLab-1.17
new file mode 100644
index 000000000000..8ee8b40b7224
--- /dev/null
+++ b/dev-python/ReportLab/files/digest-ReportLab-1.17
@@ -0,0 +1 @@
+MD5 853b3acaa998cfec39a372a94a00925d ReportLab_1_17.tgz 2160136