summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-24 20:51:48 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-24 20:51:48 +0000
commit9787f40ca98329ccfd44ee56f80f0903977c301b (patch)
tree2f397767e709f17acdfbce61220670259b4b144f /dev-python/sqlalchemy
parentDelete older ebuild. (diff)
downloadhistorical-9787f40ca98329ccfd44ee56f80f0903977c301b.tar.gz
historical-9787f40ca98329ccfd44ee56f80f0903977c301b.tar.bz2
historical-9787f40ca98329ccfd44ee56f80f0903977c301b.zip
Delete older ebuild.
Diffstat (limited to 'dev-python/sqlalchemy')
-rw-r--r--dev-python/sqlalchemy/sqlalchemy-0.5.8.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/dev-python/sqlalchemy/sqlalchemy-0.5.8.ebuild b/dev-python/sqlalchemy/sqlalchemy-0.5.8.ebuild
deleted file mode 100644
index 16060cc26cc8..000000000000
--- a/dev-python/sqlalchemy/sqlalchemy-0.5.8.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sqlalchemy/sqlalchemy-0.5.8.ebuild,v 1.6 2010/09/13 16:44:13 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils
-
-MY_P="SQLAlchemy-${PV/_}"
-
-DESCRIPTION="Python SQL toolkit and Object Relational Mapper."
-HOMEPAGE="http://www.sqlalchemy.org/ http://pypi.python.org/pypi/SQLAlchemy"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="doc examples firebird mssql mysql postgres +sqlite test"
-KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-
-RDEPEND="firebird? ( dev-python/kinterbasdb )
- mssql? ( dev-python/pymssql )
- mysql? ( dev-python/mysql-python )
- postgres? (
- >=dev-python/psycopg-2
- )
- sqlite? (
- >=dev-db/sqlite-3.3.13
- || ( >=dev-lang/python-2.5[sqlite] dev-python/pysqlite )
- )"
-
-DEPEND="dev-python/setuptools
- test? (
- >=dev-db/sqlite-3.3.13
- >=dev-python/nose-0.10.4
- || ( >=dev-lang/python-2.5[sqlite] dev-python/pysqlite )
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_test() {
- testing() {
- PYTHONPATH="lib" nosetests-${PYTHON_ABI}
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- pushd doc > /dev/null
- rm -fr build
- dohtml -r [a-z]* _images _static
- popd > /dev/null
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}