summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-06-25 18:56:36 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-06-25 18:56:36 +0000
commit7a1a0449519703e92d456cbb558e0944f2efcf2c (patch)
tree00a85d81a0c902719c9c2df932c44c658f84921a /dev-ml/fieldslib
parentversion bump, by Vladimir Ivanov, bug #361161 (diff)
downloadhistorical-7a1a0449519703e92d456cbb558e0944f2efcf2c.tar.gz
historical-7a1a0449519703e92d456cbb558e0944f2efcf2c.tar.bz2
historical-7a1a0449519703e92d456cbb558e0944f2efcf2c.zip
version bump, by Vladimir Ivanov, bug #361167
Package-Manager: portage-2.2.0_alpha41/cvs/Linux x86_64
Diffstat (limited to 'dev-ml/fieldslib')
-rw-r--r--dev-ml/fieldslib/ChangeLog7
-rw-r--r--dev-ml/fieldslib/fieldslib-0.1.2.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-ml/fieldslib/ChangeLog b/dev-ml/fieldslib/ChangeLog
index dfa0bcaf9daf..90c2603a30aa 100644
--- a/dev-ml/fieldslib/ChangeLog
+++ b/dev-ml/fieldslib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/fieldslib
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/fieldslib/ChangeLog,v 1.3 2011/01/24 09:19:48 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/fieldslib/ChangeLog,v 1.4 2011/06/25 18:56:36 aballier Exp $
+
+*fieldslib-0.1.2 (25 Jun 2011)
+
+ 25 Jun 2011; Alexis Ballier <aballier@gentoo.org> +fieldslib-0.1.2.ebuild:
+ version bump, by Vladimir Ivanov, bug #361167
24 Jan 2011; Alexis Ballier <aballier@gentoo.org> -fieldslib-0.1.0.ebuild:
remove old
diff --git a/dev-ml/fieldslib/fieldslib-0.1.2.ebuild b/dev-ml/fieldslib/fieldslib-0.1.2.ebuild
new file mode 100644
index 000000000000..8ad265ffb565
--- /dev/null
+++ b/dev-ml/fieldslib/fieldslib-0.1.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/fieldslib/fieldslib-0.1.2.ebuild,v 1.1 2011/06/25 18:56:36 aballier Exp $
+
+EAPI="2"
+inherit findlib multilib
+
+DESCRIPTION="Folding over record fields"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://www.janestreet.com/ocaml/${P}.tar.gz"
+
+LICENSE="LGPL-2.1-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug +ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-3.12[ocamlopt?]
+ >=dev-ml/type-conv-2.3.0"
+RDEPEND="${DEPEND}"
+
+oasis_use_enable() {
+ echo "--override $2 `use $1 && echo \"true\" || echo \"false\"`"
+}
+
+src_configure() {
+ ./configure --prefix usr \
+ --libdir /usr/$(get_libdir) \
+ --destdir "${D}" \
+ $(oasis_use_enable debug debug) \
+ $(oasis_use_enable ocamlopt is_native) \
+ || die
+}
+
+src_install() {
+ findlib_src_install
+
+ # install documentation
+ dodoc README || die
+}