summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2005-05-04 09:28:27 +0000
committerMartin Schlemmer <azarah@gentoo.org>2005-05-04 09:28:27 +0000
commit5c651ce74649028d2c98862e801546cf7fcebd84 (patch)
tree01a0ccda9d8ae7da2231b7e7bee08eb600b40ce3 /dev-libs
parentReadded to ~ppc (diff)
downloadhistorical-5c651ce74649028d2c98862e801546cf7fcebd84.tar.gz
historical-5c651ce74649028d2c98862e801546cf7fcebd84.tar.bz2
historical-5c651ce74649028d2c98862e801546cf7fcebd84.zip
Update version. Add KV_OUT_DIR support, bug #88072.
Package-Manager: portage-2.0.51.21
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/klibc/ChangeLog7
-rw-r--r--dev-libs/klibc/Manifest12
-rw-r--r--dev-libs/klibc/files/digest-klibc-1.0.81
-rw-r--r--dev-libs/klibc/klibc-1.0.8.ebuild153
4 files changed, 167 insertions, 6 deletions
diff --git a/dev-libs/klibc/ChangeLog b/dev-libs/klibc/ChangeLog
index e62833bf373e..f77cf2e8fb63 100644
--- a/dev-libs/klibc/ChangeLog
+++ b/dev-libs/klibc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/klibc
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/klibc/ChangeLog,v 1.6 2005/03/13 10:45:05 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/klibc/ChangeLog,v 1.7 2005/05/04 09:28:27 azarah Exp $
+
+*klibc-1.0.8 (04 May 2005)
+
+ 04 May 2005; Martin Schlemmer <azarah@gentoo.org> +klibc-1.0.8.ebuild:
+ Update version. Add KV_OUT_DIR support, bug #88072.
13 Mar 2005; Martin Schlemmer <azarah@gentoo.org> klibc-1.0.3.ebuild:
Add /usr/lib/klibc to PRELINK_PATH_MASK.
diff --git a/dev-libs/klibc/Manifest b/dev-libs/klibc/Manifest
index ae37417339eb..90089adc028b 100644
--- a/dev-libs/klibc/Manifest
+++ b/dev-libs/klibc/Manifest
@@ -3,16 +3,18 @@ Hash: SHA1
MD5 300321e4e9125b68cfc58017ec3949fd klibc-1.0.ebuild 3289
MD5 b612d343db3c54560665171eb7db245c metadata.xml 223
-MD5 beb313b40bf598a07e83498ceaab297e ChangeLog 1256
+MD5 cf28776ef755463203f3cf8c879d8d1c ChangeLog 1413
+MD5 4c2d18245f1ab6071c105bbf744d5d99 klibc-1.0.8.ebuild 4021
MD5 e054f1020f728f17ff8cf5fc3cef0ed3 klibc-1.0.3.ebuild 3939
MD5 d995810231e49d3aee9101cebc8a6a17 files/digest-klibc-1.0 62
MD5 dfa828b111983dc4ccc9a21dee070b39 files/klibc.m4 3630
MD5 e70edb40913b7ad07638a7202f773b6f files/klibc-1.0-makeklcc-empty-args.patch 807
+MD5 d839dab2895dd0e607d19436928be939 files/digest-klibc-1.0.8 64
MD5 626ed5b2981bf97e3b37743bb3b4cc08 files/digest-klibc-1.0.3 64
-----BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
+Version: GnuPG v1.4.1 (GNU/Linux)
-iD8DBQFCNBqP1ZcsMnZjRyIRAkQWAJ0avMMpfCMIDp860LcPWC69a0Aq+QCfRodU
-NURkiAYAzv5NJZynCz0sS7k=
-=eqPw
+iD8DBQFCeJcF1ZcsMnZjRyIRAp+pAKCS6K0K40sFt4DXvonmDvSN2C9fgwCfVy1W
+U9N0qMuXbxsYDmC90izZhFM=
+=TQyQ
-----END PGP SIGNATURE-----
diff --git a/dev-libs/klibc/files/digest-klibc-1.0.8 b/dev-libs/klibc/files/digest-klibc-1.0.8
new file mode 100644
index 000000000000..d92870d748c1
--- /dev/null
+++ b/dev-libs/klibc/files/digest-klibc-1.0.8
@@ -0,0 +1 @@
+MD5 06daaff20aa7d9cc888393e969624907 klibc-1.0.8.tar.bz2 446138
diff --git a/dev-libs/klibc/klibc-1.0.8.ebuild b/dev-libs/klibc/klibc-1.0.8.ebuild
new file mode 100644
index 000000000000..3b6203d3f877
--- /dev/null
+++ b/dev-libs/klibc/klibc-1.0.8.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/klibc/klibc-1.0.8.ebuild,v 1.1 2005/05/04 09:28:27 azarah Exp $
+
+inherit eutils linux-mod
+
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
+ export CTARGET=${CATEGORY/cross-}
+ fi
+fi
+
+DESCRIPTION="A minimal libc subset for use with initramfs."
+HOMEPAGE="http://www.zytor.com/mailman/listinfo/klibc"
+SRC_URI="ftp://ftp.kernel.org/pub/linux/libs/klibc/${P}.tar.bz2
+ ftp://ftp.kernel.org/pub/linux/libs/klibc/Stable/${P}.tar.bz2
+ ftp://ftp.kernel.org/pub/linux/libs/klibc/Testing/${P}.tar.bz2"
+LICENSE="|| ( GPL-2 LGPL-2 )"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RESTRICT="nostrip"
+
+DEPEND="dev-lang/perl
+ virtual/linux-sources"
+RDEPEND="dev-lang/perl"
+
+if [[ ${CTARGET} != ${CHOST} ]] ; then
+ SLOT="${CTARGET}"
+else
+ SLOT="0"
+fi
+
+is_cross() { [[ ${CHOST} != ${CTARGET} ]] ; }
+
+guess_arch() {
+ local x
+ local host=$(echo "${CTARGET%%-*}" | sed -e 's/i.86/i386/' \
+ -e 's/sun4u/sparc64/' \
+ -e 's/arm.*/arm/' \
+ -e 's/sa110/arm/' \
+ -e 's/powerpc/ppc/')
+
+ # Sort reverse so that we will get ppc64 before ppc, etc
+ for x in $(ls -1 "${S}/include/arch/" | sort -r) ; do
+ if [[ ${host} == "${x}" ]] ; then
+ echo "${x}"
+ return 0
+ fi
+ done
+
+ return 1
+}
+
+pkg_setup() {
+ # Make sure kernel sources are OK
+ # (Override for linux-mod eclass)
+ check_kernel_built
+}
+
+src_unpack() {
+ unpack ${A}
+
+ if [[ ! -d /usr/${CTARGET} ]] ; then
+ echo
+ eerror "It does not look like your cross-compiler is setup properly!"
+ die "It does not look like your cross-compiler is setup properly!"
+ fi
+
+ if ! guess_arch &>/dev/null ; then
+ echo
+ eerror "Could not guess klibc's ARCH from your CTARGET!"
+ die "Could not guess klibc's ARCH from your CTARGET!"
+ fi
+
+ kernel_arch=$(readlink "${KV_OUT_DIR}/include/asm" | sed -e 's:asm-::')
+ if [[ ${kernel_arch} != $(guess_arch) ]] ; then
+ echo
+ eerror "Your kernel sources are not configured for your chosen arch!"
+ eerror "(KERNEL_ARCH=\"${kernel_arch}\", ARCH=\"$(guess_arch)\")"
+ die "Your kernel sources are not configured for your chosen arch!"
+ fi
+
+ cd ${S}
+
+ # Add our linux source tree symlink
+ ln -snf ${KV_DIR} linux
+
+ # set the build directory
+ echo "KRNLOBJ = ${KV_OUT_DIR}" >> MCONFIG
+
+ # We do not want all the nice prelink warnings
+ # NOTE: for amd64, we might change below to '/usr/$(get_libdir)/klibc',
+ # but I do not do it right now, as the build system do not support
+ # the lib64 yet ....
+ cat > "${S}/70klibc" <<-EOF
+ PRELINK_PATH_MASK="/usr/lib/klibc"
+ EOF
+}
+
+src_compile() {
+ if is_cross ; then
+ einfo "ARCH = \"$(guess_arch)\""
+ einfo "CROSS = \"${CTARGET}-\""
+ emake ARCH=$(guess_arch) \
+ CROSS="${CTARGET}-" || die "Compile failed!"
+ else
+ env -u ARCH \
+ emake || die "Compile failed!"
+ fi
+}
+
+src_install() {
+ local klibc_prefix
+
+ if is_cross ; then
+ make INSTALLROOT=${D} \
+ ARCH=$(guess_arch) \
+ CROSS="${CTARGET}-" \
+ install || die "Install failed!"
+
+ klibc_prefix=$("${S}/${CTARGET}-klcc" -print-klibc-bindir)
+ else
+ env -u ARCH \
+ make INSTALLROOT=${D} install || die "Install failed!"
+
+ klibc_prefix=$("${S}/klcc" -print-klibc-bindir)
+ fi
+
+ # Hardlinks becoming copies
+ dosym gzip "${klibc_prefix}/gunzip"
+ dosym gzip "${klibc_prefix}/zcat"
+
+ if ! is_cross ; then
+ insinto /usr/share/aclocal
+ doins ${FILESDIR}/klibc.m4
+
+ doenvd ${S}/70klibc
+
+ dodoc ${S}/README ${S}/klibc/{LICENSE,CAVEATS}
+ newdoc ${S}/klibc/README README.klibc
+ newdoc ${S}/klibc/arch/README README.klibc.arch
+ docinto ash; newdoc ${S}/ash/README.klibc README
+ docinto gzip; dodoc ${S}/gzip/{COPYING,README}
+ docinto ipconfig; dodoc ${S}/ipconfig/README
+ docinto kinit; dodoc ${S}/kinit/README
+ fi
+}
+
+pkg_postinst() {
+ # Override for linux-mod eclass
+ return 0
+}