summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-10-03 12:44:03 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-10-03 12:44:03 +0000
commit4603d234052c6cbb054787609d3d5340e3322dcb (patch)
tree3b914012c7c588db3489bc43ff90886b51e89c89 /dev-cpp/libcmis
parentBump the patchset version to work with poppler 0.18.0 (diff)
downloadhistorical-4603d234052c6cbb054787609d3d5340e3322dcb.tar.gz
historical-4603d234052c6cbb054787609d3d5340e3322dcb.tar.bz2
historical-4603d234052c6cbb054787609d3d5340e3322dcb.zip
Add release version.
Package-Manager: portage-2.2.0_alpha60/cvs/Linux x86_64
Diffstat (limited to 'dev-cpp/libcmis')
-rw-r--r--dev-cpp/libcmis/ChangeLog8
-rw-r--r--dev-cpp/libcmis/libcmis-0.1.0.ebuild46
-rw-r--r--dev-cpp/libcmis/libcmis-9999.ebuild4
3 files changed, 55 insertions, 3 deletions
diff --git a/dev-cpp/libcmis/ChangeLog b/dev-cpp/libcmis/ChangeLog
index bc56b35d064f..315b942cc6a1 100644
--- a/dev-cpp/libcmis/ChangeLog
+++ b/dev-cpp/libcmis/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/libcmis
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libcmis/ChangeLog,v 1.1 2011/10/03 08:54:32 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libcmis/ChangeLog,v 1.2 2011/10/03 12:44:03 scarabeus Exp $
+
+*libcmis-0.1.0 (03 Oct 2011)
+
+ 03 Oct 2011; Tomáš Chvátal <scarabeus@gentoo.org> +libcmis-0.1.0.ebuild,
+ libcmis-9999.ebuild:
+ Add release version.
*libcmis-9999 (03 Oct 2011)
diff --git a/dev-cpp/libcmis/libcmis-0.1.0.ebuild b/dev-cpp/libcmis/libcmis-0.1.0.ebuild
new file mode 100644
index 000000000000..4e86edcd6f46
--- /dev/null
+++ b/dev-cpp/libcmis/libcmis-0.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libcmis/libcmis-0.1.0.ebuild,v 1.1 2011/10/03 12:44:03 scarabeus Exp $
+
+EAPI=4
+
+EGIT_REPO_URI="git://gitorious.org/libcmis/libcmis.git"
+[[ ${PV} == 9999 ]] && SCM_ECLASS="git-2"
+inherit autotools ${SCM_ECLASS}
+unset SCM_ECLASS
+
+DESCRIPTION="C++ client library for the CMIS interface"
+HOMEPAGE="http://gitorious.org/libcmis"
+[[ ${PV} == 9999 ]] || SRC_URI="http://people.freedesktop.org/~cbosdo/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 LGPL-2 MPL-1.1 )"
+SLOT="0"
+[[ ${PV} == 9999 ]] || KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs test"
+
+RDEPEND="
+ dev-libs/boost
+ dev-libs/libxml2
+ net-misc/curl
+"
+DEPEND="${RDEPEND}
+ test? ( dev-util/cppunit )
+"
+
+# It fetches the apache chemistry webapp and then try to run some magic on it
+RESTRICT="test"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --enable-client
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}
diff --git a/dev-cpp/libcmis/libcmis-9999.ebuild b/dev-cpp/libcmis/libcmis-9999.ebuild
index 1e6b74bbd7f4..a44ef02e84d8 100644
--- a/dev-cpp/libcmis/libcmis-9999.ebuild
+++ b/dev-cpp/libcmis/libcmis-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libcmis/libcmis-9999.ebuild,v 1.1 2011/10/03 08:54:32 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libcmis/libcmis-9999.ebuild,v 1.2 2011/10/03 12:44:03 scarabeus Exp $
EAPI=4
@@ -11,7 +11,7 @@ unset SCM_ECLASS
DESCRIPTION="C++ client library for the CMIS interface"
HOMEPAGE="http://gitorious.org/libcmis"
-[[ ${PV} == 9999 ]] || SRC_URI=""
+[[ ${PV} == 9999 ]] || SRC_URI="http://people.freedesktop.org/~cbosdo/${PN}/${P}.tar.gz"
LICENSE="|| ( GPL-2 LGPL-2 MPL-1.1 )"
SLOT="0"