summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-10-11 07:36:34 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-10-11 07:36:34 +0000
commitf74410a7c593ef6b79c0b7a0e1801f7738246c6f (patch)
treeca02529adf12d6c4fe56ddc2ae8aadf50120d565 /app-text/unrtf
parentinitial commit. ebuild and gcc3.3 patch written by robbat2@gentoo.org. patch ... (diff)
downloadhistorical-f74410a7c593ef6b79c0b7a0e1801f7738246c6f.tar.gz
historical-f74410a7c593ef6b79c0b7a0e1801f7738246c6f.tar.bz2
historical-f74410a7c593ef6b79c0b7a0e1801f7738246c6f.zip
initial commit. ebuild and gcc3.3 patch written by robbat2@gentoo.org. patch passed upstream.
Diffstat (limited to 'app-text/unrtf')
-rw-r--r--app-text/unrtf/Manifest3
-rw-r--r--app-text/unrtf/files/digest-unrtf-0.18.11
-rw-r--r--app-text/unrtf/unrtf-0.18.1.ebuild31
3 files changed, 34 insertions, 1 deletions
diff --git a/app-text/unrtf/Manifest b/app-text/unrtf/Manifest
index 596c3c26ea2f..9f8b3a9dcc38 100644
--- a/app-text/unrtf/Manifest
+++ b/app-text/unrtf/Manifest
@@ -1,2 +1,3 @@
-MD5 3a3a8391ca0af029884f9c69229707cc unrtf-0.18.1.ebuild 506
+MD5 ab818dfb848b80c4540c4e4ad41fd1a5 unrtf-0.18.1.ebuild 724
+MD5 ca3a85da39d9aa26ffa0cf20d0f3de10 ChangeLog 412
MD5 b5fe3aaf6fc458ab7c52127ff2de3694 files/digest-unrtf-0.18.1 63
diff --git a/app-text/unrtf/files/digest-unrtf-0.18.1 b/app-text/unrtf/files/digest-unrtf-0.18.1
new file mode 100644
index 000000000000..e60231ada591
--- /dev/null
+++ b/app-text/unrtf/files/digest-unrtf-0.18.1
@@ -0,0 +1 @@
+MD5 c7eb7eb30880c4fb8d089b8a486d255d unrtf-0.18.1.tar.gz 63141
diff --git a/app-text/unrtf/unrtf-0.18.1.ebuild b/app-text/unrtf/unrtf-0.18.1.ebuild
new file mode 100644
index 000000000000..795cf51a4893
--- /dev/null
+++ b/app-text/unrtf/unrtf-0.18.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/unrtf/unrtf-0.18.1.ebuild,v 1.1 2003/10/11 07:36:20 robbat2 Exp $
+
+DESCRIPTION="This is a sample skeleton ebuild file"
+HOMEPAGE="http://www.gnu.org/software/${PN}/${PN}.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz
+ mirror://gentoo/${P}-gcc33.patch"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=""
+#RDEPEND=""
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ epatch ${DISTDIR}/unrtf-0.18.1-gcc33.patch.gz
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dobin unrtf
+ doman unrtf.1
+ dohtml doc/unrtf.html
+ dodoc CHANGES COPYING README TODO
+}