From 1f21c0b5fc563408466284a7fcb06a1a5ce0974f Mon Sep 17 00:00:00 2001
From: Jimi Huotari <chiitoo@gentoo.org>
Date: Thu, 31 Mar 2022 16:49:48 +0300
Subject: dev-util/lxqt-build-tools: fix build-issues with glib-2.72

This patches in a fix for CMake-time issues with
'dev-libs/libqtxdg' and 'x11-libs/libfm-qt'.

Closes: https://bugs.gentoo.org/835648
Package-Manager: Portage-3.0.30, Repoman-3.0.3
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Closes: https://github.com/gentoo/gentoo/pull/24835
Signed-off-by: Sam James <sam@gentoo.org>
---
 .../files/lxqt-build-tools-0.10.0-glib-2.72.patch  | 25 +++++++++++++++++++
 .../lxqt-build-tools-0.10.0-r1.ebuild              | 28 ++++++++++++++++++++++
 2 files changed, 53 insertions(+)
 create mode 100644 dev-util/lxqt-build-tools/files/lxqt-build-tools-0.10.0-glib-2.72.patch
 create mode 100644 dev-util/lxqt-build-tools/lxqt-build-tools-0.10.0-r1.ebuild

(limited to 'dev-util/lxqt-build-tools')

diff --git a/dev-util/lxqt-build-tools/files/lxqt-build-tools-0.10.0-glib-2.72.patch b/dev-util/lxqt-build-tools/files/lxqt-build-tools-0.10.0-glib-2.72.patch
new file mode 100644
index 000000000000..359a4a966f40
--- /dev/null
+++ b/dev-util/lxqt-build-tools/files/lxqt-build-tools-0.10.0-glib-2.72.patch
@@ -0,0 +1,25 @@
+From 62b77bb807aa2ac2c1df8eec372df771da8d2203 Mon Sep 17 00:00:00 2001
+From: Dmitry Shachnev <mitya57@users.noreply.github.com>
+Date: Tue, 29 Mar 2022 00:29:49 +0300
+Subject: [PATCH] Replace gunixconnection.h file in gio-unix include dir check
+ (#74)
+
+That file was moved from gio-unix to gio in GLib 2.71.1:
+https://gitlab.gnome.org/GNOME/glib/-/commit/83d45c4f35dc87ba
+---
+ cmake/find-modules/FindGLIB.cmake | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cmake/find-modules/FindGLIB.cmake b/cmake/find-modules/FindGLIB.cmake
+index 0564b8d..bb2336a 100644
+--- a/cmake/find-modules/FindGLIB.cmake
++++ b/cmake/find-modules/FindGLIB.cmake
+@@ -101,7 +101,7 @@ foreach (_component ${GLIB_FIND_COMPONENTS})
+     elseif (${_component} STREQUAL "gio-unix")
+         pkg_check_modules(GIO_UNIX gio-unix-2.0)
+         find_path(GLIB_GIO_UNIX_INCLUDE_DIR
+-                  NAMES gio/gunixconnection.h
++                  NAMES gio/gunixfdlist.h
+                   HINTS ${GIO_UNIX_INCLUDEDIR}
+                   PATH_SUFFIXES gio-unix-2.0)
+ 
diff --git a/dev-util/lxqt-build-tools/lxqt-build-tools-0.10.0-r1.ebuild b/dev-util/lxqt-build-tools/lxqt-build-tools-0.10.0-r1.ebuild
new file mode 100644
index 000000000000..1f28afe1af42
--- /dev/null
+++ b/dev-util/lxqt-build-tools/lxqt-build-tools-0.10.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt Build Tools"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} = *9999* ]]; then
+	inherit git-r3
+	EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+	SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+	KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="
+	>=dev-libs/glib-2.50.0
+	>=dev-qt/qtcore-5.15:5
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-0.10.0-glib-2.72.patch" ) # https://bugs.gentoo.org/835648
-- 
cgit v1.2.3-65-gdbad