summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/s3cmd/Manifest1
-rw-r--r--net-misc/s3cmd/files/s3cmd-2.1.0-fix-compatibility-with-Python-3.9.patch57
-rw-r--r--net-misc/s3cmd/s3cmd-2.1.0-r1.ebuild25
-rw-r--r--net-misc/s3cmd/s3cmd-2.1.0.ebuild23
4 files changed, 0 insertions, 106 deletions
diff --git a/net-misc/s3cmd/Manifest b/net-misc/s3cmd/Manifest
index 2182f33fdf23..c4392dc2b593 100644
--- a/net-misc/s3cmd/Manifest
+++ b/net-misc/s3cmd/Manifest
@@ -1,3 +1,2 @@
-DIST s3cmd-2.1.0.tar.gz 127120 BLAKE2B 4282f616eb7ca97fa0d529a2c5acc1359f88888d182b62e1fa7d3f7401a93852a4e0724363a4c6f0a6520d6aef290d64e1775cb252fc0fbaa4b94762402c381e SHA512 98156218c4379e233185662d29fa4299b4a4e45a0fe143a145f30ff7d03362a4558b5fff5e5da0da850f5cce2c760fcd031bcf5ff7a6bd2c6352259e791d65e6
DIST s3cmd-2.2.0.tar.gz 134390 BLAKE2B d578aa13a7b8599c70dc6daa5d21950331b0b07278479d1f3947e6be78a9bd108c7f8ea6f198fa518dfa6ad44d907d979a29d5d9f1a15e4f73484fcebb118225 SHA512 07b2410554233b435b3476e09fd14354abaa19374cc1211f861147023470599483c18d213a44b5c9aee32d71b5a4bc5d9ce25721fb077cbadfd208d457e13845
DIST s3cmd-2.3.0.tar.gz 136754 BLAKE2B 61feff68d008536d4d31009f4ad18da37ccd0cdab9bfdf151b7112ac66f43bde78f042bc2ad36998fe070428a10a9ba99db5d6d39e9eb74e829a855eb11d1697 SHA512 3507fb8b597617a384508149cb30bdfa8bc8a7b3705782fbf9a943c4be413dc5b7cfb3572b632e8bebbb644ab31f418428ccca996c0d2ba840ad88df1f5a406a
diff --git a/net-misc/s3cmd/files/s3cmd-2.1.0-fix-compatibility-with-Python-3.9.patch b/net-misc/s3cmd/files/s3cmd-2.1.0-fix-compatibility-with-Python-3.9.patch
deleted file mode 100644
index 92d90c6df9b4..000000000000
--- a/net-misc/s3cmd/files/s3cmd-2.1.0-fix-compatibility-with-Python-3.9.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-From 4806955e05011c3d981e91c12a95d84ab3aa65d4 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Ond=C5=99ej=20Budai?= <obudai@redhat.com>
-Date: Fri, 2 Oct 2020 14:24:09 +0200
-Subject: [PATCH] fix compatibility with Python 3.9
-
-getchildren() method was removed from the ElementTree and Element classes in
-Python 3.9. See the release notes:
-
-https://docs.python.org/3.9/whatsnew/3.9.html#removed
----
- S3/Exceptions.py | 2 +-
- S3/Utils.py | 8 ++++----
- 2 files changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/S3/Exceptions.py b/S3/Exceptions.py
-index d12c5c5..2710d82 100644
---- a/S3/Exceptions.py
-+++ b/S3/Exceptions.py
-@@ -126,7 +126,7 @@ class S3Error (S3Exception):
- if not error_node.tag == "Error":
- error_node = tree.find(".//Error")
- if error_node is not None:
-- for child in error_node.getchildren():
-+ for child in error_node:
- if child.text != "":
- debug("ErrorXML: " + child.tag + ": " + repr(child.text))
- info[child.tag] = child.text
-diff --git a/S3/Utils.py b/S3/Utils.py
-index b9f4fd5..1f66f6c 100644
---- a/S3/Utils.py
-+++ b/S3/Utils.py
-@@ -64,9 +64,9 @@ def parseNodes(nodes):
- retval = []
- for node in nodes:
- retval_item = {}
-- for child in node.getchildren():
-+ for child in node:
- name = decode_from_s3(child.tag)
-- if child.getchildren():
-+ if len(child):
- retval_item[name] = parseNodes([child])
- else:
- found_text = node.findtext(".//%s" % child.tag)
-@@ -122,8 +122,8 @@ __all__.append("getListFromXml")
-
- def getDictFromTree(tree):
- ret_dict = {}
-- for child in tree.getchildren():
-- if child.getchildren():
-+ for child in tree:
-+ if len(child):
- ## Complex-type child. Recurse
- content = getDictFromTree(child)
- else:
---
-2.26.3
-
diff --git a/net-misc/s3cmd/s3cmd-2.1.0-r1.ebuild b/net-misc/s3cmd/s3cmd-2.1.0-r1.ebuild
deleted file mode 100644
index 956b31286cec..000000000000
--- a/net-misc/s3cmd/s3cmd-2.1.0-r1.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_7 python3_8 python3_9 )
-PYTHON_REQ_USE="xml(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Command line client for Amazon S3"
-HOMEPAGE="https://s3tools.org/s3cmd"
-SRC_URI="mirror://sourceforge/s3tools/${P/_/-}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 x86 ~amd64-linux ~x64-macos"
-
-RDEPEND="
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/python-magic[${PYTHON_USEDEP}]"
-
-S="${WORKDIR}/${P/_/-}"
-
-PATCHES=( "${FILESDIR}/${P}-fix-compatibility-with-Python-3.9.patch" )
diff --git a/net-misc/s3cmd/s3cmd-2.1.0.ebuild b/net-misc/s3cmd/s3cmd-2.1.0.ebuild
deleted file mode 100644
index e20c06c77889..000000000000
--- a/net-misc/s3cmd/s3cmd-2.1.0.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_7 python3_8 python3_9 )
-PYTHON_REQ_USE="xml(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Command line client for Amazon S3"
-HOMEPAGE="https://s3tools.org/s3cmd"
-SRC_URI="mirror://sourceforge/s3tools/${P/_/-}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 x86 ~amd64-linux ~x64-macos"
-
-RDEPEND="
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/python-magic[${PYTHON_USEDEP}]"
-
-S="${WORKDIR}/${P/_/-}"