summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pypy3-bin')
-rw-r--r--dev-python/pypy3-bin/files/4.0.0-gentoo-path.patch50
-rw-r--r--dev-python/pypy3-bin/pypy3-bin-2.4.0-r2.ebuild2
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-python/pypy3-bin/files/4.0.0-gentoo-path.patch b/dev-python/pypy3-bin/files/4.0.0-gentoo-path.patch
new file mode 100644
index 000000000000..cf96d3fb2a53
--- /dev/null
+++ b/dev-python/pypy3-bin/files/4.0.0-gentoo-path.patch
@@ -0,0 +1,50 @@
+From 165e05bbdc93e54411217c0198d0a5cbb9de4e33 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Fri, 27 Nov 2015 17:02:42 +0100
+Subject: [PATCH] Gentoo: override paths for system-wide install based on
+ sys.prefix
+
+Override all default distutils install paths to ones suitable for
+system-wide install when sys.prefix indicates we're running the Gentoo
+system-wide install of PyPy with no prefix overrides (e.g. virtualenv).
+
+Fixes: https://bugs.gentoo.org/462306
+Fixes: https://bugs.gentoo.org/465546
+---
+ lib-python/3/distutils/command/install.py | 13 ++++++++++++-
+ 1 file changed, 12 insertions(+), 1 deletion(-)
+
+diff --git a/lib-python/3/distutils/command/install.py b/lib-python/3/distutils/command/install.py
+index fc43951..fed5218 100644
+--- a/lib-python/3/distutils/command/install.py
++++ b/lib-python/3/distutils/command/install.py
+@@ -90,6 +90,13 @@ INSTALL_SCHEMES = {
+ 'scripts': '$base/bin',
+ 'data' : '$base',
+ },
++ 'gentoo': {
++ 'purelib': '$base/site-packages',
++ 'platlib': '$base/site-packages',
++ 'headers': '$base/include',
++ 'scripts': '@EPREFIX@/usr/bin',
++ 'data' : '@EPREFIX@/usr',
++ },
+ }
+
+ # The keys to an installation scheme; if any new types of files are to be
+@@ -476,7 +483,11 @@ class install (Command):
+ # it's the caller's problem if they supply a bad name!
+ if (hasattr(sys, 'pypy_version_info') and
+ not name.endswith(('_user', '_home'))):
+- name = 'pypy'
++ if self.install_base == os.path.normpath('@EPREFIX@/usr/@libdir@/pypy3'):
++ # override paths for system-wide install
++ name = 'gentoo'
++ else:
++ name = 'pypy'
+ scheme = INSTALL_SCHEMES[name]
+ for key in SCHEME_KEYS:
+ attrname = 'install_' + key
+--
+2.6.3
+
diff --git a/dev-python/pypy3-bin/pypy3-bin-2.4.0-r2.ebuild b/dev-python/pypy3-bin/pypy3-bin-2.4.0-r2.ebuild
index aa19868e5bb3..fd93b92918fd 100644
--- a/dev-python/pypy3-bin/pypy3-bin-2.4.0-r2.ebuild
+++ b/dev-python/pypy3-bin/pypy3-bin-2.4.0-r2.ebuild
@@ -78,7 +78,7 @@ PDEPEND="app-admin/python-updater"
S=${WORKDIR}/pypy3-${PV}-src
src_prepare() {
- epatch "${FILESDIR}/1.9-scripts-location.patch" \
+ epatch "${FILESDIR}/4.0.0-gentoo-path.patch" \
"${FILESDIR}/1.9-distutils.unixccompiler.UnixCCompiler.runtime_library_dir_option.patch" \
"${FILESDIR}/2.4.0-ncurses6.patch"