summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.34.113.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 7fada2a9b4e7..49945ffdeadc 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -5,4 +5,5 @@ DIST botocore-1.34.109.gh.tar.gz 13036889 BLAKE2B aa755b6078a98214cf3a602283a121
DIST botocore-1.34.110.gh.tar.gz 13056986 BLAKE2B 815a24b950228b3e8e85867a9ac391af8ededbff9684d09c37a9b799be051ab2fe09db925d975ac9a8c6ecfe079df3ea7be967d5d49f7913ee9f5b881658bbcd SHA512 59028c45ed775b1ca84714480b263dc1c607ef53eaf970538fcfbf091a62bc1b2495616cb619ff5d74ca8ec4ca6b6fa8d9f5f0b81313652b9ead3ec7ccdba778
DIST botocore-1.34.111.gh.tar.gz 13059351 BLAKE2B 753b2639104035679c73f2723fbcaaea1c02a912be9492e7e2d9b208c1c04595efe43e1bd1d12d85c47d063ad8f196b0c271106636a62b788d1632be03fc176a SHA512 498676d52a250df742d538460489a1c06c422dcd7a20c3704ac44561fef02bf2efe1801751c379de30fba35a21f052092a86190585f655e45bc01db8d5d3534a
DIST botocore-1.34.112.gh.tar.gz 13060339 BLAKE2B 33157d7d4fb5b7eb908dce2fa7ef0d61ad3b27952ccbb6677a18a957fdc3bcc56d73e9a48c7ddfa8d9aceff44167e881990c31b4ab1db7b00f3c1142b7b79cd3 SHA512 8790f16ec26ab0c67daf555d93e15768dde9a138e99a8a3c40e68d8f40a04b1ba2be97bce80b1ae94c0d168da0ba3779ff5c340d2f3d4962bab138ff5d80e84a
+DIST botocore-1.34.113.gh.tar.gz 13060395 BLAKE2B 8f9329d613f489f2305d068566940a94199a16e9d538597a86cd916a331245a70c6ad771f0d7d71a05a77a49c86aa8ff6be2ac6cd97c04828cc9f54cb6c5e2ac SHA512 218656c921b7ae6a605d6cca4cb90b76aee2a18541e78189828f2adfbb821fbebac406ba19887c0a07aece72dd4936f41b057fb25611e1b03db4bd11fda66bd6
DIST botocore-1.34.98.gh.tar.gz 13008491 BLAKE2B 0b5c368264cc43c162d158b383535183c0fd0065dc6c5edfd3eaaab842d0607b3cc3b99860fa8dc4ef207b5be1457fce9d143723da29e262f30ecc82c5f9ba66 SHA512 39ccb0082ecd6ed6cc7d3f7cea01d39e8d5e92224e3290a66f86ed00562a1d858f75d006af725d2b857ac891f1b366300b7e4c2d24277d942b5a9b9e2cdba431
diff --git a/dev-python/botocore/botocore-1.34.113.ebuild b/dev-python/botocore/botocore-1.34.113.ebuild
new file mode 100644
index 000000000000..ba6cd2a5d2a2
--- /dev/null
+++ b/dev-python/botocore/botocore-1.34.113.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}