summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/async-lru')
-rw-r--r--dev-python/async-lru/Manifest1
-rw-r--r--dev-python/async-lru/async-lru-1.0.2_p20201029.ebuild36
-rw-r--r--dev-python/async-lru/metadata.xml12
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/async-lru/Manifest b/dev-python/async-lru/Manifest
new file mode 100644
index 000000000000..f97e0cc563ec
--- /dev/null
+++ b/dev-python/async-lru/Manifest
@@ -0,0 +1 @@
+DIST async-lru-17a5d207f603c0c142f01a69fbf6f487b3fef5c4.tar.gz 10486 BLAKE2B 88831686b79ed742d28a202b1b303333c52b604f6e786cd0bccc4141a81d002a2b2daf3a264bf83d40e5218a3aa3209579d99b9e1b358da708ffada50bea2d3e SHA512 3c92b5c2fe149e53889f9c4adba9b88a03815d563b56d45363310c2527d4ebb800147fc8e38847f4b473d424692bfae55f96e482979009fb1a977850fb08b2f1
diff --git a/dev-python/async-lru/async-lru-1.0.2_p20201029.ebuild b/dev-python/async-lru/async-lru-1.0.2_p20201029.ebuild
new file mode 100644
index 000000000000..a8a2f32ddf3c
--- /dev/null
+++ b/dev-python/async-lru/async-lru-1.0.2_p20201029.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+EGIT_COMMIT=17a5d207f603c0c142f01a69fbf6f487b3fef5c4
+DESCRIPTION="Simple lru_cache for asyncio"
+HOMEPAGE="
+ https://github.com/aio-libs/async-lru/
+ https://pypi.org/project/async_lru/"
+SRC_URI="
+ https://github.com/aio-libs/async-lru/archive/${EGIT_COMMIT}.tar.gz
+ -> ${PN}-${EGIT_COMMIT}.tar.gz"
+S=${WORKDIR}/${PN}-${EGIT_COMMIT}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e 's:--cache-clear::' \
+ -e 's:--no-cov-on-fail --cov=async_lru --cov-report=term --cov-report=html::' \
+ -i setup.cfg || die
+
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/async-lru/metadata.xml b/dev-python/async-lru/metadata.xml
new file mode 100644
index 000000000000..79feba24df12
--- /dev/null
+++ b/dev-python/async-lru/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">aio-libs/async-lru</remote-id>
+ <remote-id type="pypi">async_lru</remote-id>
+ </upstream>
+</pkgmetadata>