summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/readargs/readargs-1.2.2.ebuild')
-rw-r--r--dev-haskell/readargs/readargs-1.2.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/readargs/readargs-1.2.2.ebuild b/dev-haskell/readargs/readargs-1.2.2.ebuild
new file mode 100644
index 000000000000..14ff37d890c7
--- /dev/null
+++ b/dev-haskell/readargs/readargs-1.2.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+MY_PN="ReadArgs"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple command line argument parsing"
+HOMEPAGE="http://github.com/rampion/ReadArgs"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/system-filepath-0.4.7:=[profile?] <dev-haskell/system-filepath-0.5:=[profile?]
+ >=dev-haskell/text-0.11.1.13:=[profile?] <dev-haskell/text-12:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hspec-1.3 )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ cabal_chdeps \
+ 'hspec >= 1.3 && < 2.1' 'hspec >= 1.3'
+}