summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hspec-core')
-rw-r--r--dev-haskell/hspec-core/Manifest2
-rw-r--r--dev-haskell/hspec-core/hspec-core-2.1.2.ebuild37
-rw-r--r--dev-haskell/hspec-core/hspec-core-2.1.4.ebuild37
-rw-r--r--dev-haskell/hspec-core/metadata.xml9
4 files changed, 85 insertions, 0 deletions
diff --git a/dev-haskell/hspec-core/Manifest b/dev-haskell/hspec-core/Manifest
new file mode 100644
index 000000000000..120deae440a1
--- /dev/null
+++ b/dev-haskell/hspec-core/Manifest
@@ -0,0 +1,2 @@
+DIST hspec-core-2.1.2.tar.gz 29341 SHA256 70cbba8a880341d18e1676683d3ed9fb914dc9050d91dfc35cadbc7242767ad7 SHA512 5af471a54b9bcfdc76ef8f0293d483b11997d88113cc28899d4148d76404b08f456a04566734d69c6c607904e80ce295dc9364d8d396f17bec748c8a32308c1c WHIRLPOOL 0cfc8c76f841b4d88b6686379feb07a04b79b9f9df58e1320141f28739a3797d5b631ea94f0cbafb221f8205682d29caef9b16fb50b08c375a1fbeca2902f6c9
+DIST hspec-core-2.1.4.tar.gz 29371 SHA256 474a7331052ec931396f1c44ed210b912a04fea4d3b62bf222ce803a03fb4a74 SHA512 71f23c7b4075d5d48fc91b1394d1d1418f89c8756baddabea27ab09430ae982759377cb9f3fca42da72382c19fd8bfd151e89fea122e91faafb91e787bdf7b63 WHIRLPOOL 06f2bc0b956b1947c5136eafb9dea481a170ccf2f8d7cbfb5dcaddbbd4b847bd09340e9beaf84df97fbf99a5e29fd56dd19b870ce67fcb7be20aa2b264e244d1
diff --git a/dev-haskell/hspec-core/hspec-core-2.1.2.ebuild b/dev-haskell/hspec-core/hspec-core-2.1.2.ebuild
new file mode 100644
index 000000000000..9a65214f3ee3
--- /dev/null
+++ b/dev-haskell/hspec-core/hspec-core-2.1.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A Testing Framework for Haskell"
+HOMEPAGE="http://hspec.github.io/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/ansi-terminal-0.5:=[profile?]
+ >=dev-haskell/async-2:=[profile?]
+ dev-haskell/hspec-expectations:=[profile?]
+ >=dev-haskell/hunit-1.2.5:=[profile?]
+ >=dev-haskell/quickcheck-2.5.1:2=[profile?]
+ dev-haskell/quickcheck-io:=[profile?]
+ dev-haskell/random:=[profile?]
+ dev-haskell/setenv:=[profile?]
+ dev-haskell/tf-random:=[profile?]
+ >=dev-haskell/transformers-0.2.2.0:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( >=dev-haskell/hspec-meta-1.12
+ >=dev-haskell/silently-1.2.4 )
+"
diff --git a/dev-haskell/hspec-core/hspec-core-2.1.4.ebuild b/dev-haskell/hspec-core/hspec-core-2.1.4.ebuild
new file mode 100644
index 000000000000..c9fb8f701533
--- /dev/null
+++ b/dev-haskell/hspec-core/hspec-core-2.1.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A Testing Framework for Haskell"
+HOMEPAGE="http://hspec.github.io/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/ansi-terminal-0.5:=[profile?]
+ >=dev-haskell/async-2:=[profile?]
+ dev-haskell/hspec-expectations:=[profile?]
+ >=dev-haskell/hunit-1.2.5:=[profile?]
+ >=dev-haskell/quickcheck-2.5.1:2=[profile?]
+ dev-haskell/quickcheck-io:=[profile?]
+ dev-haskell/random:=[profile?]
+ dev-haskell/setenv:=[profile?]
+ dev-haskell/tf-random:=[profile?]
+ >=dev-haskell/transformers-0.2.2.0:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( >=dev-haskell/hspec-meta-1.12
+ >=dev-haskell/silently-1.2.4 )
+"
diff --git a/dev-haskell/hspec-core/metadata.xml b/dev-haskell/hspec-core/metadata.xml
new file mode 100644
index 000000000000..fd25c469363b
--- /dev/null
+++ b/dev-haskell/hspec-core/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ This package exposes internal types and functions that can be
+ used to extend Hspec&#39;s functionality.
+ </longdescription>
+</pkgmetadata>