summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/mandoc')
-rw-r--r--app-text/mandoc/mandoc-1.14.6.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/app-text/mandoc/mandoc-1.14.6.ebuild b/app-text/mandoc/mandoc-1.14.6.ebuild
index 9af875d1eed0..a4127ae75473 100644
--- a/app-text/mandoc/mandoc-1.14.6.ebuild
+++ b/app-text/mandoc/mandoc-1.14.6.ebuild
@@ -12,7 +12,8 @@ SRC_URI="https://mdocml.bsd.lv/snapshots/${P}.tar.gz"
LICENSE="ISC"
SLOT="0"
KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~loong ~ppc ppc64 ~riscv ~s390 ~sparc x86"
-IUSE="cgi selinux system-man"
+IUSE="cgi selinux system-man test"
+RESTRICT="!test? ( test )"
RDEPEND="sys-libs/zlib
system-man? ( !sys-apps/man-db )
@@ -22,6 +23,7 @@ DEPEND="${RDEPEND}
"
BDEPEND="
cgi? ( app-text/highlight )
+ test? ( dev-lang/perl )
"
RDEPEND+=" selinux? ( sec-policy/selinux-makewhatis )"
@@ -107,6 +109,10 @@ src_compile() {
use cgi && emake man.cgi
}
+src_test() {
+ emake regress
+}
+
src_install() {
emake DESTDIR="${D}" install
use cgi && emake DESTDIR="${D}" cgi-install www-install