summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/bact/bact-0.13.ebuild')
-rw-r--r--app-text/bact/bact-0.13.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-text/bact/bact-0.13.ebuild b/app-text/bact/bact-0.13.ebuild
new file mode 100644
index 000000000000..98d29fb5500b
--- /dev/null
+++ b/app-text/bact/bact-0.13.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="Boosting Algorithm for Classification of Trees"
+HOMEPAGE="http://chasen.org/~taku/software/bact/"
+SRC_URI="http://chasen.org/~taku/software/bact/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ dobin bact_learn bact_mkmodel bact_classify
+
+ dohtml index.html bact.css
+ dodoc README AUTHORS
+}