summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/moar/Manifest2
-rw-r--r--sys-apps/moar/moar-1.18.4.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/moar/Manifest b/sys-apps/moar/Manifest
index c836bb9c6a86..c2ebb5c62553 100644
--- a/sys-apps/moar/Manifest
+++ b/sys-apps/moar/Manifest
@@ -4,3 +4,5 @@ DIST moar-1.18.2-deps.tar.xz 4893264 BLAKE2B 48ac9d4992c2f6d1aa0f9160bde87bd19d6
DIST moar-1.18.2.tar.gz 2784141 BLAKE2B 0ed2df0926390ef1de11cefb8933d39e90b704d943afe83e578adee745c0e27411e7f8b3741766176b6d66b44ee56592d8d0b84484d5e83d360dc4039428b3d4 SHA512 552e9fb635c554f16c250db1702314e34d2f961cbbd50106b696c096b31f2e7f86109e99c843911829905bb5390716f642ce0ebe70f0f1b71cada1b47c53e17a
DIST moar-1.18.3-deps.tar.xz 4893264 BLAKE2B 48ac9d4992c2f6d1aa0f9160bde87bd19d66acfe912753645c9dbb6e5bc007eb68caf1fff53bae84b03e4a6607858717666b1527bf8d0080b0aca6dbb37a894e SHA512 bf141777d4fee5c14e76130671862f255675da3c628c21cb892d53a469a0872d4c7f47699c16c50728df76ba4d9e467e9b8744a322c1acc8d0151f9eb5987b66
DIST moar-1.18.3.tar.gz 2784912 BLAKE2B 8ad06cfb0c21225e5b949d39adbadadef98e4e4292432cd3e6533240afa416118fb9a9d21b06d6bdf85a6f2a19b90f09c3e298db24fec755a168423e85dc9c64 SHA512 81e54889fa0a12d127abc5596fd820d5adc5f5162adedd7125cf9e8cbd0cb0dc75c5570a1504b2c68e063880e77df4299d7830a44479c6690f6ba48ec97ea4ac
+DIST moar-1.18.4-deps.tar.xz 4893264 BLAKE2B 48ac9d4992c2f6d1aa0f9160bde87bd19d66acfe912753645c9dbb6e5bc007eb68caf1fff53bae84b03e4a6607858717666b1527bf8d0080b0aca6dbb37a894e SHA512 bf141777d4fee5c14e76130671862f255675da3c628c21cb892d53a469a0872d4c7f47699c16c50728df76ba4d9e467e9b8744a322c1acc8d0151f9eb5987b66
+DIST moar-1.18.4.tar.gz 2785962 BLAKE2B 9fdce78371e99a2e8b6be79ee6b16e880a670ace989013898ea23a84b9a8701a7832519108c03503e6a021fb34b518cc57642b08f2ae404a182cfe58157fe3ee SHA512 4ce60f3a57241058fce83a1663e6aea6f3eb485a80a433243d76e522ee2cdd8bbec94913820d50949610f923d975cfa2588cf11e7824c3cf0f3beb38988a2a00
diff --git a/sys-apps/moar/moar-1.18.4.ebuild b/sys-apps/moar/moar-1.18.4.ebuild
new file mode 100644
index 000000000000..25abd2aac1ff
--- /dev/null
+++ b/sys-apps/moar/moar-1.18.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Pager designed to do the right thing without any configuration"
+HOMEPAGE="https://github.com/walles/moar"
+SRC_URI="https://github.com/walles/moar/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="BSD-2 BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# moarvm: https://github.com/walles/moar/issues/143
+RDEPEND="!dev-lang/moarvm"
+BDEPEND="
+ test? (
+ app-arch/bzip2
+ app-arch/xz-utils
+ )
+"
+
+src_compile() {
+ # https://github.com/walles/moar/blob/master/build.sh#L28
+ ego build -ldflags="-w -X main.versionString=${PV}" -o moar
+}
+
+src_test() {
+ # From test.sh (we don't run that because it has some linting etc)
+ ego test -timeout 20s ./...
+}
+
+src_install() {
+ dobin moar
+ doman moar.1
+ einstalldocs
+}