summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/vkd3d-proton/vkd3d-proton-2.10.ebuild5
-rw-r--r--app-emulation/vkd3d-proton/vkd3d-proton-2.11.1.ebuild5
-rw-r--r--app-emulation/vkd3d-proton/vkd3d-proton-2.12.ebuild5
-rw-r--r--app-emulation/vkd3d-proton/vkd3d-proton-2.6-r1.ebuild5
-rw-r--r--app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild5
5 files changed, 25 insertions, 0 deletions
diff --git a/app-emulation/vkd3d-proton/vkd3d-proton-2.10.ebuild b/app-emulation/vkd3d-proton/vkd3d-proton-2.10.ebuild
index fb54dd38775d..d62c6a6a6518 100644
--- a/app-emulation/vkd3d-proton/vkd3d-proton-2.10.ebuild
+++ b/app-emulation/vkd3d-proton/vkd3d-proton-2.10.ebuild
@@ -110,6 +110,11 @@ src_prepare() {
src_configure() {
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
+ # random segfaults been reported with LTO in some games, filter as
+ # a safety (note that optimizing this further won't really help
+ # performance, GPU does the actual work)
+ filter-lto
+
# -mavx with mingw-gcc has a history of obscure issues and
# disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
# crashes with -march=skylake >=wine-8.10, similar issues with
diff --git a/app-emulation/vkd3d-proton/vkd3d-proton-2.11.1.ebuild b/app-emulation/vkd3d-proton/vkd3d-proton-2.11.1.ebuild
index 1eed493adf7a..dca027f8359a 100644
--- a/app-emulation/vkd3d-proton/vkd3d-proton-2.11.1.ebuild
+++ b/app-emulation/vkd3d-proton/vkd3d-proton-2.11.1.ebuild
@@ -108,6 +108,11 @@ src_prepare() {
src_configure() {
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
+ # random segfaults been reported with LTO in some games, filter as
+ # a safety (note that optimizing this further won't really help
+ # performance, GPU does the actual work)
+ filter-lto
+
# -mavx with mingw-gcc has a history of obscure issues and
# disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
# crashes with -march=skylake >=wine-8.10, similar issues with
diff --git a/app-emulation/vkd3d-proton/vkd3d-proton-2.12.ebuild b/app-emulation/vkd3d-proton/vkd3d-proton-2.12.ebuild
index c107c315e595..1190df8cfcb2 100644
--- a/app-emulation/vkd3d-proton/vkd3d-proton-2.12.ebuild
+++ b/app-emulation/vkd3d-proton/vkd3d-proton-2.12.ebuild
@@ -114,6 +114,11 @@ src_prepare() {
src_configure() {
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
+ # random segfaults been reported with LTO in some games, filter as
+ # a safety (note that optimizing this further won't really help
+ # performance, GPU does the actual work)
+ filter-lto
+
# -mavx with mingw-gcc has a history of obscure issues and
# disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
# crashes with -march=skylake >=wine-8.10, similar issues with
diff --git a/app-emulation/vkd3d-proton/vkd3d-proton-2.6-r1.ebuild b/app-emulation/vkd3d-proton/vkd3d-proton-2.6-r1.ebuild
index 912055248d4b..32e103ce091f 100644
--- a/app-emulation/vkd3d-proton/vkd3d-proton-2.6-r1.ebuild
+++ b/app-emulation/vkd3d-proton/vkd3d-proton-2.6-r1.ebuild
@@ -105,6 +105,11 @@ src_prepare() {
src_configure() {
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
+ # random segfaults been reported with LTO in some games, filter as
+ # a safety (note that optimizing this further won't really help
+ # performance, GPU does the actual work)
+ filter-lto
+
# -mavx with mingw-gcc has a history of obscure issues and
# disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
# crashes with -march=skylake >=wine-8.10, similar issues with
diff --git a/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild b/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild
index 3279df434dc9..5f2131de62c5 100644
--- a/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild
+++ b/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild
@@ -114,6 +114,11 @@ src_prepare() {
src_configure() {
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
+ # random segfaults been reported with LTO in some games, filter as
+ # a safety (note that optimizing this further won't really help
+ # performance, GPU does the actual work)
+ filter-lto
+
# -mavx with mingw-gcc has a history of obscure issues and
# disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
# crashes with -march=skylake >=wine-8.10, similar issues with