summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/toml/Manifest2
-rw-r--r--dev-python/toml/toml-0.10.0.ebuild (renamed from dev-python/toml/toml-0.9.6.ebuild)8
2 files changed, 6 insertions, 4 deletions
diff --git a/dev-python/toml/Manifest b/dev-python/toml/Manifest
index 396b35e761c1..89d930e04081 100644
--- a/dev-python/toml/Manifest
+++ b/dev-python/toml/Manifest
@@ -1 +1 @@
-DIST toml-0.9.6.tar.gz 14074 BLAKE2B 758dbde35e1afacad8456cfac42354f3205d2d1ae79ceeea1803fe253472e3299ba171ce9435529f64fd8a31adc7cc1c05282a76a47118b7aa0e3ed61ccacc25 SHA512 9f2804daebae0744c3a00bfb27b2f1efd73c96e7e5a14316d492200d63ba546167f669a187297c76daca5ef35b7adb6f309c1f6129302b6f41e6b7673bdb43b6
+DIST toml-0.10.0.tar.gz 16719 BLAKE2B f7863e9cf0ca5185a59d64010346b4b960c40bc3711d4cbd1ad907d15da823319b748df1a5536465e9f36428bf1599624ede3b1fa68cb420684a52ba137227c9 SHA512 26f26c38ce9cd48305218c2c34c5a5407b00aefc25a933f044bb7be22c23cfdfa3b8cf2da952d17760c4b9038df62e405fa039cc7b63dd3e94c9c312f04f9182
diff --git a/dev-python/toml/toml-0.9.6.ebuild b/dev-python/toml/toml-0.10.0.ebuild
index 528467cd42e5..d50fd3ab181f 100644
--- a/dev-python/toml/toml-0.9.6.ebuild
+++ b/dev-python/toml/toml-0.10.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} pypy{,3} )
inherit distutils-r1
@@ -15,6 +15,8 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+# peculiar testing depending on https://github.com/BurntSushi/toml-test. Not
+# particularly worth the trouble.
RESTRICT="test"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"