summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-containers/buildah/Manifest2
-rw-r--r--app-containers/buildah/buildah-1.32.0.ebuild84
-rw-r--r--app-containers/buildah/buildah-1.32.1.ebuild118
3 files changed, 0 insertions, 204 deletions
diff --git a/app-containers/buildah/Manifest b/app-containers/buildah/Manifest
index a0b8af325967..eb4061f349a2 100644
--- a/app-containers/buildah/Manifest
+++ b/app-containers/buildah/Manifest
@@ -1,5 +1,3 @@
DIST buildah-1.30.0.tar.gz 15623786 BLAKE2B e0b2f6d26827cfe40f88a9915f12b6acb385fbd576fa227d4fee02c162077e9c6fe0591c7171405f5645cd06e4068f26e17c2cb963898e38cfbdd61abe68dae2 SHA512 185fd98a59fa8d86fe9f1eadc9b7591e5053674464be10538a7581d8e1f6a25e5032a354c821c32a167e2864acea010243efbbe4f5a4205d8eaa2894f062a25b
-DIST buildah-1.32.0.tar.gz 18445843 BLAKE2B d7471e3f0733bc626f665c592701666ba41732eb53bf4679da7e9e28dad388532ab8c88e86db553790ced7822168fd6388dc08121e1456404f18a5d96017da60 SHA512 7c61141e43ea2f968a50b4c5ae6b69c2b9734a19774c7ca48bc942b900ca55ec381ac93fdf04f08061640a457551a9e03a45a37d22cb94b34cecded192dced8f
-DIST buildah-1.32.1.tar.gz 18452695 BLAKE2B b4f3644a046d0dd96555b810e488ea78dc396692e539978856fbc2b22010bce3ed9f578949e8de02579325fa59e00fba59908724952b8c323889c816ae4f1af6 SHA512 e5c59f158b786809c89465361a662211bbef6bb4c27c79490604923d924c2030398a0878b122b246b02ae246bd977b7ccffdc6de4f06e80f096c2921c34bf04a
DIST buildah-1.32.2.tar.gz 18451694 BLAKE2B 885b940e804394d18451e5dce3e3af4097a8adf01e59d7a288dda7063a888759abd9a5c18d8f4522709c7d296fc9a2b5d61229143f3545a786dc59ac837214e2 SHA512 3a50e53e047aa0e23643d8751af1fb51a83fd51e5440111432eb34bdb07e95f24676a917b54409c223df444fe123c8df4aa9af435737cfdd02d0eda0d3f5bba1
DIST buildah-1.33.0.tar.gz 18632278 BLAKE2B f5984aa01fbe4957de07c5925795ceb106af07fc05f2f772ff8a5812f8ebcc5b9e86ec1d2f04bda5fa0e264a1c904f74a6e8795e1af8a0dbe9e1dabfe5832bc9 SHA512 926c748bd9dbbaf86e266dec778ecf31c65c58016f09ae8b6f9e570a6603fd9c6fc72db4b8c371e999ecb4e1a2cb2429082da66bd8069916652318a0362b40da
diff --git a/app-containers/buildah/buildah-1.32.0.ebuild b/app-containers/buildah/buildah-1.32.0.ebuild
deleted file mode 100644
index 99b52da91893..000000000000
--- a/app-containers/buildah/buildah-1.32.0.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit bash-completion-r1 go-module linux-info
-GIT_COMMIT=2326d49
-
-DESCRIPTION="A tool that facilitates building OCI images"
-HOMEPAGE="https://github.com/containers/buildah"
-SRC_URI="https://github.com/containers/buildah/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-IUSE="btrfs systemd doc test"
-RESTRICT="test"
-
-DEPEND="
- systemd? ( sys-apps/systemd )
- btrfs? ( sys-fs/btrfs-progs )
- app-crypt/gpgme:=
- dev-libs/libgpg-error:=
- dev-libs/libassuan:=
- sys-apps/shadow:=
- sys-libs/libseccomp:=
-"
-RDEPEND="${DEPEND}"
-
-pkg_pretend() {
- local CONFIG_CHECK=""
- use btrfs && CONFIG_CHECK+=" ~BTRFS_FS"
- check_extra_config
-
- if ! linux_config_exists; then
- ewarn "Cannot determine configuration of your kernel."
- fi
-}
-
-src_prepare() {
- default
-
- [[ -f hack/systemd_tag.sh ]] || die
- if use systemd; then
- echo -e '#!/usr/bin/env bash\necho systemd' > hack/systemd_tag.sh || die
- else
- echo -e '#!/usr/bin/env bash\necho' > hack/systemd_tag.sh || die
- fi
-
- [[ -f btrfs_installed_tag.sh ]] || die
- [[ -f btrfs_tag.sh ]] || die
- if use btrfs; then
- echo -e '#!/usr/bin/env bash\necho btrfs_noversion' > btrfs_tag.sh || die
- else
- echo -e '#!/usr/bin/env bash\necho exclude_graphdriver_btrfs' > btrfs_installed_tag.sh || die
- fi
-
- if ! use test; then
- cat << 'EOF' > "${T}/Makefile.patch"
---- Makefile
-+++ Makefile
-@@ -54 +54 @@
--all: bin/buildah bin/imgtype bin/copy bin/tutorial docs
-+all: bin/buildah docs
-EOF
- eapply -p0 "${T}/Makefile.patch"
- fi
-}
-
-src_compile() {
- emake GIT_COMMIT=${GIT_COMMIT} all
-}
-
-src_test() {
- emake test-unit
-}
-
-src_install() {
- use doc && dodoc CHANGELOG.md CONTRIBUTING.md README.md install.md troubleshooting.md
- use doc && dodoc -r docs/tutorials
- doman docs/*.1
- dobin bin/${PN}
- dobashcomp contrib/completions/bash/buildah
-}
diff --git a/app-containers/buildah/buildah-1.32.1.ebuild b/app-containers/buildah/buildah-1.32.1.ebuild
deleted file mode 100644
index ffbc1878df1b..000000000000
--- a/app-containers/buildah/buildah-1.32.1.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit go-module linux-info
-
-DESCRIPTION="A tool that facilitates building OCI images"
-HOMEPAGE="https://github.com/containers/buildah"
-# main pkg
-LICENSE="Apache-2.0"
-# deps
-LICENSE+=" BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
-
-SLOT="0"
-IUSE="apparmor btrfs +seccomp systemd doc test"
-RESTRICT="test"
-EXTRA_DOCS=(
- "CHANGELOG.md"
- "CONTRIBUTING.md"
- "install.md"
- "troubleshooting.md"
- "docs/tutorials"
-)
-
-if [[ ${PV} == 9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/containers/buildah.git"
-else
- SRC_URI="https://github.com/containers/buildah/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64"
-fi
-
-RDEPEND="
- systemd? ( sys-apps/systemd )
- btrfs? ( sys-fs/btrfs-progs )
- seccomp? ( sys-libs/libseccomp:= )
- apparmor? ( sys-libs/libapparmor:= )
- app-crypt/gpgme:=
- dev-libs/libgpg-error:=
- dev-libs/libassuan:=
- sys-apps/shadow:=
-"
-DEPEND="${RDEPEND}"
-
-export COMMIT_NO=bfd436d159059b45d770a0fc62386c9e0b9bdbb1
-export GIT_COMMIT=${COMMIT_NO}
-
-pkg_pretend() {
- local CONFIG_CHECK=""
- use btrfs && CONFIG_CHECK+=" ~BTRFS_FS"
- check_extra_config
-
- linux_config_exists || ewarn "Cannot determine configuration of your kernel."
-}
-
-src_prepare() {
- default
-
- # ensure all necessary files are there
- local file
- for file in docs/Makefile hack/libsubid_tag.sh hack/apparmor_tag.sh \
- hack/systemd_tag.sh btrfs_installed_tag.sh btrfs_tag.sh; do
- [[ -f "${file}" ]] || die
- done
-
- sed -i -e "s|/usr/local|${EPREFIX}/usr|g" Makefile docs/Makefile || die
- echo -e '#!/usr/bin/env bash\necho libsubid' > hack/libsubid_tag.sh || die
-
- cat <<-EOF > hack/apparmor_tag.sh || die
- #!/usr/bin/env bash
- $(usex apparmor 'echo apparmor' echo)
- EOF
-
- use seccomp || {
- cat <<-'EOF' > "${T}/disable_seccomp.patch"
- --- a/Makefile
- +++ b/Makefile
- @@ -5 +5 @@
- -SECURITYTAGS ?= seccomp $(APPARMORTAG)
- +SECURITYTAGS ?= $(APPARMORTAG)
- EOF
- eapply "${T}/disable_seccomp.patch" || die
- }
-
- cat <<-EOF > hack/systemd_tag.sh || die
- #!/usr/bin/env bash
- $(usex systemd 'echo systemd' echo)
- EOF
-
- echo -e "#!/usr/bin/env bash\n echo" > btrfs_installed_tag.sh || die
- cat <<-EOF > btrfs_tag.sh || die
- #!/usr/bin/env bash
- $(usex btrfs echo 'echo exclude_graphdriver_btrfs btrfs_noversion')
- EOF
-
- use test || {
- cat <<-'EOF' > "${T}/disable_tests.patch"
- --- a/Makefile
- +++ b/Makefile
- @@ -54 +54 @@
- -all: bin/buildah bin/imgtype bin/copy bin/tutorial docs
- +all: bin/buildah docs
- EOF
- eapply "${T}/disable_tests.patch" || die
- }
-
-}
-
-src_test() {
- emake test-unit
-}
-
-src_install() {
- emake DESTDIR="${D}" install install.completions
- einstalldocs
- use doc && dodoc -r "${EXTRA_DOCS[@]}"
-}