summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/wurlitzer/Manifest1
-rw-r--r--dev-python/wurlitzer/wurlitzer-2.0.1.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/wurlitzer/Manifest b/dev-python/wurlitzer/Manifest
index 03996c2f8cd9..ff37e88f7be0 100644
--- a/dev-python/wurlitzer/Manifest
+++ b/dev-python/wurlitzer/Manifest
@@ -1 +1,2 @@
DIST wurlitzer-2.0.0.tar.gz 10203 BLAKE2B 526f1fa1cf2f257c126a4f2c67b27b373b23e113552e72372029ab69a6b629d9453c39feac083c1376e3996a44af8ad823d1ca119515b420d9fefbbf326da38e SHA512 5cafdf84e47e6d18074f6ed3af6bab2eaa1f5cfd3d658ea02a49d387127e9a9101de05c864480af42f5a7650cc47e0a218e822912a4ba3ef826e71206dd2f3e9
+DIST wurlitzer-2.0.1.tar.gz 10638 BLAKE2B e5350a3920ae072f93a0043ec368766d8e190558b3e897e68b272b06d0d6ff7907f2aeecfd41a99b54804a596ad9f7d7062995a5c465724a2b87419ee801daa3 SHA512 06f67b666c2a364b5ee497fa2f0ab8640aeb2953b678e35b13e1558ab29bc5554f479731f9942d8f033275f5151bb9f86408e0f04b1120bae0f29b27649d783c
diff --git a/dev-python/wurlitzer/wurlitzer-2.0.1.ebuild b/dev-python/wurlitzer/wurlitzer-2.0.1.ebuild
new file mode 100644
index 000000000000..f920b819d1d0
--- /dev/null
+++ b/dev-python/wurlitzer/wurlitzer-2.0.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Capture C-level stdout/stderr in Python"
+HOMEPAGE="https://github.com/minrk/wurlitzer https://pypi.org/project/wurlitzer"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ pytest -vv test.py || die "Tests fail with ${EPYTHON}"
+}