summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-29 12:27:34 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-29 12:27:34 +0100
commit09ee697ec4f4651b252199763be8dc50f8e3e634 (patch)
treed4ab8fec1ebdd3a7fee8a8f81f5e9e1e26ba1c09 /xfce-base
parentdev-tcltk/itk: fix ITCL version (diff)
downloadgentoo-09ee697ec4f4651b252199763be8dc50f8e3e634.tar.gz
gentoo-09ee697ec4f4651b252199763be8dc50f8e3e634.tar.bz2
gentoo-09ee697ec4f4651b252199763be8dc50f8e3e634.zip
xfce-base/libxfce4windowing: Bump to 4.19.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/libxfce4windowing/Manifest1
-rw-r--r--xfce-base/libxfce4windowing/libxfce4windowing-4.19.3.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/xfce-base/libxfce4windowing/Manifest b/xfce-base/libxfce4windowing/Manifest
index cb6eaad1cabf..97d0e1315485 100644
--- a/xfce-base/libxfce4windowing/Manifest
+++ b/xfce-base/libxfce4windowing/Manifest
@@ -1 +1,2 @@
DIST libxfce4windowing-4.19.1.tar.bz2 452748 BLAKE2B 0fbf8ec5bb1d1857dfbe2851ef25a63dca57315c9f9dd5e3d870ae86c5fa054e3f4915d7cef1c98a5ac909ff29e8ad47b5b2754d1c8b2199320ee4a5efcf2eae SHA512 4666ff3a0142f584fb62cff8e6271a73bc3da8f1cd6dad629e3075a5a2552f54d56abb44bc6d9b2c1b4a1c8ed131bd6aa875714191cffd28958a2edf09a90729
+DIST libxfce4windowing-4.19.3.tar.bz2 535825 BLAKE2B cb97589e213e4d07f05c6665399459f2f453a9519483606c5a5e3bd901bebbc361ae044f22596bca86c7aa8e0b23b585b7a41f0170d458d597f07b0a03e08edd SHA512 848b7aeeebdd630c27bac242b5a59d25409b2e8f22d2d8dc95fbfe45357e4f3374e36c151792ddc061b4dcf5d1fdf31f47e76c75b7167b244ae198b0a3b4bca0
diff --git a/xfce-base/libxfce4windowing/libxfce4windowing-4.19.3.ebuild b/xfce-base/libxfce4windowing/libxfce4windowing-4.19.3.ebuild
new file mode 100644
index 000000000000..89c2dd192a50
--- /dev/null
+++ b/xfce-base/libxfce4windowing/libxfce4windowing-4.19.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Unified widget and session management libs for Xfce"
+HOMEPAGE="https://gitlab.xfce.org/xfce/libxfce4windowing/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+introspection wayland X"
+REQUIRED_USE="|| ( wayland X )"
+
+DEPEND="
+ >=dev-libs/glib-2.68.0
+ >=x11-libs/gtk+-3.24.0:3[X?,introspection?,wayland?]
+ >=x11-libs/gdk-pixbuf-2.40.0[introspection?]
+ wayland? (
+ >=dev-libs/wayland-1.15
+ )
+ X? (
+ >=x11-libs/libX11-1.6.7
+ >=x11-libs/libwnck-3.14:3
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-lang/perl
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ wayland? (
+ >=dev-util/wayland-scanner-1.15
+ )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable wayland)
+ $(use_enable X x11)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}