summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilipp Rösner <rndxelement@protonmail.com>2022-05-29 22:21:31 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-06-23 12:16:55 +0300
commita463bb99d67e4588e96c58f9dd43e554f85bcc0c (patch)
treefaed525ef2f542a5c46d83d1b1de2f361f945244 /x11-wm/cwm/cwm-7.1.ebuild
parentdev-python/scipy: arm stable wrt bug #853388 (diff)
downloadgentoo-a463bb99d67e4588e96c58f9dd43e554f85bcc0c.tar.gz
gentoo-a463bb99d67e4588e96c58f9dd43e554f85bcc0c.tar.bz2
gentoo-a463bb99d67e4588e96c58f9dd43e554f85bcc0c.zip
x11-wm/cwm: add 7.1
Add an ebuild for cwm-7.1. Closes: https://bugs.gentoo.org/847529 Signed-off-by: Philipp Rösner <rndxelement@protonmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-wm/cwm/cwm-7.1.ebuild')
-rw-r--r--x11-wm/cwm/cwm-7.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-wm/cwm/cwm-7.1.ebuild b/x11-wm/cwm/cwm-7.1.ebuild
new file mode 100644
index 000000000000..0697ed5e0269
--- /dev/null
+++ b/x11-wm/cwm/cwm-7.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop toolchain-funcs
+
+DESCRIPTION="OpenBSD fork of calmwm, a clean and lightweight window manager"
+HOMEPAGE="https://github.com/leahneukirchen/cwm
+ https://www.openbsd.org/cgi-bin/cvsweb/xenocara/app/cwm/
+"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/leahneukirchen/cwm.git"
+else
+ SRC_URI="https://github.com/leahneukirchen/cwm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+
+DEPEND="x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ sys-devel/bison
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} -D_GNU_SOURCE" CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+ dodoc README
+ make_session_desktop ${PN} ${PN}
+}