summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-07-22 16:53:29 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2018-08-02 22:12:52 +0200
commit66406829655ee583cc1901f6d23b354ba6cbeab8 (patch)
tree56b58bccfdca6493bc4329a0156c43d3534ab9a6 /x11-plugins
parentx11-plugins/wminet: EAPI7, improve ebuild (diff)
downloadgentoo-66406829655ee583cc1901f6d23b354ba6cbeab8.tar.gz
gentoo-66406829655ee583cc1901f6d23b354ba6cbeab8.tar.bz2
gentoo-66406829655ee583cc1901f6d23b354ba6cbeab8.zip
x11-plugins/wmitime: add EAPI7 ebuild
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmitime/wmitime-0.5-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-plugins/wmitime/wmitime-0.5-r1.ebuild b/x11-plugins/wmitime/wmitime-0.5-r1.ebuild
new file mode 100644
index 000000000000..99ccad440497
--- /dev/null
+++ b/x11-plugins/wmitime/wmitime-0.5-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Overglorified clock dockapp w/time, date, and internet time"
+HOMEPAGE="https://www.dockapps.net/wmitime"
+SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=">=x11-libs/libdockapp-0.7:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+ einstalldocs
+}