summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/wmakerconf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/wmakerconf')
-rw-r--r--x11-misc/wmakerconf/Manifest1
-rw-r--r--x11-misc/wmakerconf/files/wmakerconf-2.12-wmaker-0.95_support.patch82
-rw-r--r--x11-misc/wmakerconf/metadata.xml8
-rw-r--r--x11-misc/wmakerconf/wmakerconf-2.12-r1.ebuild54
-rw-r--r--x11-misc/wmakerconf/wmakerconf-2.12.ebuild44
5 files changed, 189 insertions, 0 deletions
diff --git a/x11-misc/wmakerconf/Manifest b/x11-misc/wmakerconf/Manifest
new file mode 100644
index 000000000000..18e2eec2932a
--- /dev/null
+++ b/x11-misc/wmakerconf/Manifest
@@ -0,0 +1 @@
+DIST wmakerconf_2.12.tar.gz 830156 SHA256 debfc3b2a26fd4bd2dab4a06155b786e1b36e64145012410eb0de730a79a9bb3
diff --git a/x11-misc/wmakerconf/files/wmakerconf-2.12-wmaker-0.95_support.patch b/x11-misc/wmakerconf/files/wmakerconf-2.12-wmaker-0.95_support.patch
new file mode 100644
index 000000000000..5b598c3c1542
--- /dev/null
+++ b/x11-misc/wmakerconf/files/wmakerconf-2.12-wmaker-0.95_support.patch
@@ -0,0 +1,82 @@
+diff -Naur wmakerconf-2.12.orig/src/menu.c wmakerconf-2.12/src/menu.c
+--- wmakerconf-2.12.orig/src/menu.c 2012-02-10 17:34:57.601475631 +0100
++++ wmakerconf-2.12/src/menu.c 2012-02-10 17:35:03.917287748 +0100
+@@ -500,10 +500,10 @@
+ * No return value.
+ */
+ {
+- if (!WMWritePropListToFile (orig_wmaker, orig_wmaker_fname, YES))
++ if (!WMWritePropListToFile(orig_wmaker, orig_wmaker_fname))
+ warning (_("Can't revert to backupfile of `WindowMaker'. "
+ "Please manually revert from file WindowMaker.bak."));
+- if (orig_rootmenu && !WMWritePropListToFile (orig_rootmenu, orig_rootmenu_fname, YES))
++ if (orig_rootmenu && !WMWritePropListToFile(orig_rootmenu, orig_rootmenu_fname))
+ warning (_("Can't revert to backupfile of `WMRootMenu'. "
+ "Please manually revert from file WMRootMenu.bak."));
+ gtk_main_quit ();
+diff -Naur wmakerconf-2.12.orig/src/rootmenu.c wmakerconf-2.12/src/rootmenu.c
+--- wmakerconf-2.12.orig/src/rootmenu.c 2012-02-10 17:34:57.601475631 +0100
++++ wmakerconf-2.12/src/rootmenu.c 2012-02-10 17:35:03.929287391 +0100
+@@ -365,7 +365,7 @@
+ node_freeitem, NULL);
+ g_node_destroy (node);
+
+- if (WMWritePropListToFile (menu, filename, YES))
++ if (WMWritePropListToFile(menu, filename))
+ {
+ menu_changed = NO;
+ message (_("Window Maker root menu file '%s' saved."), filename);
+diff -Naur wmakerconf-2.12.orig/src/themebrowser.c wmakerconf-2.12/src/themebrowser.c
+--- wmakerconf-2.12.orig/src/themebrowser.c 2012-02-10 17:34:57.601475631 +0100
++++ wmakerconf-2.12/src/themebrowser.c 2012-02-10 17:35:56.515722786 +0100
+@@ -2705,7 +2705,7 @@
+ oldfiles = g_list_remove (oldfiles, tmp);
+ Free (tmp);
+ }
+- if (!WMWritePropListToFile (theme, stylename, YES))
++ if (!WMWritePropListToFile(theme, stylename))
+ {
+ dialog_popup (DIALOG_ERROR, NULL, NULL,
+ _("Can't save theme file\n`%s'\n"
+diff -Naur wmakerconf-2.12.orig/src/window.c wmakerconf-2.12/src/window.c
+--- wmakerconf-2.12.orig/src/window.c 2012-02-10 17:34:57.601475631 +0100
++++ wmakerconf-2.12/src/window.c 2012-02-10 17:35:03.953286677 +0100
+@@ -1069,7 +1069,7 @@
+ WMReleasePropList (all_keys);
+ }
+
+- if (WMWritePropListToFile (newwm, orig_wmaker_fname, YES))
++ if (WMWritePropListToFile(newwm, orig_wmaker_fname))
+ {
+ changed = NO;
+ message (_("Window Maker config file '%s' saved."),
+diff -Naur wmakerconf-2.12.orig/src/wmconfig.c wmakerconf-2.12/src/wmconfig.c
+--- wmakerconf-2.12.orig/src/wmconfig.c 2012-02-10 17:34:57.601475631 +0100
++++ wmakerconf-2.12/src/wmconfig.c 2012-02-10 17:35:03.957286559 +0100
+@@ -216,7 +216,7 @@
+ /*
+ * Generate backup file "'path'.bak"
+ */
+- if (WMWritePropListToFile (orig_rootmenu, new, YES))
++ if (WMWritePropListToFile(orig_rootmenu, new))
+ message (_("Backupfile `%s' generated."), new);
+ else
+ error (_("Can't write backupfile `%s'."), new);
+@@ -280,7 +280,7 @@
+ if (!windowmaker)
+ {
+ windowmaker = global_windowmaker;
+- if (WMWritePropListToFile (windowmaker, orig_wmaker_fname, YES))
++ if (WMWritePropListToFile(windowmaker, orig_wmaker_fname))
+ warning (_("New WindowMaker configuration file `%s' created."),
+ orig_wmaker_fname);
+ else
+@@ -294,7 +294,7 @@
+ /*
+ * Generate backup file "'path'.bak"
+ */
+- if (WMWritePropListToFile (windowmaker, new, YES))
++ if (WMWritePropListToFile(windowmaker, new))
+ message (_("Backupfile `%s' generated."), new);
+ else
+ error (_("Can't write backupfile `%s'."), new);
diff --git a/x11-misc/wmakerconf/metadata.xml b/x11-misc/wmakerconf/metadata.xml
new file mode 100644
index 000000000000..1f7c89842d5d
--- /dev/null
+++ b/x11-misc/wmakerconf/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnustep</herd>
+ <upstream>
+ <remote-id type="sourceforge">wmakerconf</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/wmakerconf/wmakerconf-2.12-r1.ebuild b/x11-misc/wmakerconf/wmakerconf-2.12-r1.ebuild
new file mode 100644
index 000000000000..13808a5c7f18
--- /dev/null
+++ b/x11-misc/wmakerconf/wmakerconf-2.12-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="X based config tool for the windowmaker X windowmanager"
+HOMEPAGE="http://wmakerconf.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P/-/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="imlib nls perl"
+
+RDEPEND="x11-libs/gtk+:2
+ >=x11-wm/windowmaker-0.95.2
+ imlib? ( media-libs/imlib )
+ perl? ( dev-lang/perl
+ dev-perl/HTML-Parser
+ || ( dev-perl/libwww-perl
+ www-client/lynx
+ net-misc/wget ) )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-wmaker-0.95_support.patch
+}
+
+src_configure() {
+ local myconf
+ use imlib || myconf="--disable-imlibtest"
+
+ econf \
+ $(use_enable perl upgrade) \
+ $(use_enable nls) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" gnulocaledir="${ED}/usr/share/locale" install
+ dodoc AUTHORS ChangeLog MANUAL NEWS README TODO
+ doman man/*.1
+
+ rm -f "${ED}"/usr/share/${PN}/{AUTHORS,README,COPYING,NEWS,MANUAL,ABOUT-NLS,NLS-TEAM1,ChangeLog}
+}
+
+pkg_postinst() {
+ elog "New features added with WindowMaker >= 0.95 will not be available in wmakerconf"
+ elog "WPrefs is the recommended configuration tool"
+}
diff --git a/x11-misc/wmakerconf/wmakerconf-2.12.ebuild b/x11-misc/wmakerconf/wmakerconf-2.12.ebuild
new file mode 100644
index 000000000000..bf7a858760ef
--- /dev/null
+++ b/x11-misc/wmakerconf/wmakerconf-2.12.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+DESCRIPTION="X based config tool for the windowmaker X windowmanager"
+HOMEPAGE="http://wmakerconf.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P/-/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
+IUSE="imlib nls perl"
+
+RDEPEND="x11-libs/gtk+:2
+ <x11-wm/windowmaker-0.95.0
+ imlib? ( media-libs/imlib )
+ perl? ( dev-lang/perl
+ dev-perl/HTML-Parser
+ || ( dev-perl/libwww-perl
+ www-client/lynx
+ net-misc/wget ) )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf
+ use imlib || myconf="--disable-imlibtest"
+
+ econf \
+ $(use_enable perl upgrade) \
+ $(use_enable nls) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" gnulocaledir="${ED}/usr/share/locale" install || die
+ dodoc AUTHORS ChangeLog MANUAL NEWS README TODO
+ doman man/*.1
+
+ rm -f "${ED}"/usr/share/${PN}/{AUTHORS,README,COPYING,NEWS,MANUAL,ABOUT-NLS,NLS-TEAM1,ChangeLog}
+}