summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-01-23 14:15:35 -0600
committerWilliam Hubbs <williamh@gentoo.org>2022-01-23 14:16:03 -0600
commit8bf05271ccf42be4bf75b40f9ec75c809fd9965b (patch)
treefc20a5bb0b6d61b9ee55cdbf78894d8cf2da6e0b /www-apps/trickster/trickster-1.1.5.ebuild
parentdev-libs/libevent: Stabilize 2.1.12 hppa, #746818 (diff)
downloadgentoo-8bf05271ccf42be4bf75b40f9ec75c809fd9965b.tar.gz
gentoo-8bf05271ccf42be4bf75b40f9ec75c809fd9965b.tar.bz2
gentoo-8bf05271ccf42be4bf75b40f9ec75c809fd9965b.zip
www-apps/trickster-1.1.5: build fixes
- drop the vendor tarball - fix installation of systemd service Closes: https://bugs.gentoo.org/830478 Closes: https://bugs.gentoo.org/830488 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'www-apps/trickster/trickster-1.1.5.ebuild')
-rw-r--r--www-apps/trickster/trickster-1.1.5.ebuild13
1 files changed, 3 insertions, 10 deletions
diff --git a/www-apps/trickster/trickster-1.1.5.ebuild b/www-apps/trickster/trickster-1.1.5.ebuild
index 8f4e9be4ae1f..94496cb5ca4d 100644
--- a/www-apps/trickster/trickster-1.1.5.ebuild
+++ b/www-apps/trickster/trickster-1.1.5.ebuild
@@ -7,9 +7,7 @@ inherit go-module systemd
DESCRIPTION="Dashboard Accelerator for Prometheus"
HOMEPAGE="https://github.com/tricksterproxy/trickster"
-VENDOR_URI="https://dev.gentoo.org/~williamh/dist/${P}-vendor.tar.xz"
-SRC_URI="https://github.com/tricksterproxy/trickster/archive/v${PV}.tar.gz -> ${P}.tar.gz
- ${VENDOR_URI}"
+SRC_URI="https://github.com/tricksterproxy/trickster/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
@@ -21,11 +19,6 @@ COMMON_DEPEND="
DEPEND="${COMMON_DEPEND}"
RDEPEND="${COMMON_DEPEND}"
-src_prepare() {
- default
- mv ../vendor .
-}
-
src_compile() {
set -- go build -mod vendor ./cmd/trickster
echo $@
@@ -34,8 +27,8 @@ src_compile() {
src_install() {
dobin ${PN}
-dodoc -r conf docs/*
- systemd_dounit conf/trickster.service
+dodoc -r docs/*
+ systemd_dounit deploy/systemd/trickster.service
insinto /etc/trickster
doins "${FILESDIR}"/${PN}.conf
newinitd "${FILESDIR}"/${PN}.initd ${PN}