summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Tsoy <alexander@tsoy.me>2022-04-17 02:43:27 +0300
committerJoonas Niilola <juippis@gentoo.org>2022-04-23 08:31:31 +0300
commit0a8ca88b368c413288d453a5e9f98acc24ad1392 (patch)
treeb3f0bdda56ef1694443cd9ca0f62be77400d15c9 /sys-process/rtirq
parentmedia-fonts/joypixels: Version bump to 6.6.0 (diff)
downloadgentoo-0a8ca88b368c413288d453a5e9f98acc24ad1392.tar.gz
gentoo-0a8ca88b368c413288d453a5e9f98acc24ad1392.tar.bz2
gentoo-0a8ca88b368c413288d453a5e9f98acc24ad1392.zip
sys-process/rtirq: Version bump to 20210329
Signed-off-by: Alexander Tsoy <alexander@tsoy.me> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-process/rtirq')
-rw-r--r--sys-process/rtirq/Manifest1
-rw-r--r--sys-process/rtirq/rtirq-20210329.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/sys-process/rtirq/Manifest b/sys-process/rtirq/Manifest
index d5352d4ebc0d..09df64b10c4a 100644
--- a/sys-process/rtirq/Manifest
+++ b/sys-process/rtirq/Manifest
@@ -1,2 +1,3 @@
DIST rtirq-20180209.tar.gz 12290 BLAKE2B 432bf6c931b753d4d9a5d7c50a35b0fb9b2161d09c9f762b97a5aae88152de1f3d14a2a4ccc46d8607d7379e4a7a659d603cc09ee20017923b176359eb4b9133 SHA512 9de924e627b91d6df162b6c8c0c3421fbab11f08162abe98b0fac8742ea924a7e0a18aab23d828e19fe81dfdb70f2f6814c7195acbcbc93af9a339dc549190b2
DIST rtirq-20191121.tar.gz 12755 BLAKE2B 040e1b39b83dc27e542093a12830fa51c9786c2747962740c31e684235acab33275a40761fd87cd1307284c2b8e49362d4acb216000338bc0744dd0ca6b0144c SHA512 bb1ae0099e37220b13f91303e56e8ae7892964638c1000fd66b6ceb23925c8aa2ac0c629bbb799a59c1a8adb035c34c4b0bee31afe05fcc9f80cd94d5a84ddc1
+DIST rtirq-20210329.tar.gz 15360 BLAKE2B 278868817b349d0fd8bc70f0fb0374016d9117b593ed2fe710300fe194e7f8e640f4071f30e73688cca11d6da79fd93624a5e5e5246bfc2f9cd367397c00cadd SHA512 e08ee7768c93dd4e7244b61629272c4a4482d63b1fe37b7972a27703cd0a55cc12449589a781b33e9c92f5dd664c1a4ceba65caadb09c676deea86c161cc3d37
diff --git a/sys-process/rtirq/rtirq-20210329.ebuild b/sys-process/rtirq/rtirq-20210329.ebuild
new file mode 100644
index 000000000000..56edc30f9a09
--- /dev/null
+++ b/sys-process/rtirq/rtirq-20210329.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit linux-info systemd
+
+DESCRIPTION="Modify realtime scheduling policy and priority of IRQ handlers"
+HOMEPAGE="https://www.rncbc.org/archive/#rtirq"
+SRC_URI="https://www.rncbc.org/archive/${P}.tar.gz
+ https://www.rncbc.org/archive/old/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ # We install into bin
+ sed -i -e "s:/usr/sbin/rtirq:/usr/bin/rtirq:" ${PN}{,-resume}.service || die
+
+ default
+}
+
+src_install() {
+ newbin rtirq.sh rtirq
+ newinitd "${FILESDIR}"/rtirq.initd rtirq
+ insinto /etc/
+ doins rtirq.conf
+ systemd_dounit rtirq{,-resume}.service
+}
+
+pkg_postinst() {
+ local kconfig_warn=1
+ local cmdline
+ local ver
+
+ if linux-info_get_any_version && linux_config_exists; then
+ if linux_chkconfig_present PREEMPT_RT; then
+ kconfig_warn=0
+ elif linux_chkconfig_present IRQ_FORCED_THREADING; then
+ cmdline=$(< /proc/cmdline) || die
+ [[ ${cmdline} == *threadirqs* ]] && kconfig_warn=0
+ fi
+ fi
+
+ if (( ${kconfig_warn} )); then
+ ewarn "To use rtirq, you need one of the following kernel configurations:"
+ ewarn " - PREEMPT_RT config option enabled (e.g. with sys-kernel/rt-sources);"
+ ewarn " - IRQ_FORCED_THREADING config option enabled and 'threadirqs' option"
+ ewarn " added to the kernel cmdline."
+ fi
+
+ for ver in ${REPLACING_VERSIONS}; do
+ if ver_test ${ver} -lt "20210329"; then
+ elog "Starting with 20210329 version the config has been moved to '${EROOT}/etc/rtirq.conf'"
+ elog "Please migrate all you setting from '${EROOT}/etc/conf.d/rtirq'"
+ break
+ fi
+ done
+}