summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-26 16:31:49 +0100
committerSam James <sam@gentoo.org>2023-06-26 16:31:49 +0100
commit4913f0a16e3cf0065d7e6de18e414882423f7d72 (patch)
tree07877453e77ce53d7fe9d2b27a92e83e2d2c158f /sys-libs/glibc
parentnet-misc/openssh-contrib: drop libc_Cygwin cruft (diff)
downloadgentoo-4913f0a16e3cf0065d7e6de18e414882423f7d72.tar.gz
gentoo-4913f0a16e3cf0065d7e6de18e414882423f7d72.tar.bz2
gentoo-4913f0a16e3cf0065d7e6de18e414882423f7d72.zip
sys-libs/glibc: always filter-lto, even w/ USE=custom-cflags
Closes: https://bugs.gentoo.org/909193 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/glibc-2.31-r7.ebuild2
-rw-r--r--sys-libs/glibc/glibc-2.32-r8.ebuild2
-rw-r--r--sys-libs/glibc/glibc-2.33-r14.ebuild2
-rw-r--r--sys-libs/glibc/glibc-2.34-r14.ebuild2
-rw-r--r--sys-libs/glibc/glibc-2.35-r11.ebuild2
-rw-r--r--sys-libs/glibc/glibc-2.36-r7.ebuild2
-rw-r--r--sys-libs/glibc/glibc-2.36-r8.ebuild2
-rw-r--r--sys-libs/glibc/glibc-2.37-r2.ebuild2
-rw-r--r--sys-libs/glibc/glibc-2.37-r3.ebuild2
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild2
10 files changed, 10 insertions, 10 deletions
diff --git a/sys-libs/glibc/glibc-2.31-r7.ebuild b/sys-libs/glibc/glibc-2.31-r7.ebuild
index 78cb09bec8e9..ff102e83e4d2 100644
--- a/sys-libs/glibc/glibc-2.31-r7.ebuild
+++ b/sys-libs/glibc/glibc-2.31-r7.ebuild
@@ -367,12 +367,12 @@ setup_flags() {
# relating to failed builds, we strip most CFLAGS out to ensure as few
# problems as possible.
strip-flags
- filter-lto
# Lock glibc at -O2; we want to be conservative here.
filter-flags '-O?'
append-flags -O2
fi
strip-unsupported-flags
+ filter-lto
filter-flags -m32 -m64 '-mabi=*'
# glibc aborts if rpath is set by LDFLAGS
diff --git a/sys-libs/glibc/glibc-2.32-r8.ebuild b/sys-libs/glibc/glibc-2.32-r8.ebuild
index 3d72cb214594..83c994830e78 100644
--- a/sys-libs/glibc/glibc-2.32-r8.ebuild
+++ b/sys-libs/glibc/glibc-2.32-r8.ebuild
@@ -384,12 +384,12 @@ setup_flags() {
# relating to failed builds, we strip most CFLAGS out to ensure as few
# problems as possible.
strip-flags
- filter-lto
# Lock glibc at -O2; we want to be conservative here.
filter-flags '-O?'
append-flags -O2
fi
strip-unsupported-flags
+ filter-lto
filter-flags -m32 -m64 '-mabi=*'
# glibc aborts if rpath is set by LDFLAGS
diff --git a/sys-libs/glibc/glibc-2.33-r14.ebuild b/sys-libs/glibc/glibc-2.33-r14.ebuild
index 1f432881eeeb..817ff95e7869 100644
--- a/sys-libs/glibc/glibc-2.33-r14.ebuild
+++ b/sys-libs/glibc/glibc-2.33-r14.ebuild
@@ -396,12 +396,12 @@ setup_flags() {
# relating to failed builds, we strip most CFLAGS out to ensure as few
# problems as possible.
strip-flags
- filter-lto
# Lock glibc at -O2; we want to be conservative here.
filter-flags '-O?'
append-flags -O2
fi
strip-unsupported-flags
+ filter-lto
filter-flags -m32 -m64 '-mabi=*'
# glibc aborts if rpath is set by LDFLAGS
diff --git a/sys-libs/glibc/glibc-2.34-r14.ebuild b/sys-libs/glibc/glibc-2.34-r14.ebuild
index 544d8be04150..0a2e4d90ccb4 100644
--- a/sys-libs/glibc/glibc-2.34-r14.ebuild
+++ b/sys-libs/glibc/glibc-2.34-r14.ebuild
@@ -399,13 +399,13 @@ setup_flags() {
# relating to failed builds, we strip most CFLAGS out to ensure as few
# problems as possible.
strip-flags
- filter-lto
# Lock glibc at -O2; we want to be conservative here.
filter-flags '-O?'
append-flags -O2
fi
strip-unsupported-flags
+ filter-lto
filter-flags -m32 -m64 '-mabi=*'
# glibc aborts if rpath is set by LDFLAGS
diff --git a/sys-libs/glibc/glibc-2.35-r11.ebuild b/sys-libs/glibc/glibc-2.35-r11.ebuild
index 5b6649f3f6de..090f19b517a8 100644
--- a/sys-libs/glibc/glibc-2.35-r11.ebuild
+++ b/sys-libs/glibc/glibc-2.35-r11.ebuild
@@ -412,13 +412,13 @@ setup_flags() {
# relating to failed builds, we strip most CFLAGS out to ensure as few
# problems as possible.
strip-flags
- filter-lto
# Lock glibc at -O2; we want to be conservative here.
filter-flags '-O?'
append-flags -O2
fi
strip-unsupported-flags
+ filter-lto
filter-flags -m32 -m64 '-mabi=*'
# glibc aborts if rpath is set by LDFLAGS
diff --git a/sys-libs/glibc/glibc-2.36-r7.ebuild b/sys-libs/glibc/glibc-2.36-r7.ebuild
index 49ab641a06f2..c1813a55f183 100644
--- a/sys-libs/glibc/glibc-2.36-r7.ebuild
+++ b/sys-libs/glibc/glibc-2.36-r7.ebuild
@@ -418,13 +418,13 @@ setup_flags() {
# relating to failed builds, we strip most CFLAGS out to ensure as few
# problems as possible.
strip-flags
- filter-lto
# Lock glibc at -O2; we want to be conservative here.
filter-flags '-O?'
append-flags -O2
fi
strip-unsupported-flags
+ filter-lto
filter-flags -m32 -m64 '-mabi=*'
# glibc aborts if rpath is set by LDFLAGS
diff --git a/sys-libs/glibc/glibc-2.36-r8.ebuild b/sys-libs/glibc/glibc-2.36-r8.ebuild
index dc181a1690f3..5998cc3c9055 100644
--- a/sys-libs/glibc/glibc-2.36-r8.ebuild
+++ b/sys-libs/glibc/glibc-2.36-r8.ebuild
@@ -418,13 +418,13 @@ setup_flags() {
# relating to failed builds, we strip most CFLAGS out to ensure as few
# problems as possible.
strip-flags
- filter-lto
# Lock glibc at -O2; we want to be conservative here.
filter-flags '-O?'
append-flags -O2
fi
strip-unsupported-flags
+ filter-lto
filter-flags -m32 -m64 '-mabi=*'
# glibc aborts if rpath is set by LDFLAGS
diff --git a/sys-libs/glibc/glibc-2.37-r2.ebuild b/sys-libs/glibc/glibc-2.37-r2.ebuild
index 5c8351a2a379..b28145dab4c9 100644
--- a/sys-libs/glibc/glibc-2.37-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.37-r2.ebuild
@@ -419,13 +419,13 @@ setup_flags() {
# relating to failed builds, we strip most CFLAGS out to ensure as few
# problems as possible.
strip-flags
- filter-lto
# Lock glibc at -O2; we want to be conservative here.
filter-flags '-O?'
append-flags -O2
fi
strip-unsupported-flags
+ filter-lto
filter-flags -m32 -m64 '-mabi=*'
# glibc aborts if rpath is set by LDFLAGS
diff --git a/sys-libs/glibc/glibc-2.37-r3.ebuild b/sys-libs/glibc/glibc-2.37-r3.ebuild
index df775e7f1f85..8cb029656f12 100644
--- a/sys-libs/glibc/glibc-2.37-r3.ebuild
+++ b/sys-libs/glibc/glibc-2.37-r3.ebuild
@@ -407,13 +407,13 @@ setup_flags() {
# relating to failed builds, we strip most CFLAGS out to ensure as few
# problems as possible.
strip-flags
- filter-lto
# Lock glibc at -O2; we want to be conservative here.
filter-flags '-O?'
append-flags -O2
fi
strip-unsupported-flags
+ filter-lto
filter-flags -m32 -m64 '-mabi=*'
# glibc aborts if rpath is set by LDFLAGS
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 54fcf643e2cf..ffcac4cc7948 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -407,13 +407,13 @@ setup_flags() {
# relating to failed builds, we strip most CFLAGS out to ensure as few
# problems as possible.
strip-flags
- filter-lto
# Lock glibc at -O2; we want to be conservative here.
filter-flags '-O?'
append-flags -O2
fi
strip-unsupported-flags
+ filter-lto
filter-flags -m32 -m64 '-mabi=*'
# glibc aborts if rpath is set by LDFLAGS