summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-kernel/zen-sources
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-kernel/zen-sources')
-rw-r--r--sys-kernel/zen-sources/files/powernow-k8-family10-model10_fix.patch34
-rw-r--r--sys-kernel/zen-sources/metadata.xml13
-rw-r--r--sys-kernel/zen-sources/zen-sources-3.10.9999.ebuild39
-rw-r--r--sys-kernel/zen-sources/zen-sources-3.11.9999.ebuild39
-rw-r--r--sys-kernel/zen-sources/zen-sources-3.12.9999.ebuild39
-rw-r--r--sys-kernel/zen-sources/zen-sources-3.13.9999.ebuild39
-rw-r--r--sys-kernel/zen-sources/zen-sources-3.8.9999.ebuild39
-rw-r--r--sys-kernel/zen-sources/zen-sources-3.9.9999.ebuild39
8 files changed, 281 insertions, 0 deletions
diff --git a/sys-kernel/zen-sources/files/powernow-k8-family10-model10_fix.patch b/sys-kernel/zen-sources/files/powernow-k8-family10-model10_fix.patch
new file mode 100644
index 000000000000..10ad496ce57f
--- /dev/null
+++ b/sys-kernel/zen-sources/files/powernow-k8-family10-model10_fix.patch
@@ -0,0 +1,34 @@
+From 679370641e3675633cad222449262abbe93a4a2a Mon Sep 17 00:00:00 2001
+From: Mark Langsdorf <mark.langsdorf@amd.com>
+Date: Wed, 31 Mar 2010 21:56:45 +0200
+Subject: [PATCH] powernow-k8: Fix frequency reporting
+
+With F10, model 10, all valid frequencies are in the ACPI _PST table.
+
+Cc: <stable@kernel.org> # 33.x 32.x
+Signed-off-by: Mark Langsdorf <mark.langsdorf@amd.com>
+LKML-Reference: <1270065406-1814-6-git-send-email-bp@amd64.org>
+Signed-off-by: Borislav Petkov <borislav.petkov@amd.com>
+Reviewed-by: Thomas Renninger <trenn@suse.de>
+Signed-off-by: H. Peter Anvin <hpa@zytor.com>
+---
+ arch/x86/kernel/cpu/cpufreq/powernow-k8.c | 3 ++-
+ 1 files changed, 2 insertions(+), 1 deletions(-)
+
+diff --git a/arch/x86/kernel/cpu/cpufreq/powernow-k8.c b/arch/x86/kernel/cpu/cpufreq/powernow-k8.c
+index 52fce63..6f3dc8f 100644
+--- a/arch/x86/kernel/cpu/cpufreq/powernow-k8.c
++++ b/arch/x86/kernel/cpu/cpufreq/powernow-k8.c
+@@ -935,7 +935,8 @@ static int fill_powernow_table_pstate(struct powernow_k8_data *data,
+ powernow_table[i].index = index;
+
+ /* Frequency may be rounded for these */
+- if (boot_cpu_data.x86 == 0x10 || boot_cpu_data.x86 == 0x11) {
++ if ((boot_cpu_data.x86 == 0x10 && boot_cpu_data.x86_model < 10)
++ || boot_cpu_data.x86 == 0x11) {
+ powernow_table[i].frequency =
+ freq_from_fid_did(lo & 0x3f, (lo >> 6) & 7);
+ } else
+--
+1.7.1
+
diff --git a/sys-kernel/zen-sources/metadata.xml b/sys-kernel/zen-sources/metadata.xml
new file mode 100644
index 000000000000..df5ec0287618
--- /dev/null
+++ b/sys-kernel/zen-sources/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proxy-maintainers</herd>
+<maintainer>
+ <email>vicegentoo@gmail.com</email>
+ <name>Daniel Weiss</name>
+ <description>Maintainer. Assign bugs to him</description>
+</maintainer>
+<upstream>
+ <remote-id type="cpe">cpe:/o:linux:linux_kernel</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/sys-kernel/zen-sources/zen-sources-3.10.9999.ebuild b/sys-kernel/zen-sources/zen-sources-3.10.9999.ebuild
new file mode 100644
index 000000000000..8c69704ca931
--- /dev/null
+++ b/sys-kernel/zen-sources/zen-sources-3.10.9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+K_PREPATCHED="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_DEBLOB_AVAILABLE=0
+CKV="${PV/99/}"
+
+ETYPE="sources"
+
+EGIT_BRANCH="${PV/.9999/}/master"
+EGIT_REPO_URI="git://github.com/damentz/zen-kernel.git
+ https://github.com/damentz/zen-kernel.git"
+
+inherit kernel-2 git-2
+detect_version
+
+K_NOSETEXTRAVERSION="don't_set_it"
+DESCRIPTION="The Zen Kernel Live Sources"
+HOMEPAGE="http://zen-kernel.org"
+
+IUSE=""
+
+KEYWORDS=""
+
+K_EXTRAEINFO="For more info on zen-sources, and for how to report problems, see: \
+${HOMEPAGE}, also go to #zen-sources on freenode"
+
+pkg_setup(){
+ ewarn "Be carefull!! You are about to install live kernel sources."
+ ewarn "Git zen-sources are extremely unsupported, even from the upstream"
+ ewarn "developers. Use them at your own risk and don't bite us if your"
+ ewarn "system explodes"
+ kernel-2_pkg_setup
+}
diff --git a/sys-kernel/zen-sources/zen-sources-3.11.9999.ebuild b/sys-kernel/zen-sources/zen-sources-3.11.9999.ebuild
new file mode 100644
index 000000000000..8c69704ca931
--- /dev/null
+++ b/sys-kernel/zen-sources/zen-sources-3.11.9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+K_PREPATCHED="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_DEBLOB_AVAILABLE=0
+CKV="${PV/99/}"
+
+ETYPE="sources"
+
+EGIT_BRANCH="${PV/.9999/}/master"
+EGIT_REPO_URI="git://github.com/damentz/zen-kernel.git
+ https://github.com/damentz/zen-kernel.git"
+
+inherit kernel-2 git-2
+detect_version
+
+K_NOSETEXTRAVERSION="don't_set_it"
+DESCRIPTION="The Zen Kernel Live Sources"
+HOMEPAGE="http://zen-kernel.org"
+
+IUSE=""
+
+KEYWORDS=""
+
+K_EXTRAEINFO="For more info on zen-sources, and for how to report problems, see: \
+${HOMEPAGE}, also go to #zen-sources on freenode"
+
+pkg_setup(){
+ ewarn "Be carefull!! You are about to install live kernel sources."
+ ewarn "Git zen-sources are extremely unsupported, even from the upstream"
+ ewarn "developers. Use them at your own risk and don't bite us if your"
+ ewarn "system explodes"
+ kernel-2_pkg_setup
+}
diff --git a/sys-kernel/zen-sources/zen-sources-3.12.9999.ebuild b/sys-kernel/zen-sources/zen-sources-3.12.9999.ebuild
new file mode 100644
index 000000000000..8c69704ca931
--- /dev/null
+++ b/sys-kernel/zen-sources/zen-sources-3.12.9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+K_PREPATCHED="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_DEBLOB_AVAILABLE=0
+CKV="${PV/99/}"
+
+ETYPE="sources"
+
+EGIT_BRANCH="${PV/.9999/}/master"
+EGIT_REPO_URI="git://github.com/damentz/zen-kernel.git
+ https://github.com/damentz/zen-kernel.git"
+
+inherit kernel-2 git-2
+detect_version
+
+K_NOSETEXTRAVERSION="don't_set_it"
+DESCRIPTION="The Zen Kernel Live Sources"
+HOMEPAGE="http://zen-kernel.org"
+
+IUSE=""
+
+KEYWORDS=""
+
+K_EXTRAEINFO="For more info on zen-sources, and for how to report problems, see: \
+${HOMEPAGE}, also go to #zen-sources on freenode"
+
+pkg_setup(){
+ ewarn "Be carefull!! You are about to install live kernel sources."
+ ewarn "Git zen-sources are extremely unsupported, even from the upstream"
+ ewarn "developers. Use them at your own risk and don't bite us if your"
+ ewarn "system explodes"
+ kernel-2_pkg_setup
+}
diff --git a/sys-kernel/zen-sources/zen-sources-3.13.9999.ebuild b/sys-kernel/zen-sources/zen-sources-3.13.9999.ebuild
new file mode 100644
index 000000000000..a0718234745d
--- /dev/null
+++ b/sys-kernel/zen-sources/zen-sources-3.13.9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+K_PREPATCHED="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_DEBLOB_AVAILABLE=0
+CKV="${PV/99/}"
+
+ETYPE="sources"
+
+EGIT_BRANCH="${PV/.9999/}/master"
+EGIT_REPO_URI="git://github.com/damentz/zen-kernel.git
+ https://github.com/damentz/zen-kernel.git"
+
+inherit kernel-2 git-2
+detect_version
+
+K_NOSETEXTRAVERSION="don't_set_it"
+DESCRIPTION="The Zen Kernel Live Sources"
+HOMEPAGE="http://zen-kernel.org"
+
+IUSE=""
+
+KEYWORDS=""
+
+K_EXTRAEINFO="For more info on zen-sources, and for how to report problems, see: \
+${HOMEPAGE}, also go to #zen-sources on freenode"
+
+pkg_setup(){
+ ewarn "Be carefull!! You are about to install live kernel sources."
+ ewarn "Git zen-sources are extremely unsupported, even from the upstream"
+ ewarn "developers. Use them at your own risk and don't bite us if your"
+ ewarn "system explodes"
+ kernel-2_pkg_setup
+}
diff --git a/sys-kernel/zen-sources/zen-sources-3.8.9999.ebuild b/sys-kernel/zen-sources/zen-sources-3.8.9999.ebuild
new file mode 100644
index 000000000000..8c69704ca931
--- /dev/null
+++ b/sys-kernel/zen-sources/zen-sources-3.8.9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+K_PREPATCHED="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_DEBLOB_AVAILABLE=0
+CKV="${PV/99/}"
+
+ETYPE="sources"
+
+EGIT_BRANCH="${PV/.9999/}/master"
+EGIT_REPO_URI="git://github.com/damentz/zen-kernel.git
+ https://github.com/damentz/zen-kernel.git"
+
+inherit kernel-2 git-2
+detect_version
+
+K_NOSETEXTRAVERSION="don't_set_it"
+DESCRIPTION="The Zen Kernel Live Sources"
+HOMEPAGE="http://zen-kernel.org"
+
+IUSE=""
+
+KEYWORDS=""
+
+K_EXTRAEINFO="For more info on zen-sources, and for how to report problems, see: \
+${HOMEPAGE}, also go to #zen-sources on freenode"
+
+pkg_setup(){
+ ewarn "Be carefull!! You are about to install live kernel sources."
+ ewarn "Git zen-sources are extremely unsupported, even from the upstream"
+ ewarn "developers. Use them at your own risk and don't bite us if your"
+ ewarn "system explodes"
+ kernel-2_pkg_setup
+}
diff --git a/sys-kernel/zen-sources/zen-sources-3.9.9999.ebuild b/sys-kernel/zen-sources/zen-sources-3.9.9999.ebuild
new file mode 100644
index 000000000000..8c69704ca931
--- /dev/null
+++ b/sys-kernel/zen-sources/zen-sources-3.9.9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+K_PREPATCHED="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_DEBLOB_AVAILABLE=0
+CKV="${PV/99/}"
+
+ETYPE="sources"
+
+EGIT_BRANCH="${PV/.9999/}/master"
+EGIT_REPO_URI="git://github.com/damentz/zen-kernel.git
+ https://github.com/damentz/zen-kernel.git"
+
+inherit kernel-2 git-2
+detect_version
+
+K_NOSETEXTRAVERSION="don't_set_it"
+DESCRIPTION="The Zen Kernel Live Sources"
+HOMEPAGE="http://zen-kernel.org"
+
+IUSE=""
+
+KEYWORDS=""
+
+K_EXTRAEINFO="For more info on zen-sources, and for how to report problems, see: \
+${HOMEPAGE}, also go to #zen-sources on freenode"
+
+pkg_setup(){
+ ewarn "Be carefull!! You are about to install live kernel sources."
+ ewarn "Git zen-sources are extremely unsupported, even from the upstream"
+ ewarn "developers. Use them at your own risk and don't bite us if your"
+ ewarn "system explodes"
+ kernel-2_pkg_setup
+}