summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2023-09-16 14:09:52 +0100
committerJames Le Cuirot <chewi@gentoo.org>2023-09-16 14:10:39 +0100
commit547998220914f0d2d7bbf9b4e0ae2335c7deb6c4 (patch)
treede810cd7c4bd9077e7cb07d0c9507f207673bc34 /sys-fs/safecopy
parentprofiles: drop obsolete masks (diff)
downloadgentoo-547998220914f0d2d7bbf9b4e0ae2335c7deb6c4.tar.gz
gentoo-547998220914f0d2d7bbf9b4e0ae2335c7deb6c4.tar.bz2
gentoo-547998220914f0d2d7bbf9b4e0ae2335c7deb6c4.zip
sys-fs/safecopy: Fix test issues, EAPI 8
Closes: https://bugs.gentoo.org/838091 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'sys-fs/safecopy')
-rw-r--r--sys-fs/safecopy/files/safecopy-tests.patch22
-rw-r--r--sys-fs/safecopy/safecopy-1.7-r1.ebuild (renamed from sys-fs/safecopy/safecopy-1.7.ebuild)9
2 files changed, 27 insertions, 4 deletions
diff --git a/sys-fs/safecopy/files/safecopy-tests.patch b/sys-fs/safecopy/files/safecopy-tests.patch
new file mode 100644
index 000000000000..84587de17084
--- /dev/null
+++ b/sys-fs/safecopy/files/safecopy-tests.patch
@@ -0,0 +1,22 @@
+diff -Naur a/simulator/src/simulatorlb.c b/simulator/src/simulatorlb.c
+--- a/simulator/src/simulatorlb.c 2009-07-28 15:31:16.000000000 +0100
++++ b/simulator/src/simulatorlb.c 2023-09-16 13:52:16.111512487 +0100
+@@ -2,7 +2,7 @@
+ * This file is copyright ©2009 Corvus Corax
+ * Distributed under the terms of the GPL version 2 or higher
+ */
+-#define _FILE_OFFSET_BITS 64
++#define _LARGEFILE64_SOURCE
+ #include <config.h>
+
+ #ifdef USE_GNU_SOURCE
+@@ -531,3 +531,9 @@
+ }
+ return realread(fd,buf,count);
+ }
++
++// copy_file_range() may be used instead so force failure to fall back to read().
++ssize_t copy_file_range(int fd_in, off_t off_in, int fd_out, off_t off_out, size_t len, unsigned int flags) {
++ errno = EXDEV;
++ return -1;
++}
diff --git a/sys-fs/safecopy/safecopy-1.7.ebuild b/sys-fs/safecopy/safecopy-1.7-r1.ebuild
index ea11400db323..9991c27a9c67 100644
--- a/sys-fs/safecopy/safecopy-1.7.ebuild
+++ b/sys-fs/safecopy/safecopy-1.7-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-DESCRIPTION="Tool for fault-tolerant data recovery from damaged (io-errors) devices or files"
-HOMEPAGE="http://safecopy.sourceforge.net"
+DESCRIPTION="Tool for fault-tolerant data recovery from damaged (IO-errors) devices or files"
+HOMEPAGE="https://safecopy.sourceforge.net"
SRC_URI="mirror://sourceforge/safecopy/${P}.tar.gz"
LICENSE="GPL-2+"
@@ -13,6 +13,7 @@ KEYWORDS="amd64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
+PATCHES=( "${FILESDIR}"/${PN}-tests.patch )
DOCS=( README )
src_configure() {