summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-19 20:15:52 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-19 20:16:38 -0500
commit8587a7e33150509d141300486131b448f2775b7a (patch)
tree6a8694db218c1f412d6db16c99c55ac0fbc29d10 /sys-cluster
parentsys-kernel/gentoo-sources: Linux patch 4.9.169 (diff)
downloadgentoo-8587a7e33150509d141300486131b448f2775b7a.tar.gz
gentoo-8587a7e33150509d141300486131b448f2775b7a.tar.bz2
gentoo-8587a7e33150509d141300486131b448f2775b7a.zip
sys-cluster/placement: install migration scripts
Fixes: https://bugs.gentoo.org/683706 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/placement/placement-1.0.0-r1.ebuild (renamed from sys-cluster/placement/placement-1.0.0.ebuild)3
-rw-r--r--sys-cluster/placement/placement-2019.1.9999.ebuild3
2 files changed, 6 insertions, 0 deletions
diff --git a/sys-cluster/placement/placement-1.0.0.ebuild b/sys-cluster/placement/placement-1.0.0-r1.ebuild
index d3ab3c47e563..291dc9ebaad5 100644
--- a/sys-cluster/placement/placement-1.0.0.ebuild
+++ b/sys-cluster/placement/placement-1.0.0-r1.ebuild
@@ -102,4 +102,7 @@ python_install_all() {
insinto /etc/placement
insopts -m 0640 -o placement -g placement
newins "${DISTDIR}/placement.conf.sample-${PV}" placement.conf.sample
+
+ dobin tools/mysql-migrate-db.sh
+ dobin tools/postgresql-migrate-db.sh
}
diff --git a/sys-cluster/placement/placement-2019.1.9999.ebuild b/sys-cluster/placement/placement-2019.1.9999.ebuild
index d3ab3c47e563..291dc9ebaad5 100644
--- a/sys-cluster/placement/placement-2019.1.9999.ebuild
+++ b/sys-cluster/placement/placement-2019.1.9999.ebuild
@@ -102,4 +102,7 @@ python_install_all() {
insinto /etc/placement
insopts -m 0640 -o placement -g placement
newins "${DISTDIR}/placement.conf.sample-${PV}" placement.conf.sample
+
+ dobin tools/mysql-migrate-db.sh
+ dobin tools/postgresql-migrate-db.sh
}