summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2021-04-03 10:36:24 -0400
committerMike Gilbert <floppym@gentoo.org>2021-04-03 10:36:24 -0400
commit90a0342e7bd37e7069b5c6bdaf8eca6f43c4f3a2 (patch)
tree7562c1383092e65079466e8175bd73eca78420c6 /sys-block/nbd
parentdev-python/xdg: Update pyxdg blocker (diff)
downloadgentoo-90a0342e7bd37e7069b5c6bdaf8eca6f43c4f3a2.tar.gz
gentoo-90a0342e7bd37e7069b5c6bdaf8eca6f43c4f3a2.tar.bz2
gentoo-90a0342e7bd37e7069b5c6bdaf8eca6f43c4f3a2.zip
sys-block/nbd: install systemd service unit
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-block/nbd')
-rw-r--r--sys-block/nbd/nbd-3.21-r1.ebuild (renamed from sys-block/nbd/nbd-3.21.ebuild)7
-rw-r--r--sys-block/nbd/nbd-9999.ebuild9
2 files changed, 15 insertions, 1 deletions
diff --git a/sys-block/nbd/nbd-3.21.ebuild b/sys-block/nbd/nbd-3.21-r1.ebuild
index 57890d32bc1c..732367ad8970 100644
--- a/sys-block/nbd/nbd-3.21.ebuild
+++ b/sys-block/nbd/nbd-3.21-r1.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit systemd
+
DESCRIPTION="Userland client/server for kernel network block device"
HOMEPAGE="http://nbd.sourceforge.net/"
if [[ "${PV}" = 9999 ]] ; then
@@ -58,3 +60,8 @@ src_configure() {
)
econf "${myeconfargs[@]}"
}
+
+src_install() {
+ default
+ systemd_dounit systemd/nbd@.service
+}
diff --git a/sys-block/nbd/nbd-9999.ebuild b/sys-block/nbd/nbd-9999.ebuild
index fad2a1deedee..732367ad8970 100644
--- a/sys-block/nbd/nbd-9999.ebuild
+++ b/sys-block/nbd/nbd-9999.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit systemd
+
DESCRIPTION="Userland client/server for kernel network block device"
HOMEPAGE="http://nbd.sourceforge.net/"
if [[ "${PV}" = 9999 ]] ; then
@@ -58,3 +60,8 @@ src_configure() {
)
econf "${myeconfargs[@]}"
}
+
+src_install() {
+ default
+ systemd_dounit systemd/nbd@.service
+}