summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-04-29 12:25:37 -0400
committerMike Gilbert <floppym@gentoo.org>2020-04-29 12:25:37 -0400
commitc7ea8556fef6dcd2b7890e478bdfb3920e5a332a (patch)
tree1cdc7fc899fd27a6f65415e3bc98b7f6e9718950 /sys-apps/util-linux
parentdev-python/simpy: Bump to 3.0.13 (diff)
downloadgentoo-c7ea8556fef6dcd2b7890e478bdfb3920e5a332a.tar.gz
gentoo-c7ea8556fef6dcd2b7890e478bdfb3920e5a332a.tar.bz2
gentoo-c7ea8556fef6dcd2b7890e478bdfb3920e5a332a.zip
sys-apps/util-linux: backport hwclock fix for glibc-2.31
Closes: https://bugs.gentoo.org/720006 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps/util-linux')
-rw-r--r--sys-apps/util-linux/files/util-linux-2.35.1-hwclock-glibc-2.31.patch165
-rw-r--r--sys-apps/util-linux/util-linux-2.35.1-r2.ebuild (renamed from sys-apps/util-linux/util-linux-2.35.1-r1.ebuild)1
-rw-r--r--sys-apps/util-linux/util-linux-2.35.1.ebuild314
3 files changed, 166 insertions, 314 deletions
diff --git a/sys-apps/util-linux/files/util-linux-2.35.1-hwclock-glibc-2.31.patch b/sys-apps/util-linux/files/util-linux-2.35.1-hwclock-glibc-2.31.patch
new file mode 100644
index 000000000000..c8b5cf76a23c
--- /dev/null
+++ b/sys-apps/util-linux/files/util-linux-2.35.1-hwclock-glibc-2.31.patch
@@ -0,0 +1,165 @@
+From cd781c405be82540484da3bfe3d3f17a39b8eb5c Mon Sep 17 00:00:00 2001
+From: J William Piggott <elseifthen@gmx.com>
+Date: Fri, 21 Feb 2020 20:03:47 -0500
+Subject: hwclock: make glibc 2.31 compatible
+
+______________________________________________________
+GNU C Library NEWS -- history of user-visible changes.
+Version 2.31
+Deprecated and removed features, and other changes affecting compatibility:
+
+* The settimeofday function can still be used to set a system-wide time
+ zone when the operating system supports it. This is because the Linux
+ kernel reused the API, on some architectures, to describe a system-wide
+ time-zone-like offset between the software clock maintained by the kernel,
+ and the "RTC" clock that keeps time when the system is shut down.
+
+ However, to reduce the odds of this offset being set by accident,
+ settimeofday can no longer be used to set the time and the offset
+ simultaneously. If both of its two arguments are non-null, the call
+ will fail (setting errno to EINVAL).
+
+ Callers attempting to set this offset should also be prepared for the call
+ to fail and set errno to ENOSYS; this already happens on the Hurd and on
+ some Linux architectures. The Linux kernel maintainers are discussing a
+ more principled replacement for the reused API. After a replacement
+ becomes available, we will change settimeofday to fail with ENOSYS on all
+ platforms when its 'tzp' argument is not a null pointer.
+
+ settimeofday itself is obsolescent according to POSIX. Programs that set
+ the system time should use clock_settime and/or the adjtime family of
+ functions instead. We may cease to make settimeofday available to newly
+ linked binaries after there is a replacement for Linux's time-zone-like
+ offset API.
+______________________________________________________
+
+hwclock(8) had one settimeofday(2) call where both args were set for
+--hctosys when the RTC was ticking UTC. This allowed setting the system
+time, timezone, and locking the warp_clock function with a single call.
+That operation now takes 3 calls of settimeofday(2).
+
+Although this common operation now takes three calls, the overall logic
+for the set_system_clock() function was simplified.
+
+Co-Author: Karel Zak <kzak@redhat.com>
+Signed-off-by: J William Piggott <elseifthen@gmx.com>
+---
+ sys-utils/hwclock.c | 71 ++++++++++++++++++++++++++++-------------------------
+ 1 file changed, 37 insertions(+), 34 deletions(-)
+
+diff --git a/sys-utils/hwclock.c b/sys-utils/hwclock.c
+index e736da717..1191a8571 100644
+--- a/sys-utils/hwclock.c
++++ b/sys-utils/hwclock.c
+@@ -643,28 +643,28 @@ display_time(struct timeval hwctime)
+ * tz.tz_minuteswest argument and sets PCIL (see below). At boot settimeofday(2)
+ * has one-shot access to this function as shown in the table below.
+ *
+- * +-------------------------------------------------------------------+
+- * | settimeofday(tv, tz) |
+- * |-------------------------------------------------------------------|
+- * | Arguments | System Time | PCIL | | warp_clock |
+- * | tv | tz | set | warped | set | firsttime | locked |
+- * |---------|---------|---------------|------|-----------|------------|
+- * | pointer | NULL | yes | no | no | 1 | no |
+- * | pointer | pointer | yes | no | no | 0 | yes |
+- * | NULL | ptr2utc | no | no | no | 0 | yes |
+- * | NULL | pointer | no | yes | yes | 0 | yes |
+- * +-------------------------------------------------------------------+
++ * +-------------------------------------------------------------------------+
++ * | settimeofday(tv, tz) |
++ * |-------------------------------------------------------------------------|
++ * | Arguments | System Time | TZ | PCIL | | warp_clock |
++ * | tv | tz | set | warped | set | set | firsttime | locked |
++ * |---------|---------|---------------|-----|------|-----------|------------|
++ * | pointer | NULL | yes | no | no | no | 1 | no |
++ * | NULL | ptr2utc | no | no | yes | no | 0 | yes |
++ * | NULL | pointer | no | yes | yes | yes | 0 | yes |
++ * +-------------------------------------------------------------------------+
+ * ptr2utc: tz.tz_minuteswest is zero (UTC).
+ * PCIL: persistent_clock_is_local, sets the "11 minute mode" timescale.
+ * firsttime: locks the warp_clock function (initialized to 1 at boot).
++ * Since glibc v2.31 settimeofday() will fail if both args are non NULL
+ *
+ * +---------------------------------------------------------------------------+
+ * | op | RTC scale | settimeofday calls |
+ * |---------|-----------|-----------------------------------------------------|
+ * | systz | Local | 1) warps system time*, sets PCIL* and kernel tz |
+ * | systz | UTC | 1st) locks warp_clock* 2nd) sets kernel tz |
+- * | hctosys | Local | 1st) sets PCIL* 2nd) sets system time and kernel tz |
+- * | hctosys | UTC | 1) sets system time and kernel tz |
++ * | hctosys | Local | 1st) sets PCIL* & kernel tz 2nd) sets system time |
++ * | hctosys | UTC | 1st) locks warp* 2nd) sets tz 3rd) sets system time |
+ * +---------------------------------------------------------------------------+
+ * * only on first call after boot
+ */
+@@ -675,42 +675,45 @@ set_system_clock(const struct hwclock_control *ctl,
+ struct tm broken;
+ int minuteswest;
+ int rc = 0;
+- const struct timezone tz_utc = { 0 };
+
+ localtime_r(&newtime.tv_sec, &broken);
+ minuteswest = -get_gmtoff(&broken) / 60;
+
+ if (ctl->verbose) {
+- if (ctl->hctosys && !ctl->universal)
+- printf(_("Calling settimeofday(NULL, %d) to set "
+- "persistent_clock_is_local.\n"), minuteswest);
+- if (ctl->systz && ctl->universal)
++ if (ctl->universal) {
+ puts(_("Calling settimeofday(NULL, 0) "
+- "to lock the warp function."));
++ "to lock the warp_clock function."));
++ if (!( ctl->universal && !minuteswest ))
++ printf(_("Calling settimeofday(NULL, %d) "
++ "to set the kernel timezone.\n"),
++ minuteswest);
++ } else
++ printf(_("Calling settimeofday(NULL, %d) to warp "
++ "System time, set PCIL and the kernel tz.\n"),
++ minuteswest);
++
+ if (ctl->hctosys)
+- printf(_("Calling settimeofday(%ld.%06ld, %d)\n"),
+- newtime.tv_sec, newtime.tv_usec, minuteswest);
+- else {
+- printf(_("Calling settimeofday(NULL, %d) "), minuteswest);
+- if (ctl->universal)
+- puts(_("to set the kernel timezone."));
+- else
+- puts(_("to warp System time."));
+- }
++ printf(_("Calling settimeofday(%ld.%06ld, NULL) "
++ "to set the System time.\n"),
++ newtime.tv_sec, newtime.tv_usec);
+ }
+
+ if (!ctl->testing) {
++ const struct timezone tz_utc = { 0 };
+ const struct timezone tz = { minuteswest };
+
+- if (ctl->hctosys && !ctl->universal) /* set PCIL */
+- rc = settimeofday(NULL, &tz);
+- if (ctl->systz && ctl->universal) /* lock warp_clock */
++ /* If UTC RTC: lock warp_clock and PCIL */
++ if (ctl->universal)
+ rc = settimeofday(NULL, &tz_utc);
+- if (!rc && ctl->hctosys)
+- rc = settimeofday(&newtime, &tz);
+- else if (!rc)
++
++ /* Set kernel tz; if localtime RTC: warp_clock and set PCIL */
++ if (!rc && !( ctl->universal && !minuteswest ))
+ rc = settimeofday(NULL, &tz);
+
++ /* Set the System Clock */
++ if ((!rc || errno == ENOSYS) && ctl->hctosys)
++ rc = settimeofday(&newtime, NULL);
++
+ if (rc) {
+ warn(_("settimeofday() failed"));
+ return EXIT_FAILURE;
+--
+cgit 1.2-0.3.lf.el7
+
diff --git a/sys-apps/util-linux/util-linux-2.35.1-r1.ebuild b/sys-apps/util-linux/util-linux-2.35.1-r2.ebuild
index c7848ba55183..68e7b84262b9 100644
--- a/sys-apps/util-linux/util-linux-2.35.1-r1.ebuild
+++ b/sys-apps/util-linux/util-linux-2.35.1-r2.ebuild
@@ -83,6 +83,7 @@ S="${WORKDIR}/${MY_P}"
PATCHES=(
"${FILESDIR}"/util-linux-2.35.1-include_sys_types-header.patch
"${FILESDIR}"/util-linux-2.35.1-cleanup-pidfd-include.patch
+ "${FILESDIR}"/util-linux-2.35.1-hwclock-glibc-2.31.patch
)
src_prepare() {
diff --git a/sys-apps/util-linux/util-linux-2.35.1.ebuild b/sys-apps/util-linux/util-linux-2.35.1.ebuild
deleted file mode 100644
index 9153eb2da129..000000000000
--- a/sys-apps/util-linux/util-linux-2.35.1.ebuild
+++ /dev/null
@@ -1,314 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit toolchain-funcs libtool flag-o-matic bash-completion-r1 usr-ldscript \
- pam python-r1 multilib-minimal multiprocessing systemd
-
-MY_PV="${PV/_/-}"
-MY_P="${PN}-${MY_PV}"
-
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3 autotools
- EGIT_REPO_URI="https://git.kernel.org/pub/scm/utils/util-linux/util-linux.git"
-else
- [[ "${PV}" = *_rc* ]] || \
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
- SRC_URI="https://www.kernel.org/pub/linux/utils/util-linux/v${PV:0:4}/${MY_P}.tar.xz"
-fi
-
-DESCRIPTION="Various useful Linux utilities"
-HOMEPAGE="https://www.kernel.org/pub/linux/utils/util-linux/ https://github.com/karelzak/util-linux"
-
-LICENSE="GPL-2 GPL-3 LGPL-2.1 BSD-4 MIT public-domain"
-SLOT="0"
-IUSE="build caps +cramfs cryptsetup fdformat hardlink kill +logger ncurses nls pam python +readline selinux slang static-libs su +suid systemd test tty-helpers udev unicode userland_GNU"
-
-# Most lib deps here are related to programs rather than our libs,
-# so we rarely need to specify ${MULTILIB_USEDEP}.
-RDEPEND="
- virtual/libcrypt:=
- caps? ( sys-libs/libcap-ng )
- cramfs? ( sys-libs/zlib:= )
- cryptsetup? ( sys-fs/cryptsetup )
- ncurses? ( >=sys-libs/ncurses-5.2-r2:0=[unicode?] )
- nls? ( virtual/libintl[${MULTILIB_USEDEP}] )
- pam? ( sys-libs/pam )
- python? ( ${PYTHON_DEPS} )
- readline? ( sys-libs/readline:0= )
- selinux? ( >=sys-libs/libselinux-2.2.2-r4[${MULTILIB_USEDEP}] )
- slang? ( sys-libs/slang )
- !build? ( systemd? ( sys-apps/systemd ) )
- udev? ( virtual/libudev:= )"
-BDEPEND="
- virtual/pkgconfig
- nls? ( sys-devel/gettext )
- test? ( sys-devel/bc )
-"
-DEPEND="
- ${RDEPEND}
- virtual/os-headers
-"
-RDEPEND+="
- hardlink? ( !app-arch/hardlink )
- logger? ( !>=app-admin/sysklogd-2.0[logger] )
- kill? (
- !sys-apps/coreutils[kill]
- !sys-process/procps[kill]
- )
- su? (
- !<sys-apps/shadow-4.7-r2
- !>=sys-apps/shadow-4.7-r2[su]
- )
- !net-wireless/rfkill
- !sys-process/schedutils
- !sys-apps/setarch
- !<sys-apps/sysvinit-2.88-r7
- !<sys-libs/e2fsprogs-libs-1.41.8
- !<sys-fs/e2fsprogs-1.41.8
- !<app-shells/bash-completion-2.7-r1"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-RESTRICT="!test? ( test )"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}"/util-linux-2.35.1-include_sys_types-header.patch
- "${FILESDIR}"/util-linux-2.35.1-cleanup-pidfd-include.patch
-)
-
-src_prepare() {
- default
-
- # Prevent uuidd test failure due to socket path limit. #593304
- sed -i \
- -e "s|UUIDD_SOCKET=\"\$(mktemp -u \"\${TS_OUTDIR}/uuiddXXXXXXXXXXXXX\")\"|UUIDD_SOCKET=\"\$(mktemp -u \"${T}/uuiddXXXXXXXXXXXXX.sock\")\"|g" \
- tests/ts/uuid/uuidd || die "Failed to fix uuidd test"
-
- if ! use userland_GNU; then
- # test runner is using GNU-specific xargs call
- sed -i -e 's:xargs:gxargs:' tests/run.sh || die
- # test requires util-linux uuidgen (which we don't build)
- rm tests/ts/uuid/oids || die
- fi
-
- if [[ ${PV} == 9999 ]] ; then
- po/update-potfiles
- eautoreconf
- fi
-
- elibtoolize
-}
-
-lfs_fallocate_test() {
- # Make sure we can use fallocate with LFS #300307
- cat <<-EOF > "${T}"/fallocate.${ABI}.c
- #define _GNU_SOURCE
- #include <fcntl.h>
- main() { return fallocate(0, 0, 0, 0); }
- EOF
- append-lfs-flags
- $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} "${T}"/fallocate.${ABI}.c -o /dev/null >/dev/null 2>&1 \
- || export ac_cv_func_fallocate=no
- rm -f "${T}"/fallocate.${ABI}.c
-}
-
-python_configure() {
- local myeconfargs=(
- "${commonargs[@]}"
- --disable-all-programs
- --disable-bash-completion
- --without-systemdsystemunitdir
- --with-python
- )
- if use userland_GNU; then
- myeconfargs+=(
- --enable-libblkid
- --enable-libmount
- --enable-pylibmount
- )
- fi
- mkdir "${BUILD_DIR}" || die
- pushd "${BUILD_DIR}" >/dev/null || die
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
- popd >/dev/null || die
-}
-
-multilib_src_configure() {
- lfs_fallocate_test
- # The scanf test in a run-time test which fails while cross-compiling.
- # Blindly assume a POSIX setup since we require libmount, and libmount
- # itself fails when the scanf test fails. #531856
- tc-is-cross-compiler && export scanf_cv_alloc_modifier=ms
- export ac_cv_header_security_pam_misc_h=$(multilib_native_usex pam) #485486
- export ac_cv_header_security_pam_appl_h=$(multilib_native_usex pam) #545042
-
- # Undo bad ncurses handling by upstream. Fall back to pkg-config. #601530
- export NCURSES6_CONFIG=false NCURSES5_CONFIG=false
- export NCURSESW6_CONFIG=false NCURSESW5_CONFIG=false
-
- # configure args shared by python and non-python builds
- local commonargs=(
- --enable-fs-paths-extra="${EPREFIX}/usr/sbin:${EPREFIX}/bin:${EPREFIX}/usr/bin"
- )
-
- local myeconfargs=(
- "${commonargs[@]}"
- --with-bashcompletiondir="$(get_bashcompdir)"
- --without-python
- $(multilib_native_use_enable suid makeinstall-chown)
- $(multilib_native_use_enable suid makeinstall-setuid)
- $(multilib_native_use_with readline)
- $(multilib_native_use_with slang)
- $(multilib_native_use_with systemd)
- $(multilib_native_use_with udev)
- $(multilib_native_usex ncurses "$(use_with unicode ncursesw)" '--without-ncursesw')
- $(multilib_native_usex ncurses "$(use_with !unicode ncurses)" '--without-ncurses')
- $(tc-has-tls || echo --disable-tls)
- $(use_enable nls)
- $(use_enable unicode widechar)
- $(use_enable static-libs static)
- $(use_with ncurses tinfo)
- $(use_with selinux)
- )
- # build programs only on GNU, on *BSD we want libraries only
- if multilib_is_native_abi && use userland_GNU; then
- myeconfargs+=(
- --disable-chfn-chsh
- --disable-login
- --disable-nologin
- --disable-pylibmount
- --enable-agetty
- --enable-bash-completion
- --enable-line
- --enable-partx
- --enable-raw
- --enable-rename
- --enable-rfkill
- --enable-schedutils
- --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
- $(use_enable caps setpriv)
- $(use_enable cramfs)
- $(use_enable fdformat)
- $(use_enable hardlink)
- $(use_enable kill)
- $(use_enable logger)
- $(use_enable su)
- $(use_enable tty-helpers mesg)
- $(use_enable tty-helpers wall)
- $(use_enable tty-helpers write)
- $(use_with cryptsetup)
- )
- else
- myeconfargs+=(
- --disable-all-programs
- --disable-bash-completion
- --without-systemdsystemunitdir
- # build libraries
- --enable-libuuid
- --enable-libblkid
- --enable-libsmartcols
- --enable-libfdisk
- )
- if use userland_GNU; then
- # those libraries don't work on *BSD
- myeconfargs+=(
- --enable-libmount
- )
- fi
- fi
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-
- if multilib_is_native_abi && use python; then
- python_foreach_impl python_configure
- fi
-}
-
-python_compile() {
- pushd "${BUILD_DIR}" >/dev/null || die
- emake all
- popd >/dev/null || die
-}
-
-multilib_src_compile() {
- emake all
-
- if multilib_is_native_abi && use python; then
- python_foreach_impl python_compile
- fi
-}
-
-python_test() {
- pushd "${BUILD_DIR}" >/dev/null || die
- emake check TS_OPTS="--parallel=$(makeopts_jobs) --nonroot"
- popd >/dev/null || die
-}
-
-multilib_src_test() {
- emake check TS_OPTS="--parallel=$(makeopts_jobs) --nonroot"
- if multilib_is_native_abi && use python; then
- python_foreach_impl python_test
- fi
-}
-
-python_install() {
- pushd "${BUILD_DIR}" >/dev/null || die
- emake DESTDIR="${D}" install
- python_optimize
- popd >/dev/null || die
-}
-
-multilib_src_install() {
- if multilib_is_native_abi && use python; then
- python_foreach_impl python_install
- fi
-
- # This needs to be called AFTER python_install call (#689190)
- emake DESTDIR="${D}" install
-
- if multilib_is_native_abi && use userland_GNU; then
- # need the libs in /
- gen_usr_ldscript -a blkid fdisk mount smartcols uuid
- fi
-}
-
-multilib_src_install_all() {
- dodoc AUTHORS NEWS README* Documentation/{TODO,*.txt,releases/*}
-
- # e2fsprogs-libs didnt install .la files, and .pc work fine
- find "${ED}" -name "*.la" -delete || die
-
- if ! use userland_GNU; then
- # manpage collisions
- # TODO: figure out a good way to keep them
- rm "${ED}"/usr/share/man/man3/uuid* || die
- fi
-
- if use pam; then
- newpamd "${FILESDIR}/runuser.pamd" runuser
- newpamd "${FILESDIR}/runuser-l.pamd" runuser-l
- fi
-
- # Note:
- # Bash completion for "runuser" command is provided by same file which
- # would also provide bash completion for "su" command. However, we don't
- # use "su" command from this package.
- # This triggers a known QA warning which we ignore for now to magically
- # keep bash completion for "su" command which shadow package does not
- # provide.
-}
-
-pkg_postinst() {
- if ! use tty-helpers; then
- elog "The mesg/wall/write tools have been disabled due to USE=-tty-helpers."
- fi
-
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- elog "The agetty util now clears the terminal by default. You"
- elog "might want to add --noclear to your /etc/inittab lines."
- fi
-}