summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-12-18 14:35:15 -0500
committerMichael Orlitzky <mjo@gentoo.org>2020-12-18 17:45:38 -0500
commit77e8fdbed312558dfd23e748cc6e0dc980516f0f (patch)
tree3b9fef2de7ee17f07a4bf9203fc8a96e33595450 /sci-mathematics/flint
parentx11-libs/gtk+: bump gtk2 to EAPI 7 (diff)
downloadgentoo-77e8fdbed312558dfd23e748cc6e0dc980516f0f.tar.gz
gentoo-77e8fdbed312558dfd23e748cc6e0dc980516f0f.tar.bz2
gentoo-77e8fdbed312558dfd23e748cc6e0dc980516f0f.zip
sci-mathematics/flint: new upstream version 2.7.0.
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics/flint')
-rw-r--r--sci-mathematics/flint/Manifest1
-rw-r--r--sci-mathematics/flint/flint-2.7.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/sci-mathematics/flint/Manifest b/sci-mathematics/flint/Manifest
index 463f6c1d5f42..23761c102388 100644
--- a/sci-mathematics/flint/Manifest
+++ b/sci-mathematics/flint/Manifest
@@ -1,2 +1,3 @@
DIST flint-2.5.2.tar.gz 2212242 BLAKE2B 36b9b1f2acb1d79534d85884d755fddba3b8b40efbe92aeeecd7d1526cd21f0849054c30d23c565c6a13c609992cf22f56f5b640da15e1c7e6ba6840fc710d47 SHA512 cce36947b558aabecaf780171b4bbc0e1330c3b1a7e3580717584be5cab4991d33b190531c7995b224a3a440e28c4a610d6f781901e29f48ced12a9c5ba960a2
DIST flint-2.6.3.tar.gz 4526340 BLAKE2B d663b44166cd857f83c2752eb4d4f6dc45eb8de535089e5dbe9939ac1464f1d69f66b62184644fff1ecd1d171f389d5ab874873def670c702733a0eba17bfd13 SHA512 8e71570364c789b1d4eaaa5f5adf10212cab47bf1a9f45c333211035ed021a86bb7b1de1feec51e83b2e113e8168853e370f127d2d2b1e941a12aec71fe8ae9e
+DIST flint-2.7.0.tar.gz 4943210 BLAKE2B a23b79195c71ef4691a450a82daded3de56eb51df1b3c850e13200527fff08da668281f350d7278ff52187eba8b7d9b27f4e69fafcaf771d8a01d72c6925b062 SHA512 6eac3d6fc306cacf482379074cba0d109aae4fbe8f907c17bcfe0afc2e8603c0fbe80e88a1ac374d9fa6d87aa59eb2b973f225a69da6dcc647255f060ad8711f
diff --git a/sci-mathematics/flint/flint-2.7.0.ebuild b/sci-mathematics/flint/flint-2.7.0.ebuild
new file mode 100644
index 000000000000..d61fd70522a9
--- /dev/null
+++ b/sci-mathematics/flint/flint-2.7.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit cmake python-any-r1
+
+DESCRIPTION="Fast Library for Number Theory"
+HOMEPAGE="http://www.flintlib.org/"
+SRC_URI="http://www.flintlib.org/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+
+# Based off the soname, e.g. /usr/lib64/libflint.so -> libflint.so.15
+SLOT="0/15"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="doc ntl test"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="doc? (
+ dev-python/sphinx
+ app-text/texlive-core
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ )
+ ${PYTHON_DEPS}"
+DEPEND="dev-libs/gmp:=
+ dev-libs/mpfr:=
+ ntl? ( dev-libs/ntl:= )"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-2.6.0-multilib-strict.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_NTL="$(usex ntl)"
+ -DBUILD_TESTING="$(usex test)"
+ -DBUILD_DOCS="$(usex doc)"
+ )
+
+ cmake_src_configure
+
+ if use doc ; then
+ HTML_DOCS="${BUILD_DIR}/html/*"
+ DOCS=(
+ "${S}"/README
+ "${S}"/AUTHORS
+ "${S}"/NEWS
+ "${BUILD_DIR}"/latex/Flint.pdf
+ )
+ fi
+}
+
+src_compile() {
+ cmake_src_compile
+
+ if use doc ; then
+ cmake_build html
+ cmake_build pdf
+ fi
+}