summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-proxy/rejik
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-proxy/rejik')
-rw-r--r--net-proxy/rejik/Manifest2
-rw-r--r--net-proxy/rejik/metadata.xml11
-rw-r--r--net-proxy/rejik/rejik-3.2.10.ebuild85
3 files changed, 98 insertions, 0 deletions
diff --git a/net-proxy/rejik/Manifest b/net-proxy/rejik/Manifest
new file mode 100644
index 000000000000..48dde094e461
--- /dev/null
+++ b/net-proxy/rejik/Manifest
@@ -0,0 +1,2 @@
+DIST banlists-2.x.x.tgz 116100 SHA256 221a40e8db9d19477d6fdece00c9152526a0d2f0c2298504fc99b4378457b09e SHA512 068d01685e01679b2726da1cbc5f31f6aba54ab2194e8ab145bd2409e7fc71e3662445a8274b08746e5cdeadea2197f5a72a1abef98ec91267df851615b188b3 WHIRLPOOL 8bea0d00cf0eea807eb5a0ec645715832f3cc8ba42b3110d72c61c7474ea76df1c5823173bf2cbc241b86c43aa4d581cbfbed9bacbd5daac935a86fe030c89ec
+DIST redirector-3.2.10.tgz 45407 SHA256 1648af09df86dba5a73fa8d3ebaf02a62c281b847b96d5921507093056a0d05f SHA512 6e82341e402b149464b048e763cfa6f7bc514bae48514b482eded9288af9705942fbfd2e11b5701d3540489ec5ccab358848108fe15f25c5ab2915e44f3f1033 WHIRLPOOL 7b97124945d9d75077fe0047d5a89cf68da6ff9b8f38988e9984aed95927cc28893e50fb79863ec37109bdc872e6379cd1edbe408e30722351e9f24c90a06291
diff --git a/net-proxy/rejik/metadata.xml b/net-proxy/rejik/metadata.xml
new file mode 100644
index 000000000000..056590827b98
--- /dev/null
+++ b/net-proxy/rejik/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+ <use>
+ <flag name='banlists'>Install upstream provided simple banlists</flag>
+ </use>
+</pkgmetadata>
diff --git a/net-proxy/rejik/rejik-3.2.10.ebuild b/net-proxy/rejik/rejik-3.2.10.ebuild
new file mode 100644
index 000000000000..efe424cf6ffa
--- /dev/null
+++ b/net-proxy/rejik/rejik-3.2.10.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A squid redirector used for blocking unwanted content"
+HOMEPAGE="http://rejik.ru/"
+SRC_URI="http://rejik.ru/download/redirector-${PV}.tgz
+ banlists? ( http://rejik.ru/download/banlists-2.x.x.tgz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="banlists"
+
+DEPEND="dev-libs/libpcre"
+RDEPEND="${DEPEND}
+ dev-perl/Text-Iconv
+ dev-perl/XML-Parser
+ net-proxy/squid"
+
+S=${WORKDIR}/redirector-${PV}
+
+src_prepare() {
+ sed -i -e "s:INSTALL_PATH=/usr/local/rejik3:INSTALL_PATH=${D}/opt/rejik:g" Makefile
+ sed -i -e "s:/usr/local/rejik3:/opt/rejik:g" vars.h
+ sed -i -e "s:SQUID_USER=nobody:SQUID_USER=squid:g" Makefile
+ sed -i -e "s:SQUID_GROUP=nogroup:SQUID_GROUP=squid:g" Makefile
+ # Respect CFLAGS
+ sed -i -e "s:CC=gcc -Wall:CC=$(tc-getCC) $CFLAGS:" Makefile
+ # Respect LDFLAGS
+ sed -i -e "s:LIBS=-L/lib \`pcre-config --libs\`:LIBS=-L/lib \`pcre-config --libs\` $LDFLAGS:" Makefile
+ #
+ sed -i -e "s:error_log /usr/local/rejik3:error_log /var/log/rejik:g" redirector.conf.dist
+ sed -i -e "s:change_log /usr/local/rejik3:change_log /var/log/rejik:g" redirector.conf.dist
+ sed -i -e "s:/usr/local/rejik3:/opt/rejik:g" redirector.conf.dist
+}
+
+src_install() {
+ dodir /opt/rejik
+ exeinto /opt/rejik
+ insinto /opt/rejik
+
+ doexe make-cache
+ doexe redirector
+ doins redirector.conf.dist
+
+ dodir /opt/rejik/tools
+ insinto /opt/rejik/tools
+ exeinto /opt/rejik/tools
+
+ fperms +x tools/kill-cache
+ fperms +x tools/benchmark
+
+ doexe tools/kill-cache
+ doexe tools/benchmark
+ doins tools/IN.gz
+
+ fowners -R squid:squid /opt/rejik
+ fperms 750 /opt/rejik
+
+ keepdir /var/log/rejik
+ fowners -R squid:squid /var/log/rejik
+
+ if use banlists; then
+ insinto /opt/rejik
+ doins -r "${WORKDIR}/banlists"
+ fi
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "Copy /opt/rejik/redirector.conf.dist to /opt/rejik/redirector.conf and add line"
+ einfo "for squid 3.*"
+ einfo "url_rewrite_program /opt/rejik/redirector /opt/rejik/redirector.conf "
+ einfo "for squid 2.*"
+ einfo "redirect_program /opt/rejik/redirector /opt/rejik/redirector.conf"
+ einfo "to /etc/squid/squid.conf"
+ einfo ""
+ einfo "Dont forget to edit /opt/rejik/redirector.conf"
+ einfo "Be sure redirector.conf has right permissions"
+}