summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsoredake <fdsfgs@krutt.org>2017-11-28 11:06:24 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-11-30 00:19:20 +0100
commit41a54521bd78bd8d90e9cca129208ce9060b3b5c (patch)
treebab296ef17bb342268523cf449e37943a6f1fb50 /net-news/rssguard
parentdev-libs/tvision: Version bump to 2.2.1.4 (diff)
downloadgentoo-41a54521bd78bd8d90e9cca129208ce9060b3b5c.tar.gz
gentoo-41a54521bd78bd8d90e9cca129208ce9060b3b5c.tar.bz2
gentoo-41a54521bd78bd8d90e9cca129208ce9060b3b5c.zip
net-news/rssguard: update live version
Closes: https://github.com/gentoo/gentoo/pull/6115
Diffstat (limited to 'net-news/rssguard')
-rw-r--r--net-news/rssguard/rssguard-9999.ebuild35
1 files changed, 16 insertions, 19 deletions
diff --git a/net-news/rssguard/rssguard-9999.ebuild b/net-news/rssguard/rssguard-9999.ebuild
index 4ca7b2a43990..06be77e74c1c 100644
--- a/net-news/rssguard/rssguard-9999.ebuild
+++ b/net-news/rssguard/rssguard-9999.ebuild
@@ -1,43 +1,40 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit git-r3 qmake-utils
+inherit flag-o-matic git-r3 qmake-utils
DESCRIPTION="A tiny RSS and Atom feed reader"
HOMEPAGE="https://github.com/martinrotter/rssguard"
-EGIT_REPO_URI="https://github.com/martinrotter/${PN}.git"
+EGIT_REPO_URI="https://github.com/martinrotter/rssguard.git"
EGIT_SUBMODULES=()
LICENSE="GPL-3"
SLOT="0"
IUSE="debug webengine"
+MINQT="5.8:5"
RDEPEND="
- >=dev-qt/qtcore-5.6:5
- >=dev-qt/qtgui-5.6:5
- >=dev-qt/qtnetwork-5.6:5
- >=dev-qt/qtsql-5.6:5
- >=dev-qt/qtwidgets-5.6:5
- >=dev-qt/qtxml-5.6:5
- webengine? ( >=dev-qt/qtwebengine-5.6:5[widgets] )
+ >=dev-qt/qtcore-${MINQT}
+ >=dev-qt/qtgui-${MINQT}
+ >=dev-qt/qtnetwork-${MINQT}
+ >=dev-qt/qtsql-${MINQT}
+ >=dev-qt/qtwidgets-${MINQT}
+ >=dev-qt/qtxml-${MINQT}
+ webengine? ( >=dev-qt/qtwebengine-${MINQT}[widgets] )
"
DEPEND="${RDEPEND}
- >=dev-qt/linguist-tools-5.6:5
+ >=dev-qt/linguist-tools-${MINQT}
"
-src_prepare() {
- default
-
- # remove bundled qtbase translations
- rm -v localization/qtbase* || die
- sed -i -e "s|localization/qtbase_[a-z][a-z].ts||g" ${PN}.pro || die
-}
-
src_configure() {
+ # needed after 8eb640b6f2e140e7c5a1adbe5532cf3662d850b5
+ "$(qt5_get_bindir)/lrelease" rssguard.pro || die "lrelease failed"
+ # CONFIG+=ltcg is needed because of https://github.com/martinrotter/rssguard/issues/156
eqmake5 \
CONFIG+=$(usex debug debug release) \
+ $(is-flagq -flto* && echo "CONFIG+=ltcg") \
USE_WEBENGINE=$(usex webengine true false) \
LRELEASE_EXECUTABLE="$(qt5_get_bindir)/lrelease" \
PREFIX="${EPREFIX}"/usr \