summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-11-03 20:05:07 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-11-03 20:11:55 -0500
commitb6f38b3c9e1e2e703a7d36f5a54b706424d122ce (patch)
treea371a71f9ae6cf339d0df04a739b4f968f0dd9d9 /net-misc
parentnet-misc/rsync: drop 3.2.7-r3 (diff)
downloadgentoo-b6f38b3c9e1e2e703a7d36f5a54b706424d122ce.tar.gz
gentoo-b6f38b3c9e1e2e703a7d36f5a54b706424d122ce.tar.bz2
gentoo-b6f38b3c9e1e2e703a7d36f5a54b706424d122ce.zip
net-misc/yt-dlp: add 2024.11.04
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/yt-dlp/Manifest1
-rw-r--r--net-misc/yt-dlp/yt-dlp-2024.11.04.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/net-misc/yt-dlp/Manifest b/net-misc/yt-dlp/Manifest
index e14b09d20829..69ae48485f3d 100644
--- a/net-misc/yt-dlp/Manifest
+++ b/net-misc/yt-dlp/Manifest
@@ -1,2 +1,3 @@
DIST yt-dlp-2024.10.07.tar.gz 5752925 BLAKE2B c903ed6aaf88d96f0c99b0daa2d06b3388352ef0c100078e3474653ef8adc9a4c6988d01b118f03f187474ce0c3e90f36cfaa88e099527ee717127e0cb40c76f SHA512 2eef4db06cf970a7a8d84941daa28b193790f4cdc372794500c88beecfbd0e4dc464abc4cd53fb315d147c42c62bb9010f0a8903e68afaadce80c663bd734f27
DIST yt-dlp-2024.10.22.tar.gz 5766340 BLAKE2B 6a1d0b1358196224b99333dec155b37401c1c73ad4d65752b8e776758aa1eec448317ebec9b007db1f318424f5853b4d25bec1b925032c7b9567c7c1496ed775 SHA512 486463af3487d3773fbeb975c741164131b802eac621eb1dc43f47704bcf2405bbb62b72d0fcc41a5b7e1651c81aec9fe284a42217bf06148d1870fbe362b0d7
+DIST yt-dlp-2024.11.04.tar.gz 5790714 BLAKE2B 01e28d2058ee7f899b8046bb8409b4eadcc2eb4ed2881068a9710913fea92fb37c5f7e638d94d0d1ef8314549d161c5e5b2a4a4065ad9620610ddd73cbcdeb0f SHA512 6af8973ca83cd622cfd61bbdd02fea6db34eb9b3986b9b2c402b7828d1c9da6c2931fc616f43be08be5332c6b2b1707a9ed21a14b71f639a5891a0ecbd1baccd
diff --git a/net-misc/yt-dlp/yt-dlp-2024.11.04.ebuild b/net-misc/yt-dlp/yt-dlp-2024.11.04.ebuild
new file mode 100644
index 000000000000..3de67e0bfb4a
--- /dev/null
+++ b/net-misc/yt-dlp/yt-dlp-2024.11.04.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+inherit bash-completion-r1 distutils-r1 optfeature wrapper
+
+DESCRIPTION="youtube-dl fork with additional features and fixes"
+HOMEPAGE="https://github.com/yt-dlp/yt-dlp/"
+SRC_URI="
+ https://github.com/yt-dlp/yt-dlp/releases/download/${PV}/${PN}.tar.gz
+ -> ${P}.tar.gz
+"
+S=${WORKDIR}/${PN}
+
+LICENSE="Unlicense"
+SLOT="0"
+# note that yt-dlp bumps are typically done straight-to-stable (unless there
+# was major/breaking changes) given website changes breaks it on a whim
+KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~riscv x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ !net-misc/youtube-dl[-yt-dlp(-)]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # fails with FEATURES=network-sandbox
+ test/test_networking.py::TestHTTPRequestHandler::test_connect_timeout
+ # fails with FEATURES=distcc, bug #915614
+ test/test_networking.py::TestYoutubeDLNetworking::test_proxy\[None-expected2\]
+ )
+
+ epytest -m 'not download'
+}
+
+python_install_all() {
+ dodoc README.md Changelog.md supportedsites.md
+ doman yt-dlp.1
+
+ dobashcomp completions/bash/yt-dlp
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/fish/yt-dlp.fish
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/zsh/_yt-dlp
+
+ rm -r "${ED}"/usr/share/doc/yt_dlp || die
+
+ make_wrapper youtube-dl "yt-dlp --compat-options youtube-dl"
+}
+
+pkg_postinst() {
+ optfeature "various features (merging tracks, streamed content)" media-video/ffmpeg
+ has_version media-video/atomicparsley || # allow fallback but don't advertise
+ optfeature "embedding metadata thumbnails in MP4/M4A files" media-libs/mutagen
+ optfeature "decrypting cookies from Chromium-based browsers" dev-python/secretstorage
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog 'A wrapper using "yt-dlp --compat-options youtube-dl" was installed'
+ elog 'as "youtube-dl". This is strictly for compatibility and it is'
+ elog 'recommended to use "yt-dlp" directly, it may be removed in the future.'
+ fi
+}