summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/curl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/curl')
-rw-r--r--net-misc/curl/Manifest2
-rw-r--r--net-misc/curl/curl-7.42.1-r1.ebuild244
-rw-r--r--net-misc/curl/curl-7.42.1.ebuild243
-rw-r--r--net-misc/curl/curl-7.43.0.ebuild244
-rw-r--r--net-misc/curl/files/curl-7.30.0-prefix.patch21
-rw-r--r--net-misc/curl/files/curl-fix-gnutls-nettle.patch27
-rw-r--r--net-misc/curl/files/curl-respect-cflags-3.patch14
-rw-r--r--net-misc/curl/metadata.xml25
8 files changed, 820 insertions, 0 deletions
diff --git a/net-misc/curl/Manifest b/net-misc/curl/Manifest
new file mode 100644
index 000000000000..eb700fb3e16c
--- /dev/null
+++ b/net-misc/curl/Manifest
@@ -0,0 +1,2 @@
+DIST curl-7.42.1.tar.bz2 3327304 SHA256 e2905973391ec2dfd7743a8034ad10eeb58dab8b3a297e7892a41a7999cac887 SHA512 846c2d2bc73d39240686bf54e4c02553a1ca1640123fef30538cfc8a6317650f4cb9f1cc882016b7826ef9c84cb92adbfa24e55d59d2e7203bdcb12835fb474f WHIRLPOOL ff826e11812334ebca650c54788bf1b81b2927f7b9607b10e79cc70f6d1f9b893aebc816914158243510ffaead3b15a21ce10e7180eeb175b0b503e9ac8b0c6e
+DIST curl-7.43.0.tar.bz2 3363770 SHA256 baa654a1122530483ccc1c58cc112fec3724a82c11c6a389f1e6a37dc8858df9 SHA512 0b06ec078680619f56a458ac115142546134917331b71b73ed2c0371c480034dac7ed848814be0dd1e752154c53e48b9e0276b83f75a690df6cfb480ab331272 WHIRLPOOL e5c97b3cbf0f9915f62a100ce2972e6cffcabae753770c2f0a1fc3bcef3a66c0a2d4d7e361b00f442d62eca3b0d9526eb34f6b043fb655648180e81ef630a527
diff --git a/net-misc/curl/curl-7.42.1-r1.ebuild b/net-misc/curl/curl-7.42.1-r1.ebuild
new file mode 100644
index 000000000000..85e5f86dc206
--- /dev/null
+++ b/net-misc/curl/curl-7.42.1-r1.ebuild
@@ -0,0 +1,244 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools eutils prefix multilib-minimal
+
+DESCRIPTION="A Client that groks URLs"
+HOMEPAGE="http://curl.haxx.se/"
+SRC_URI="http://curl.haxx.se/download/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="adns http2 idn ipv6 kerberos ldap metalink rtmp samba ssh ssl static-libs test threads"
+IUSE+=" curl_ssl_axtls curl_ssl_gnutls curl_ssl_nss +curl_ssl_openssl curl_ssl_polarssl curl_ssl_winssl"
+IUSE+=" elibc_Winnt"
+
+#lead to lots of false negatives, bug #285669
+RESTRICT="test"
+
+RDEPEND="ldap? ( >=net-nds/openldap-2.4.38-r1[${MULTILIB_USEDEP}] )
+ ssl? (
+ curl_ssl_axtls? (
+ >=net-libs/axtls-1.4.9-r1[${MULTILIB_USEDEP}]
+ app-misc/ca-certificates
+ )
+ curl_ssl_gnutls? (
+ || (
+ (
+ >=net-libs/gnutls-3.2.15[static-libs?,${MULTILIB_USEDEP}]
+ >=dev-libs/nettle-2.6[${MULTILIB_USEDEP}]
+ )
+ (
+ =net-libs/gnutls-2.12*[nettle,static-libs?,${MULTILIB_USEDEP}]
+ >=dev-libs/nettle-2.6[${MULTILIB_USEDEP}]
+ )
+ (
+ =net-libs/gnutls-2.12*[-nettle,static-libs?,${MULTILIB_USEDEP}]
+ >=dev-libs/libgcrypt-1.5.3[static-libs?,${MULTILIB_USEDEP}]
+ )
+ )
+ app-misc/ca-certificates
+ )
+ curl_ssl_openssl? (
+ >=dev-libs/openssl-1.0.1h-r2[static-libs?,${MULTILIB_USEDEP}]
+ )
+ curl_ssl_nss? (
+ >=dev-libs/nss-3.15.4[${MULTILIB_USEDEP}]
+ app-misc/ca-certificates
+ )
+ curl_ssl_polarssl? (
+ >=net-libs/polarssl-1.3.4:=[${MULTILIB_USEDEP}]
+ app-misc/ca-certificates
+ )
+ )
+ http2? ( =net-libs/nghttp2-0.7*[${MULTILIB_USEDEP}] )
+ idn? ( >=net-dns/libidn-1.28[static-libs?,${MULTILIB_USEDEP}] )
+ adns? ( >=net-dns/c-ares-1.10.0-r1[${MULTILIB_USEDEP}] )
+ kerberos? ( >=virtual/krb5-0-r1[${MULTILIB_USEDEP}] )
+ metalink? ( >=media-libs/libmetalink-0.1.1[${MULTILIB_USEDEP}] )
+ rtmp? ( >=media-video/rtmpdump-2.4_p20131018[${MULTILIB_USEDEP}] )
+ ssh? ( >=net-libs/libssh2-1.4.3[static-libs?,${MULTILIB_USEDEP}] )
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20140508-r13
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )"
+
+# Do we need to enforce the same ssl backend for curl and rtmpdump? Bug #423303
+# rtmp? (
+# media-video/rtmpdump
+# curl_ssl_gnutls? ( media-video/rtmpdump[gnutls] )
+# curl_ssl_openssl? ( media-video/rtmpdump[-gnutls,ssl] )
+# )
+
+# ssl providers to be added:
+# fbopenssl $(use_with spnego)
+
+# krb4 http://web.mit.edu/kerberos/www/krb4-end-of-life.html
+
+DEPEND="${RDEPEND}
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+ test? (
+ sys-apps/diffutils
+ dev-lang/perl
+ )"
+
+# c-ares must be disabled for threads
+# only one ssl provider can be enabled
+REQUIRED_USE="
+ curl_ssl_winssl? ( elibc_Winnt )
+ threads? ( !adns )
+ ssl? (
+ ^^ (
+ curl_ssl_axtls
+ curl_ssl_gnutls
+ curl_ssl_openssl
+ curl_ssl_nss
+ curl_ssl_polarssl
+ curl_ssl_winssl
+ )
+ )"
+
+DOCS=( CHANGES README docs/FEATURES docs/INTERNALS \
+ docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE)
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/curl/curlbuild.h
+)
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/curl-config
+)
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-7.30.0-prefix.patch \
+ "${FILESDIR}"/${PN}-respect-cflags-3.patch \
+ "${FILESDIR}"/${PN}-fix-gnutls-nettle.patch
+
+ sed -i '/LD_LIBRARY_PATH=/d' configure.ac || die #382241
+
+ epatch_user
+ eprefixify curl-config.in
+ eautoreconf
+}
+
+multilib_src_configure() {
+ einfo "\033[1;32m**************************************************\033[00m"
+
+ # We make use of the fact that later flags override earlier ones
+ # So start with all ssl providers off until proven otherwise
+ local myconf=()
+ myconf+=( --without-axtls --without-gnutls --without-nss --without-polarssl --without-ssl --without-winssl )
+ myconf+=( --with-ca-bundle="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt )
+ if use ssl ; then
+ if use curl_ssl_axtls; then
+ einfo "SSL provided by axtls"
+ einfo "NOTE: axtls is meant for embedded systems and"
+ einfo "may not be the best choice as an ssl provider"
+ myconf+=( --with-axtls )
+ fi
+ if use curl_ssl_gnutls; then
+ einfo "SSL provided by gnutls"
+ if has_version ">=net-libs/gnutls-3.2.15[${MULTILIB_USEDEP}]" || has_version "=net-libs/gnutls-2.12*[nettle,${MULTILIB_USEDEP}]"; then
+ einfo "gnutls compiled with dev-libs/nettle"
+ myconf+=( --with-gnutls --with-nettle )
+ else
+ einfo "gnutls compiled with dev-libs/libgcrypt"
+ myconf+=( --with-gnutls --without-nettle )
+ fi
+ fi
+ if use curl_ssl_nss; then
+ einfo "SSL provided by nss"
+ myconf+=( --with-nss )
+ fi
+ if use curl_ssl_polarssl; then
+ einfo "SSL provided by polarssl"
+ einfo "NOTE: polarssl is meant for embedded systems and"
+ einfo "may not be the best choice as an ssl provider"
+ myconf+=( --with-polarssl )
+ fi
+ if use curl_ssl_openssl; then
+ einfo "SSL provided by openssl"
+ myconf+=( --with-ssl --with-ca-path="${EPREFIX}"/etc/ssl/certs )
+ fi
+ if use curl_ssl_winssl; then
+ einfo "SSL provided by Windows"
+ myconf+=( --with-winssl )
+ fi
+ else
+ einfo "SSL disabled"
+ fi
+ einfo "\033[1;32m**************************************************\033[00m"
+
+ # These configuration options are organized alphabetically
+ # within each category. This should make it easier if we
+ # ever decide to make any of them contingent on USE flags:
+ # 1) protocols first. To see them all do
+ # 'grep SUPPORT_PROTOCOLS configure.ac'
+ # 2) --enable/disable options second.
+ # 'grep -- --enable configure | grep Check | awk '{ print $4 }' | sort
+ # 3) --with/without options third.
+ # grep -- --with configure | grep Check | awk '{ print $4 }' | sort
+ ECONF_SOURCE="${S}" \
+ econf \
+ --enable-dict \
+ --enable-file \
+ --enable-ftp \
+ --enable-gopher \
+ --enable-http \
+ --enable-imap \
+ $(use_enable ldap) \
+ $(use_enable ldap ldaps) \
+ --enable-pop3 \
+ --enable-rtsp \
+ $(use_enable samba smb) \
+ $(use_with ssh libssh2) \
+ --enable-smtp \
+ --enable-telnet \
+ --enable-tftp \
+ $(use_enable adns ares) \
+ --enable-cookies \
+ --enable-hidden-symbols \
+ $(use_enable ipv6) \
+ --enable-largefile \
+ --enable-manual \
+ --enable-proxy \
+ --disable-soname-bump \
+ --disable-sspi \
+ $(use_enable static-libs static) \
+ $(use_enable threads threaded-resolver) \
+ --disable-versioned-symbols \
+ --without-cyassl \
+ --without-darwinssl \
+ $(use_with idn libidn) \
+ $(use_with kerberos gssapi "${EPREFIX}"/usr) \
+ --without-krb4 \
+ $(use_with metalink libmetalink) \
+ $(use_with http2 nghttp2) \
+ $(use_with rtmp librtmp) \
+ --without-spnego \
+ --without-winidn \
+ --with-zlib \
+ "${myconf[@]}"
+
+ if ! multilib_is_native_abi; then
+ # avoid building the client
+ sed -i -e '/SUBDIRS/s:src::' Makefile || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --all
+
+ rm -rf "${ED}"/etc/
+
+ # https://sourceforge.net/tracker/index.php?func=detail&aid=1705197&group_id=976&atid=350976
+ insinto /usr/share/aclocal
+ doins docs/libcurl/libcurl.m4
+}
diff --git a/net-misc/curl/curl-7.42.1.ebuild b/net-misc/curl/curl-7.42.1.ebuild
new file mode 100644
index 000000000000..93e5bc53d5b9
--- /dev/null
+++ b/net-misc/curl/curl-7.42.1.ebuild
@@ -0,0 +1,243 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools eutils prefix multilib-minimal
+
+DESCRIPTION="A Client that groks URLs"
+HOMEPAGE="http://curl.haxx.se/"
+SRC_URI="http://curl.haxx.se/download/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="adns idn ipv6 kerberos ldap metalink rtmp samba ssh ssl static-libs test threads"
+IUSE="${IUSE} curl_ssl_axtls curl_ssl_gnutls curl_ssl_nss +curl_ssl_openssl curl_ssl_polarssl curl_ssl_winssl"
+IUSE="${IUSE} elibc_Winnt"
+
+#lead to lots of false negatives, bug #285669
+RESTRICT="test"
+
+RDEPEND="ldap? ( >=net-nds/openldap-2.4.38-r1[${MULTILIB_USEDEP}] )
+ ssl? (
+ curl_ssl_axtls? (
+ >=net-libs/axtls-1.4.9-r1[${MULTILIB_USEDEP}]
+ app-misc/ca-certificates
+ )
+ curl_ssl_gnutls? (
+ || (
+ (
+ >=net-libs/gnutls-3.2.15[static-libs?,${MULTILIB_USEDEP}]
+ >=dev-libs/nettle-2.6[${MULTILIB_USEDEP}]
+ )
+ (
+ =net-libs/gnutls-2.12*[nettle,static-libs?,${MULTILIB_USEDEP}]
+ >=dev-libs/nettle-2.6[${MULTILIB_USEDEP}]
+ )
+ (
+ =net-libs/gnutls-2.12*[-nettle,static-libs?,${MULTILIB_USEDEP}]
+ >=dev-libs/libgcrypt-1.5.3[static-libs?,${MULTILIB_USEDEP}]
+ )
+ )
+ app-misc/ca-certificates
+ )
+ curl_ssl_openssl? (
+ >=dev-libs/openssl-1.0.1h-r2[static-libs?,${MULTILIB_USEDEP}]
+ )
+ curl_ssl_nss? (
+ >=dev-libs/nss-3.15.4[${MULTILIB_USEDEP}]
+ app-misc/ca-certificates
+ )
+ curl_ssl_polarssl? (
+ >=net-libs/polarssl-1.3.4:=[${MULTILIB_USEDEP}]
+ app-misc/ca-certificates
+ )
+ )
+ idn? ( >=net-dns/libidn-1.28[static-libs?,${MULTILIB_USEDEP}] )
+ adns? ( >=net-dns/c-ares-1.10.0-r1[${MULTILIB_USEDEP}] )
+ kerberos? ( >=virtual/krb5-0-r1[${MULTILIB_USEDEP}] )
+ metalink? ( >=media-libs/libmetalink-0.1.1[${MULTILIB_USEDEP}] )
+ rtmp? ( >=media-video/rtmpdump-2.4_p20131018[${MULTILIB_USEDEP}] )
+ ssh? ( >=net-libs/libssh2-1.4.3[static-libs?,${MULTILIB_USEDEP}] )
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20140508-r13
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )"
+
+# Do we need to enforce the same ssl backend for curl and rtmpdump? Bug #423303
+# rtmp? (
+# media-video/rtmpdump
+# curl_ssl_gnutls? ( media-video/rtmpdump[gnutls] )
+# curl_ssl_openssl? ( media-video/rtmpdump[-gnutls,ssl] )
+# )
+
+# ssl providers to be added:
+# fbopenssl $(use_with spnego)
+
+# krb4 http://web.mit.edu/kerberos/www/krb4-end-of-life.html
+
+DEPEND="${RDEPEND}
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+ test? (
+ sys-apps/diffutils
+ dev-lang/perl
+ )"
+
+# c-ares must be disabled for threads
+# only one ssl provider can be enabled
+REQUIRED_USE="
+ curl_ssl_winssl? ( elibc_Winnt )
+ threads? ( !adns )
+ ssl? (
+ ^^ (
+ curl_ssl_axtls
+ curl_ssl_gnutls
+ curl_ssl_openssl
+ curl_ssl_nss
+ curl_ssl_polarssl
+ curl_ssl_winssl
+ )
+ )"
+
+DOCS=( CHANGES README docs/FEATURES docs/INTERNALS \
+ docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE)
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/curl/curlbuild.h
+)
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/curl-config
+)
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-7.30.0-prefix.patch \
+ "${FILESDIR}"/${PN}-respect-cflags-3.patch \
+ "${FILESDIR}"/${PN}-fix-gnutls-nettle.patch
+
+ sed -i '/LD_LIBRARY_PATH=/d' configure.ac || die #382241
+
+ epatch_user
+ eprefixify curl-config.in
+ eautoreconf
+}
+
+multilib_src_configure() {
+ einfo "\033[1;32m**************************************************\033[00m"
+
+ # We make use of the fact that later flags override earlier ones
+ # So start with all ssl providers off until proven otherwise
+ local myconf=()
+ myconf+=( --without-axtls --without-gnutls --without-nss --without-polarssl --without-ssl --without-winssl )
+ myconf+=( --with-ca-bundle="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt )
+ if use ssl ; then
+ if use curl_ssl_axtls; then
+ einfo "SSL provided by axtls"
+ einfo "NOTE: axtls is meant for embedded systems and"
+ einfo "may not be the best choice as an ssl provider"
+ myconf+=( --with-axtls )
+ fi
+ if use curl_ssl_gnutls; then
+ einfo "SSL provided by gnutls"
+ if has_version ">=net-libs/gnutls-3.2.15[${MULTILIB_USEDEP}]" || has_version "=net-libs/gnutls-2.12*[nettle,${MULTILIB_USEDEP}]"; then
+ einfo "gnutls compiled with dev-libs/nettle"
+ myconf+=( --with-gnutls --with-nettle )
+ else
+ einfo "gnutls compiled with dev-libs/libgcrypt"
+ myconf+=( --with-gnutls --without-nettle )
+ fi
+ fi
+ if use curl_ssl_nss; then
+ einfo "SSL provided by nss"
+ myconf+=( --with-nss )
+ fi
+ if use curl_ssl_polarssl; then
+ einfo "SSL provided by polarssl"
+ einfo "NOTE: polarssl is meant for embedded systems and"
+ einfo "may not be the best choice as an ssl provider"
+ myconf+=( --with-polarssl )
+ fi
+ if use curl_ssl_openssl; then
+ einfo "SSL provided by openssl"
+ myconf+=( --with-ssl --with-ca-path="${EPREFIX}"/etc/ssl/certs )
+ fi
+ if use curl_ssl_winssl; then
+ einfo "SSL provided by Windows"
+ myconf+=( --with-winssl )
+ fi
+ else
+ einfo "SSL disabled"
+ fi
+ einfo "\033[1;32m**************************************************\033[00m"
+
+ # These configuration options are organized alphabetically
+ # within each category. This should make it easier if we
+ # ever decide to make any of them contingent on USE flags:
+ # 1) protocols first. To see them all do
+ # 'grep SUPPORT_PROTOCOLS configure.ac'
+ # 2) --enable/disable options second.
+ # 'grep -- --enable configure | grep Check | awk '{ print $4 }' | sort
+ # 3) --with/without options third.
+ # grep -- --with configure | grep Check | awk '{ print $4 }' | sort
+ ECONF_SOURCE="${S}" \
+ econf \
+ --enable-dict \
+ --enable-file \
+ --enable-ftp \
+ --enable-gopher \
+ --enable-http \
+ --enable-imap \
+ $(use_enable ldap) \
+ $(use_enable ldap ldaps) \
+ --enable-pop3 \
+ --enable-rtsp \
+ $(use_enable samba smb) \
+ $(use_with ssh libssh2) \
+ --enable-smtp \
+ --enable-telnet \
+ --enable-tftp \
+ $(use_enable adns ares) \
+ --enable-cookies \
+ --enable-hidden-symbols \
+ $(use_enable ipv6) \
+ --enable-largefile \
+ --enable-manual \
+ --enable-proxy \
+ --disable-soname-bump \
+ --disable-sspi \
+ $(use_enable static-libs static) \
+ $(use_enable threads threaded-resolver) \
+ --disable-versioned-symbols \
+ --without-cyassl \
+ --without-darwinssl \
+ $(use_with idn libidn) \
+ $(use_with kerberos gssapi "${EPREFIX}"/usr) \
+ --without-krb4 \
+ $(use_with metalink libmetalink) \
+ --without-nghttp2 \
+ $(use_with rtmp librtmp) \
+ --without-spnego \
+ --without-winidn \
+ --with-zlib \
+ "${myconf[@]}"
+
+ if ! multilib_is_native_abi; then
+ # avoid building the client
+ sed -i -e '/SUBDIRS/s:src::' Makefile || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --all
+
+ rm -rf "${ED}"/etc/
+
+ # https://sourceforge.net/tracker/index.php?func=detail&aid=1705197&group_id=976&atid=350976
+ insinto /usr/share/aclocal
+ doins docs/libcurl/libcurl.m4
+}
diff --git a/net-misc/curl/curl-7.43.0.ebuild b/net-misc/curl/curl-7.43.0.ebuild
new file mode 100644
index 000000000000..434cff2396b1
--- /dev/null
+++ b/net-misc/curl/curl-7.43.0.ebuild
@@ -0,0 +1,244 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools eutils prefix multilib-minimal
+
+DESCRIPTION="A Client that groks URLs"
+HOMEPAGE="http://curl.haxx.se/"
+SRC_URI="http://curl.haxx.se/download/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="adns http2 idn ipv6 kerberos ldap metalink rtmp samba ssh ssl static-libs test threads"
+IUSE+=" curl_ssl_axtls curl_ssl_gnutls curl_ssl_nss +curl_ssl_openssl curl_ssl_polarssl curl_ssl_winssl"
+IUSE+=" elibc_Winnt"
+
+#lead to lots of false negatives, bug #285669
+RESTRICT="test"
+
+RDEPEND="ldap? ( >=net-nds/openldap-2.4.38-r1[${MULTILIB_USEDEP}] )
+ ssl? (
+ curl_ssl_axtls? (
+ >=net-libs/axtls-1.4.9-r1[${MULTILIB_USEDEP}]
+ app-misc/ca-certificates
+ )
+ curl_ssl_gnutls? (
+ || (
+ (
+ >=net-libs/gnutls-3.2.15[static-libs?,${MULTILIB_USEDEP}]
+ >=dev-libs/nettle-2.6[${MULTILIB_USEDEP}]
+ )
+ (
+ =net-libs/gnutls-2.12*[nettle,static-libs?,${MULTILIB_USEDEP}]
+ >=dev-libs/nettle-2.6[${MULTILIB_USEDEP}]
+ )
+ (
+ =net-libs/gnutls-2.12*[-nettle,static-libs?,${MULTILIB_USEDEP}]
+ >=dev-libs/libgcrypt-1.5.3[static-libs?,${MULTILIB_USEDEP}]
+ )
+ )
+ app-misc/ca-certificates
+ )
+ curl_ssl_openssl? (
+ >=dev-libs/openssl-1.0.1h-r2[static-libs?,${MULTILIB_USEDEP}]
+ )
+ curl_ssl_nss? (
+ >=dev-libs/nss-3.15.4[${MULTILIB_USEDEP}]
+ app-misc/ca-certificates
+ )
+ curl_ssl_polarssl? (
+ >=net-libs/polarssl-1.3.4:=[${MULTILIB_USEDEP}]
+ app-misc/ca-certificates
+ )
+ )
+ http2? ( net-libs/nghttp2[${MULTILIB_USEDEP}] )
+ idn? ( >=net-dns/libidn-1.28[static-libs?,${MULTILIB_USEDEP}] )
+ adns? ( >=net-dns/c-ares-1.10.0-r1[${MULTILIB_USEDEP}] )
+ kerberos? ( >=virtual/krb5-0-r1[${MULTILIB_USEDEP}] )
+ metalink? ( >=media-libs/libmetalink-0.1.1[${MULTILIB_USEDEP}] )
+ rtmp? ( >=media-video/rtmpdump-2.4_p20131018[${MULTILIB_USEDEP}] )
+ ssh? ( >=net-libs/libssh2-1.4.3[static-libs?,${MULTILIB_USEDEP}] )
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20140508-r13
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )"
+
+# Do we need to enforce the same ssl backend for curl and rtmpdump? Bug #423303
+# rtmp? (
+# media-video/rtmpdump
+# curl_ssl_gnutls? ( media-video/rtmpdump[gnutls] )
+# curl_ssl_openssl? ( media-video/rtmpdump[-gnutls,ssl] )
+# )
+
+# ssl providers to be added:
+# fbopenssl $(use_with spnego)
+
+# krb4 http://web.mit.edu/kerberos/www/krb4-end-of-life.html
+
+DEPEND="${RDEPEND}
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+ test? (
+ sys-apps/diffutils
+ dev-lang/perl
+ )"
+
+# c-ares must be disabled for threads
+# only one ssl provider can be enabled
+REQUIRED_USE="
+ curl_ssl_winssl? ( elibc_Winnt )
+ threads? ( !adns )
+ ssl? (
+ ^^ (
+ curl_ssl_axtls
+ curl_ssl_gnutls
+ curl_ssl_openssl
+ curl_ssl_nss
+ curl_ssl_polarssl
+ curl_ssl_winssl
+ )
+ )"
+
+DOCS=( CHANGES README docs/FEATURES docs/INTERNALS \
+ docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE)
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/curl/curlbuild.h
+)
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/curl-config
+)
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-7.30.0-prefix.patch \
+ "${FILESDIR}"/${PN}-respect-cflags-3.patch \
+ "${FILESDIR}"/${PN}-fix-gnutls-nettle.patch
+
+ sed -i '/LD_LIBRARY_PATH=/d' configure.ac || die #382241
+
+ epatch_user
+ eprefixify curl-config.in
+ eautoreconf
+}
+
+multilib_src_configure() {
+ einfo "\033[1;32m**************************************************\033[00m"
+
+ # We make use of the fact that later flags override earlier ones
+ # So start with all ssl providers off until proven otherwise
+ local myconf=()
+ myconf+=( --without-axtls --without-gnutls --without-nss --without-polarssl --without-ssl --without-winssl )
+ myconf+=( --with-ca-bundle="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt )
+ if use ssl ; then
+ if use curl_ssl_axtls; then
+ einfo "SSL provided by axtls"
+ einfo "NOTE: axtls is meant for embedded systems and"
+ einfo "may not be the best choice as an ssl provider"
+ myconf+=( --with-axtls )
+ fi
+ if use curl_ssl_gnutls; then
+ einfo "SSL provided by gnutls"
+ if has_version ">=net-libs/gnutls-3.2.15[${MULTILIB_USEDEP}]" || has_version "=net-libs/gnutls-2.12*[nettle,${MULTILIB_USEDEP}]"; then
+ einfo "gnutls compiled with dev-libs/nettle"
+ myconf+=( --with-gnutls --with-nettle )
+ else
+ einfo "gnutls compiled with dev-libs/libgcrypt"
+ myconf+=( --with-gnutls --without-nettle )
+ fi
+ fi
+ if use curl_ssl_nss; then
+ einfo "SSL provided by nss"
+ myconf+=( --with-nss )
+ fi
+ if use curl_ssl_polarssl; then
+ einfo "SSL provided by polarssl"
+ einfo "NOTE: polarssl is meant for embedded systems and"
+ einfo "may not be the best choice as an ssl provider"
+ myconf+=( --with-polarssl )
+ fi
+ if use curl_ssl_openssl; then
+ einfo "SSL provided by openssl"
+ myconf+=( --with-ssl --with-ca-path="${EPREFIX}"/etc/ssl/certs )
+ fi
+ if use curl_ssl_winssl; then
+ einfo "SSL provided by Windows"
+ myconf+=( --with-winssl )
+ fi
+ else
+ einfo "SSL disabled"
+ fi
+ einfo "\033[1;32m**************************************************\033[00m"
+
+ # These configuration options are organized alphabetically
+ # within each category. This should make it easier if we
+ # ever decide to make any of them contingent on USE flags:
+ # 1) protocols first. To see them all do
+ # 'grep SUPPORT_PROTOCOLS configure.ac'
+ # 2) --enable/disable options second.
+ # 'grep -- --enable configure | grep Check | awk '{ print $4 }' | sort
+ # 3) --with/without options third.
+ # grep -- --with configure | grep Check | awk '{ print $4 }' | sort
+ ECONF_SOURCE="${S}" \
+ econf \
+ --enable-dict \
+ --enable-file \
+ --enable-ftp \
+ --enable-gopher \
+ --enable-http \
+ --enable-imap \
+ $(use_enable ldap) \
+ $(use_enable ldap ldaps) \
+ --enable-pop3 \
+ --enable-rtsp \
+ $(use_enable samba smb) \
+ $(use_with ssh libssh2) \
+ --enable-smtp \
+ --enable-telnet \
+ --enable-tftp \
+ $(use_enable adns ares) \
+ --enable-cookies \
+ --enable-hidden-symbols \
+ $(use_enable ipv6) \
+ --enable-largefile \
+ --enable-manual \
+ --enable-proxy \
+ --disable-soname-bump \
+ --disable-sspi \
+ $(use_enable static-libs static) \
+ $(use_enable threads threaded-resolver) \
+ --disable-versioned-symbols \
+ --without-cyassl \
+ --without-darwinssl \
+ $(use_with idn libidn) \
+ $(use_with kerberos gssapi "${EPREFIX}"/usr) \
+ --without-krb4 \
+ $(use_with metalink libmetalink) \
+ $(use_with http2 nghttp2) \
+ $(use_with rtmp librtmp) \
+ --without-spnego \
+ --without-winidn \
+ --with-zlib \
+ "${myconf[@]}"
+
+ if ! multilib_is_native_abi; then
+ # avoid building the client
+ sed -i -e '/SUBDIRS/s:src::' Makefile || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --all
+
+ rm -rf "${ED}"/etc/
+
+ # https://sourceforge.net/tracker/index.php?func=detail&aid=1705197&group_id=976&atid=350976
+ insinto /usr/share/aclocal
+ doins docs/libcurl/libcurl.m4
+}
diff --git a/net-misc/curl/files/curl-7.30.0-prefix.patch b/net-misc/curl/files/curl-7.30.0-prefix.patch
new file mode 100644
index 000000000000..fd495c49b132
--- /dev/null
+++ b/net-misc/curl/files/curl-7.30.0-prefix.patch
@@ -0,0 +1,21 @@
+diff -Naur curl-7.30.0.orig/curl-config.in curl-7.30.0/curl-config.in
+--- curl-7.30.0.orig/curl-config.in 2013-02-06 09:44:37.000000000 -0500
++++ curl-7.30.0/curl-config.in 2013-04-17 18:43:56.000000000 -0400
+@@ -134,7 +134,7 @@
+ else
+ CPPFLAG_CURL_STATICLIB=""
+ fi
+- if test "X@includedir@" = "X/usr/include"; then
++ if test "X@includedir@" = "X@GENTOO_PORTAGE_EPREFIX@/usr/include"; then
+ echo "$CPPFLAG_CURL_STATICLIB"
+ else
+ echo "${CPPFLAG_CURL_STATICLIB}-I@includedir@"
+@@ -142,7 +142,7 @@
+ ;;
+
+ --libs)
+- if test "X@libdir@" != "X/usr/lib" -a "X@libdir@" != "X/usr/lib64"; then
++ if test "X@libdir@" != "X@GENTOO_PORTAGE_EPREFIX@/usr/lib" -a "X@libdir@" != "X@GENTOO_PORTAGE_EPREFIX@/usr/lib64"; then
+ CURLLIBDIR="-L@libdir@ "
+ else
+ CURLLIBDIR=""
diff --git a/net-misc/curl/files/curl-fix-gnutls-nettle.patch b/net-misc/curl/files/curl-fix-gnutls-nettle.patch
new file mode 100644
index 000000000000..fbacb7748bdc
--- /dev/null
+++ b/net-misc/curl/files/curl-fix-gnutls-nettle.patch
@@ -0,0 +1,27 @@
+diff -Naur curl-7.25.0.orig//configure.ac curl-7.25.0/configure.ac
+--- curl-7.25.0.orig//configure.ac 2012-04-04 17:24:48.000000000 -0400
++++ curl-7.25.0/configure.ac 2012-04-04 17:23:07.000000000 -0400
+@@ -1823,20 +1823,9 @@
+
+ if test "$GNUTLS_ENABLED" = "1"; then
+ USE_GNUTLS_NETTLE=
+- # First check if we can detect either crypto library via transitive linking
+- AC_CHECK_LIB(gnutls, nettle_MD5Init, [ USE_GNUTLS_NETTLE=1 ])
+- if test "$USE_GNUTLS_NETTLE" = ""; then
+- AC_CHECK_LIB(gnutls, gcry_control, [ USE_GNUTLS_NETTLE=0 ])
+- fi
+- # If not, try linking directly to both of them to see if they are available
+- if test "$USE_GNUTLS_NETTLE" = ""; then
+- AC_CHECK_LIB(nettle, nettle_MD5Init, [ USE_GNUTLS_NETTLE=1 ])
+- fi
+- if test "$USE_GNUTLS_NETTLE" = ""; then
+- AC_CHECK_LIB(gcrypt, gcry_control, [ USE_GNUTLS_NETTLE=0 ])
+- fi
+- if test "$USE_GNUTLS_NETTLE" = ""; then
+- AC_MSG_ERROR([GnuTLS found, but neither gcrypt nor nettle found])
++ AC_ARG_WITH(nettle)
++ if test "x$withval" = "xyes"; then
++ USE_GNUTLS_NETTLE=1
+ fi
+ if test "$USE_GNUTLS_NETTLE" = "1"; then
+ AC_DEFINE(USE_GNUTLS_NETTLE, 1, [if GnuTLS uses nettle as crypto backend])
diff --git a/net-misc/curl/files/curl-respect-cflags-3.patch b/net-misc/curl/files/curl-respect-cflags-3.patch
new file mode 100644
index 000000000000..4a4a614ee49a
--- /dev/null
+++ b/net-misc/curl/files/curl-respect-cflags-3.patch
@@ -0,0 +1,14 @@
+diff --git a/configure.ac b/configure.ac
+index e9b49c7..e374ab6 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -280,9 +280,6 @@ dnl **********************************************************************
+
+ CURL_CHECK_COMPILER
+ CURL_SET_COMPILER_BASIC_OPTS
+-CURL_SET_COMPILER_DEBUG_OPTS
+-CURL_SET_COMPILER_OPTIMIZE_OPTS
+-CURL_SET_COMPILER_WARNING_OPTS
+
+ if test "$compiler_id" = "INTEL_UNIX_C"; then
+ #
diff --git a/net-misc/curl/metadata.xml b/net-misc/curl/metadata.xml
new file mode 100644
index 000000000000..e0695ccfdf9a
--- /dev/null
+++ b/net-misc/curl/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+ <maintainer>
+ <email>gregkh@gentoo.org</email>
+ <name>Greg Kroah-Hartman</name>
+ </maintainer>
+ <use>
+ <flag name="http2">Enabled HTTP/2.0 support</flag>
+ <flag name="ssh">Enabled SSH urls in curl using libssh2</flag>
+ <flag name="metalink">Enable metalink support</flag>
+ <flag name="ssl">Enable crypto engine support (via openssl if USE='-gnutls -nss')</flag>
+ <flag name="rtmp">Enable RTMP Streaming Media support</flag>
+ </use>
+ <upstream>
+ <remote-id type="cpe">cpe:/a:curl:curl</remote-id>
+ <remote-id type="cpe">cpe:/a:curl:libcurl</remote-id>
+ <remote-id type="cpe">cpe:/a:haxx:curl</remote-id>
+ <remote-id type="cpe">cpe:/a:haxx:libcurl</remote-id>
+ </upstream>
+</pkgmetadata>